Problem Rf2 no bêta and public bêta

Discussion in 'Bug Reports' started by Christy, Jan 4, 2020.

  1. Christy

    Christy Registered

    Joined:
    Apr 22, 2018
    Messages:
    27
    Likes Received:
    5
    Hi,
    I have been pulling my hair out for 2 days, no longer able to launch Rf2. I posted on my usual forum, and people replied that I had the same bug and no longer use RF2 .... and I have no support!

    Here are 3 videos that I posted on my server, in order to show the problem well, I redid the launch actions several times in succession, in order to clearly see what is happening.
    I do not speak .. it is useless the images are there to show what is happening.

    video 1 shows you that this problem exists only on Rf2 and not on my other simulations on Steam.
    the other 2 videos show the problem.

    http://img.cd91.eu/RF2Problem/1.mp4
    video 2 :
    http://img.cd91.eu/RF2Problem/2.mp4
    video3 :
    http://img.cd91.eu/RF2Problem/3.mp4
     
  2. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,996
    Likes Received:
    1,341
    Video continuously buffers. Can't watch.
     
  3. Christy

    Christy Registered

    Joined:
    Apr 22, 2018
    Messages:
    27
    Likes Received:
    5
    very surprising here is what i have on my google explorer !
    If you do on each link of the video: right click (mouse) save the link as ... you will have it on your desktop.

    rf2.jpg
     
  4. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    @Christy All 3 links open video number 1.
     
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    @Christy OK, i have seen vid 2 now.
    Try this:
    Before you start the game, rename the folder
    ..\Steam\steamapps\common\rFactor 2\UserData
    into UserData_Backup for example.
    Then start the game.
    Does that help?
     
  6. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,996
    Likes Received:
    1,341
    Last edited: Jan 4, 2020
  7. Christy

    Christy Registered

    Joined:
    Apr 22, 2018
    Messages:
    27
    Likes Received:
    5
    Merci.
    Big hassle!
    I spent this 3rd day in trouble, and big problems
    - File deletion: userdata
    Last night, I thought the problem was solved, because RF2 launched and installed files and updates.
    And this morning RF2 started correctly. Except that after the steering wheel settings and screen settings, I only had crash bugs,malgré tout bien configuré.

    test in a car: the steering wheel, pedal, speed nothing worked!
    while in the options all is OK.

    I reinstalled version 1116, and again that problems that I had NEVER had before installing the public beta!
    I'm really mad at all this wasted time!
    there I no longer have patience ... I'm going to install Automobillista.
     
    Driver.The.WheelMan likes this.
  8. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    After installing the 1116 version again, have you again renamed/deleted the UserData folder?
    It seems that it is necessary on some systems, everytime someone switches between an old and new ui version of rfactor 2.
     
  9. Christy

    Christy Registered

    Joined:
    Apr 22, 2018
    Messages:
    27
    Likes Received:
    5
    Exactly the userdata folder has been deleted, but still a problem.
    I uninstalled RF2 and all the files in steam and then I did a beta installation again. - deleted the userdata folder.

    New problem:
    Rf2 launches then shows me an error:
    -Microsoft visual c ++ runtime library -> Runtime error
    And of course RF2 closes following this new error

    Contents of installed files

    cc.jpg

    Here short video :

    http://img.cd91.eu/RF2Problem/4.mp4
     
    Last edited: Jan 6, 2020
  10. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    1,996
    Likes Received:
    1,341
    Run all 4 vcredist files found in the Runtimes folder:
    :\Steam\steamapps\common\rFactor 2\Support\Runtimes

    For now don't worry about the new UI. Make sure you have opted out of the beta.
    "None" is what you want to see in the beta list.
     
    Last edited: Jan 6, 2020
  11. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    @Christy Yes, do what @ADSTA has said.
    Don't use any beta!
    Opt out of the Beta, then let steam verify your installation, then delete the UserData folder.
    Then start the game.
    If you still get the "-Microsoft visual c ++ runtime library -> Runtime error" messages, install the 4 files, as @ADSTA has said.
    If your computer specs are good enough, rfactor 2 should run properly.
     
    ADSTA likes this.
  12. Christy

    Christy Registered

    Joined:
    Apr 22, 2018
    Messages:
    27
    Likes Received:
    5
    Hello,
    I totally uninstalled Rf2 with all the files contained in steam / common / Rf2.
    I reinstalled version V1117 and now Rf2 works 100%.
    1) Question: Do I understand that the beta version and the new UI still have too many bugs, and that I have to wait for the normal new UI version to redo this installation?

    Thanks for your help :).
     
  13. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    What do you think, after all the problems that you have had with the new ui build? ;)
     
    ADSTA likes this.

Share This Page