Problem getting server listed...

Discussion in 'Technical & Support' started by rdmaudio, Oct 25, 2018.

  1. rdmaudio

    rdmaudio Registered

    Joined:
    May 26, 2016
    Messages:
    4
    Likes Received:
    0
    Hi everyone,
    I am having issues to get my server listed, I am installing the server in a different computer than my rig without the steam app running.

    To resume:
    1) I installed rf2 dedicated server following the steps in this guide https://steamcommunity.com/sharedfiles/filedetails/?id=553088396
    2) I opened the ports in my router and disabled all firewall features (at the router and windows)
    3) I generated my mod
    4) I runned the server but Matcher status is blank.

    I tried installing steam app (but not rf2)
    I tried changing the variable Binding IP at multiplayer.json to my local IP (and also public IP) nothing happend.
    I tried changing properties in rf2 dedi.exe shortcut "C:\rfactor2-dedicated2\rFactor2 Dedicated.exe" +path=".." +connect 192.168.1.22:64297

    I am really frustrated... I also tried to check on the ports if they where actually opened, with the link: https://www.yougetsignal.com/tools/open-ports/
    the thing is when rf2 dedi.exe is running the link detects ports 54297 and 64297 opened, but 64298 and 64299 closed. But all ports are open at the router.

    I really appreciated any help. My question will be is there any .json file or config to change I might be missing.
    Thank you!
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,794
    Likes Received:
    3,992
    Matcher Status is blank now. It's not really used anymore, don't worry about it.

    You can't use the +connect parameter when running the dedicated server - it's used when running the client to connect to the already-running server.

    Also, ports 64298 and 64299 are UDP. I think port scanners will always see them as closed, that's pretty much what UDP does (it will only get a response if rF2 answers, and it probably won't do that without a prior connection via TCP. I haven't actually tried this so I could be wrong, but I wouldn't worry about it for now)

    There has been suggestion in the past that to see your own server you should change the port down to 27013 or something, but for now you're better off seeing if someone else can see your server on the server list. I think the Matcher Status will show an error if something goes wrong, so it's probably fine. It can be harder to see it yourself than it is for others to see it.
     
  3. rdmaudio

    rdmaudio Registered

    Joined:
    May 26, 2016
    Messages:
    4
    Likes Received:
    0
    Thanks for your Reply... I Will check Changing port to see it un my LAN...
     
  4. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    448
    Likes Received:
    117
    What router are you using
     
  5. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,509
    Likes Received:
    743
    @rdmaudio To join my own server over lan, i use this line in the 'target' field of the shortcut to the launcher:
    "F:\Steam\steamapps\common\rFactor 2\Launcher\Launch rFactor.exe" +multiplayer +connect="127.0.0.1:64297"
    Adapt it to your Path and Port and try it out if it works for you too.
     
    rdmaudio likes this.
  6. rdmaudio

    rdmaudio Registered

    Joined:
    May 26, 2016
    Messages:
    4
    Likes Received:
    0
    It's a Ubee DVW32e
     
  7. rdmaudio

    rdmaudio Registered

    Joined:
    May 26, 2016
    Messages:
    4
    Likes Received:
    0
    Thanks I Will try it...
     

Share This Page