Poor performance and bad graphics

Discussion in 'General Discussion' started by 2ndLastJedi, Sep 6, 2020.

  1. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,263
    Likes Received:
    1,388
    @2ndLastJedi I can't really see any of the graphical problems. However, I agree that 30 FPS at race start with a 1080 Ti is low. I'd suggest a few things. Check if you can lower the number of visible opponents somewhat, it looks like there is at least 20 cars drawn in the Nürburgring screenshot. Secondly, check mirror settings. Your screenshots have more details visible in the mirrors than default, which suggests you have edited some mirror setting in player.JSON. I did this years ago as well, but noticed it had big performance costs for little extra benefit.
     
    2ndLastJedi likes this.
  2. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,639
    Likes Received:
    1,080
    These 2 recommandations are very good @2ndLastJedi
     
    2ndLastJedi likes this.
  3. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    Yeah I have 19 Ai and 20 cars visible and I think I did change the mirrors so will reset that and test again. I have since reduced visible cars to 15 but little change.
    I played a lot last night and started regretting making this thread because some tracks (Portugal and Sebring) did look pretty great and the Porsche Cup drove so sweet but I do get bad performance, I will reset my player. jsn file and retest.
    I do have issue with the shadow draw, aliasing and that night glow from the car liveries as seen in my screenshot though so this thread does have some merit.... But I do take back the "rF2 looks poor" points but only on some tracks, some do still look sad.
     
  4. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    I had a quick peek yesterday evening and now I know what you mean regarding Portland.

    Especially those fences and their shadows show some disturbing flickering when the camera (car) is moving.

    I guess, I never really noticed it before, because when driving, I usually focus on the road ahead and not so much on the surroundings... ;)


    AFAICT, this issue is not caused by the rF2 gfx engine, but the lack of resolution for those kind of fine details to be rendered into (triple-) FullHD.

    For a test I used nVidias DSR and let rF2 run in 3840x2160, scaled back down to 1920x1080 for matching my display.

    With all bells and whistles on, the image was a lot smoother and the flickering was reduced to a minimum.

    Obviously, this comes with a heavy performance impact, but I'll try to find a sweetspot for my GTX1070 SLI setup somehwere down the road.

    At least in private practic mode, I saw pretty constant vSynced 60 fps with some rare little drops below.

    Cheers!
    Max
     
    2ndLastJedi likes this.
  5. Paulus_NL

    Paulus_NL Registered

    Joined:
    Jul 28, 2019
    Messages:
    66
    Likes Received:
    34
    I'll see if i can post my settings today when i am home. Did some tweaks in the json, settings and nvidia to get a better and smoother image.
    Running 5860*1080 with a 1080ti and i7-7700K, 16gb RAM.

    First changes can be found in this post: https://forum.studio-397.com/index....-on-how-to-prevent-low-fps.61265/#post-961705
    Some gives you already a good FPS boost.

    Before i also had the issue with fences and the flickering of them.
    But now i got rid of it for 90% :)

    [​IMG]

    Some more examples/screens can be found on: https://www.flickr.com/photos/paulus_nl/albums/72157710015133612
     
    Last edited: Sep 9, 2020
    2ndLastJedi likes this.
  6. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    Thanks mate , i will apply those jsn tweaks and test while i wait for you full settings .
    Cheers mate .
     
  7. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    My performance problem was in game vsync !! I had it on video , so i turned it off and set it to adaptive in nvcp and it is totally smooth with full max settings , AAx5 ,PP medium and it looks great . Even in replays im getting 60 fps solid .
    20200909223857_1.jpg
    You cant see me but im eating my hat right now :eek:
    Thank you for all your help and advice .
    20200909223628_1.jpg 20200909223531_1.jpg
     
    Mauro, Max Dralle, mesfigas and 3 others like this.
  8. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    Even Sebring maxed out with 20 cars visible is only 80-90% GPU :eek: and i'm not even seeing the aliasing i was bitching about o_O 20200909231147_1.jpg 20200909230023_1.jpg 20200909230939_1.jpg
     
    Emery likes this.
  9. mantasisg

    mantasisg Registered

    Joined:
    Aug 17, 2016
    Messages:
    2,097
    Likes Received:
    2,912
    Great to know you have solved some problems you had !
     
    2ndLastJedi likes this.
  10. Paulus_NL

    Paulus_NL Registered

    Joined:
    Jul 28, 2019
    Messages:
    66
    Likes Received:
    34
    Awesome :)

    Option to make screenshots of the ingame settings? So other players can also try these etc :)
    And if there are changes done in the json file can you post them also?
     
    Emery likes this.
  11. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    Here is the player.JSON and launch config , in game i have everything maxed out and so far got solid 60 fps even at Sebring at low sun , i havent tried night racing yet . If there is a harder track to run let me know and i will try it .
    I changed the JSON to txt so i could upload it .
     

    Attached Files:

    Emery likes this.
  12. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,639
    Likes Received:
    1,080
    Your set "rearview clip = 65 meters" help probably a lot.

    For rain and other circumstances, I suggest you to set rearview particles to false.
     
  13. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    I set it to 65 because of post #45 from @Paulus_NL linked , was it that you think ? Okay i will test that at 1000 and see ;)
    I think i would prefer to have particles visible in the mirror .
    Im also going to test the "cull" false as well .
     
  14. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    Interesting... I wonder, if that would make a difference on my system as well.
    Do you monitors support variable refresh rates ?
     
  15. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,639
    Likes Received:
    1,080
    Honestlty when you drive even in VR you ALMOST don't see if particles false, cull or not, 70 meters like I set.

    But you can gain a lot of FPS, I have experienced it recently with GTX 1080 and Rift S.

    But for me smooth + driving realism + FFB is the most important, not the graphics.
     
  16. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,263
    Likes Received:
    1,388
    The cull setting is the main one that impacts FPS (true=default, objects culled, more FPS), I found less impact from distance itself.
     
  17. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    No variable refresh rate here .
    I have now set nvcp vsync to on instead of adaptive and it is still smooth . I am yet to test the mirror adjustments to see if it was that or the in game vsync . Will report back asap .
     
    Mauro likes this.
  18. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,709
    Likes Received:
    1,087
    I made clip to 1000 and cull to false and i'm still getting a lock on 60 fps so i have to believe it was the in game vsync !! Using nvcp vsync to on and all settings maxed with AA x5 and PP Medium with this player.JSON i'm very happy with rF2 performance now .
    Now if i can just work out how to stop the glowing Porsche Cup cars at night and the bright grass of Silverstone i will just look the other way from the shadow cascade and the AA doesn't seem as bad now i have no more stutters .
    Thanks for your help guys .
     

    Attached Files:

    Mauro and Max Dralle like this.
  19. enduser

    enduser Registered

    Joined:
    Feb 27, 2018
    Messages:
    124
    Likes Received:
    33
    Yea silverstone needs another udpate, other tracks too, nothing you can do with game settings.
     
    2ndLastJedi likes this.
  20. DrivingFast

    DrivingFast Registered

    Joined:
    Mar 1, 2018
    Messages:
    1,639
    Likes Received:
    1,080
    What I am going to say is not to contradict you but to help people who lack FPS on certain tracks that require more resources.

    I already had the rearview on "cull" and rearview particles on "false" (more stable FPS and fairly high gain on wet roads).....

    The fact of having forced rearview clip on 70 meters, I affirms, almost completely solved my performance problems on the only 3 tracks where I had some FPS issue : Portland, Nurburgring, Monaco.

    And even in VR, it's not annoying, while driving and enough to see the cars in the rearview.

    If it helps some.
     

Share This Page