Please help find my shadows...

Discussion in 'Technical & Support' started by marvelharvey, Apr 26, 2018.

Tags:
  1. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,093
    Likes Received:
    1,488
    Are you definitely on Build ID 2759516 ?
    (right click Rfactor2 in Steam, select Properties and then the Local Files Tab, Build ID number is on the bottom left)
     
  2. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    39
    Likes Received:
    4
    Yes Build 2759516
     
  3. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,093
    Likes Received:
    1,488
    Cool, can you please zip up your Config_DX11.ini & your player.JSON and I'll try and reproduce it, thanks. Also what Car & Track you're using.
     
  4. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    39
    Likes Received:
    4
    Here there are. It occurs at any car/track combo. And only in cockpit view. It's matter of cockpit lods for sure.
     

    Attached Files:

  5. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,093
    Likes Received:
    1,488
    With your files I'm seeing the same Shadow Drawing distance (cockpit view) in 1109 and latest Build of 1110, if you haven't already try clearing CBASH & Shaders folders plus start with a fresh player.json file just in case something got screwed up somewhere at some time.
     
  6. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    39
    Likes Received:
    4

    Yes, I allready did that, fresh everything at the same time, same short shadow LOD. Maybe this is normal, can someone with right shadow cockpit lod put some screenshots? Maybe it is normal.
     
  7. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    308
    Likes Received:
    109
    Just to reiterate, this is happening on a fresh Windows 10 install, with only Steam and rF2 downloaded. No other drivers installed or hardware attached. I even tried it with only Suzuka and the Skippy packages.

    If it's happening on fresh windows, then it seem like a hardware issue... but there's no hardware commonality between the posters in this thread. And anyway, why would our RAM/CPU/GPU/Motherboard know or care if the game was being rendered from cockpit or rollbar cam?

    So it's back to being a software issue? But why does it happen on a fresh install of Windows?

    I thought perhaps it could be because I'm running a non-English version of Windows (Japanese), but I tried on my work computer (also Japanese Windows) and rFactor2 ran fine... albeit at 1fps.

    This has me totally stumped.
     
  8. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    308
    Likes Received:
    109
    Seems to be just us. Christoper Elliot (+ a few others I know) tried my .json and .ini files and had correct shadow lengths.
     
  9. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    2,871
    Likes Received:
    958
    I doubt hardware issue, the game does not even care what motherboard etc. you use, it all works through OS and drivers. GPU drivers possibly.
     
  10. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    Any official word on it? This problem is real and irritating.
    For me it happens on all cameras.
     
  11. Travis

    Travis Registered

    Joined:
    Dec 7, 2012
    Messages:
    104
    Likes Received:
    76
    I am wondering about the last 2-3 months of Nvidia driver releases which have been very mixed in regards to performance and stability. Many of the 10 series cards have specific issues too, notably the 1060 GPU's however issues may occur to & with the higher spec 10 series cards.

    Has anyone tried a driver rollback? It is a longshot but may be worth trying. The 391.35 drivers were the last "approved" drivers on the Nvidia Reddit forum.

    As I know there are forum members who demand specific proof to my type of posts, here is a link to the latest driver test: https://www.reddit.com/r/nvidia/comments/8j8k4q/39764_whql_driver_performance_benchmark/
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,216
    Likes Received:
    1,454
    So is Christopher (and the other people) seeing no difference in shadow distance when switching between cockpit and 't-cam' view?
     
  13. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    Same problem with 391.95
     
  14. xzess

    xzess Registered

    Joined:
    Oct 5, 2010
    Messages:
    39
    Likes Received:
    4
    It is a bug or feature, in shadow LOD bias in cockpit camera, maybe in other cameras to other users. It's not hardware or windows related.
     
  15. Travis

    Travis Registered

    Joined:
    Dec 7, 2012
    Messages:
    104
    Likes Received:
    76
    It was a long shot that didn't work.

    I have zero problems so I feel for those who do have the shrinking shadow issue.
     
  16. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    2,871
    Likes Received:
    958
    You should post a screenshot because it might not be a bug at all and the way it's intended on all systems, just some users are more sensitive to noticing it. Or if it's a bug, it needs to be narrowed down...
     
  17. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    Imagine the screenshots of op are mine. Its exacly the same situation.
     
  18. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    What a shame there is no official word on this topic so we can have hope they are looking on the problem. I'm was almost to give up and stop playing RF2 because this shadows problem.
     
    Last edited: Jun 13, 2018
  19. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    Unbelievable! I did a Windows 8.1 clean installation trying to fix this problem and after install Nvidia driver 384.94 on that system the shadows distance are back to normal. Finally...now i must have a way to stop windows from update nvidia driver version. Must try 384.94 on Windows 10 too. Fingers crossed.
     
  20. Frankalexandre

    Frankalexandre Registered

    Joined:
    Jan 3, 2012
    Messages:
    99
    Likes Received:
    13
    Confirming, 384.94 solved the low distance rendering shadows on Windows 10 64 too.
     

Share This Page