SOLVED PitGroup problem

Discussion in 'Bug Reports' started by Imre Bende, Sep 15, 2021.

  1. Imre Bende

    Imre Bende Registered

    Joined:
    Jan 30, 2012
    Messages:
    175
    Likes Received:
    194
    Hello,

    I made some mods, and the pitgroup order worked fine. So far.

    Now, the pitgroup order is ok in offline, but online is randomly works.

    offline, the cars are that box what's in veh file (PitGroup=)
    online this is random, some cars are out of pitlane, teammates (same pitgroup) isn't in same box

    Important. We were 19 on the race, so was enough box

    OFFLINE
    20210915101243_1.jpg 20210915101245_1.jpg

    ONLINE
    20210915102146_1.jpg 20210915102139_1.jpg

    rFm file is ok, pitgroups are in the file

    PitOrderByQualifying = false
    PitGroupOrder
    {
    PitGroup = 2, Group1
    PitGroup = 2, Group2
    PitGroup = 2, Group3
    PitGroup = 2, Group4
    PitGroup = 2, Group5
    PitGroup = 2, Group6
    PitGroup = 2, Group7
    PitGroup = 2, Group8
    PitGroup = 2, Group9
    PitGroup = 2, Group10
    PitGroup = 2, Group11
    PitGroup = 2, Group12
    PitGroup = 2, Group13
    PitGroup = 2, Group14
    PitGroup = 2, Group15
    PitGroup = 2, Group16
    PitGroup = 2, Group17
    }

    What is it?

     
  2. Jimmi Allison

    Jimmi Allison Administrator Staff Member

    Joined:
    Apr 2, 2011
    Messages:
    1,186
    Likes Received:
    1,002
    the .veh obviously need to know what pitgroup to use, otherwise it will be random
    So team 1 both need to be "told" pitgroup=1, team 2 needs: pitgroup=2 etc.
     
  3. RoWo

    RoWo Member

    Joined:
    Jul 16, 2014
    Messages:
    450
    Likes Received:
    484
    I think, he know this already. But still doesn't work, it seems. We also experienced this in our leagues. It sometimes work, sometimes not.
     
  4. Jimmi Allison

    Jimmi Allison Administrator Staff Member

    Joined:
    Apr 2, 2011
    Messages:
    1,186
    Likes Received:
    1,002
    Never had this when its done correctly in the .veh files and if there is enough pitboxes. Perhaps track is causing an issue, perhaps parking is assigned. But first its not clear if pitgroups in veh is correct, at least from what i can read/understand.
     
  5. Imre Bende

    Imre Bende Registered

    Joined:
    Jan 30, 2012
    Messages:
    175
    Likes Received:
    194
    The Pitgroups are correct.
    10 teams, 20 cars, 10 box, not too complicated

    The veh file is correct:
    upload_2021-9-15_14-43-40.png

    I tried more circuits, the problem is same. In offline is ok, online is wrong.

    If i made mistake, i can see it in offline, but its ok
     
  6. Jimmi Allison

    Jimmi Allison Administrator Staff Member

    Joined:
    Apr 2, 2011
    Messages:
    1,186
    Likes Received:
    1,002
    Parking on server?
     
  7. Javibeza

    Javibeza Registered

    Joined:
    Oct 5, 2010
    Messages:
    47
    Likes Received:
    49
    Hi!
    It could be "assign parking" parameter in multiplayer.json.
    It must be set to false.

    Also, if the circuit has three garages per team, I've observed garage places order inside the same team are assigned kind of randomly, so maybe this place under the tents could be the 3rd garage places of the correct team garage.
     
  8. Imre Bende

    Imre Bende Registered

    Joined:
    Jan 30, 2012
    Messages:
    175
    Likes Received:
    194
    its working. thanks!
     

Share This Page