[REL] Pista del Mare 0.98

Discussion in 'Locations' started by qusimano, Jun 7, 2018.

  1. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Hi guys, I made this little kart track and now it's time to share the first version.

    https://steamcommunity.com/sharedfiles/filedetails/?id=1415069338&searchtext=

    [​IMG]
    [​IMG]
    Situated in Tuscany (Italy) near the city of Cecina, Take his name by the Mediterranean sea that is just over the pinewood: In fact "Pista del Mare" means "Track of the Sea":eek:
    here is a video of an old version, now it's a bit better:cool:
    https://www.dropbox.com/s/m1xoonjfyudk4o6/comparison.mp4?dl=0

    feel free to contribute with hints and advice if you see something strange.
    I want to say thanx to all the guys here, Coutie, Bernd, JKA, and many others, SPASKIS for his great tutorial and ISI\ S397 for the textures and some of the objects that i borrowed for make this track.
     
    Last edited: Apr 19, 2020
  2. Sebastien Sestacq

    Sebastien Sestacq Registered

    Joined:
    Jan 11, 2016
    Messages:
    829
    Likes Received:
    1,364
  3. AMillward

    AMillward Registered

    Joined:
    Apr 4, 2017
    Messages:
    1,669
    Likes Received:
    1,576
    This looks like a lot of fun!
     
  4. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    567
    Likes Received:
    676
    lol thx mate. Good job
     
    pkelly likes this.
  5. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    thx for the kind words guys, i updated the first post with link for the workshop item :eek:
     
    Corti, Steve76 and Sebastien Sestacq like this.
  6. Frank Orchand

    Frank Orchand Registered

    Joined:
    Jan 2, 2018
    Messages:
    4
    Likes Received:
    1
    I like this track but I have an issue. With ISI kart mod or with Kartsim mod, the ai only do 2 laps in practice and qualify session and then stop on track due to out of fuel. I have only this issue with track. How can I solve it ?
     
  7. Jka

    Jka Member Staff Member

    Joined:
    Jan 31, 2011
    Messages:
    921
    Likes Received:
    184
    That is probably caused by missing/wrong fuel calculations on track's AIW. Track author can fix that.
     
  8. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Hi, i'm trying to replicate the issue on my pc, but it seems to be normal here, with the Ai driving 8 or 9 laps in practice, then entering in pit, same goes for qualify, but i need to make deeper investigations.
    What i can see in a 20 lap race, is that the karts need to pit for refuel, and they do it.
     
    memoNo1 likes this.
  9. Frank Orchand

    Frank Orchand Registered

    Joined:
    Jan 2, 2018
    Messages:
    4
    Likes Received:
    1
    Hi, I did some additional tests. It seems not to be a refuelling issue, but the Ai lap time are not recorded. They stay in the status "outlap" (blue) even if the laps count is incremented. In some exceptions cases, one or 2 Ai record a lap time.
     
  10. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Thx for helping me to sort out the problem,I have noted the same thing, but i also noted that it's working in race, counting all the laptimes of all Ai, so im not sure what is wrong here. Surely @Jka he's right when he point to an AIW error, I read something about cars stopping out of fuel when the track it's originally made with bob track Builder, wich is the case here..
     
  11. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    I've found that for some strange reasons the cars are "not able to leave the pits". Reading a Rf2 log Analyzer report from practice or qualifing, all the ai cars has the "pitlane" status on every lap. They are able to leave the pit and drive the track, but none of the lap are recorded, just some ai can score some laptimes sporadicaly.
    One thing that i have noted is that the ai follow a slightly different path exiting the pitlane, in comparison to my kart, when is drived by the A.i
    If i let drive my car to the Ai it can do all the laptime i want.
    I think this is not happening in race beacause the cars are teleported on the track, so there is no transition from pitlane to track.
    if you press "finish session" in practice or qualy, most of the Ai have laptimes, but i know there is not a solution, as they will be some second faster then normal.
    The solution is to redo the AIW completely i think, i have already tried but im encountering some strange problem that i need to investigate bettero_O:oops::eek:
     
  12. t0p5ecret

    t0p5ecret Registered

    Joined:
    Feb 11, 2012
    Messages:
    643
    Likes Received:
    1,417
    Mate I will happily take a look at this if you like?
     
    pkelly likes this.
  13. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Sure! thx in advance, i send you a pm now;)
     
  14. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Thx to @Bernd the problem is identified: xpitout mesh facing into the wrong direction!
    I just need to read a tutorial on how to update a steam workshop item and then all will be fine;)
    Also thx to you @t0p5ecret, i appreciate your willing to help, anyway if you like to take a look on the aiw youre welcome;)
     
    davehenrie likes this.
  15. Frank Orchand

    Frank Orchand Registered

    Joined:
    Jan 2, 2018
    Messages:
    4
    Likes Received:
    1
    Thx a lot guys ;)
     
    pkelly likes this.
  16. qusimano

    qusimano Registered

    Joined:
    Oct 11, 2012
    Messages:
    163
    Likes Received:
    60
    Hi
    I've Updated the workshop item:)
     
    deceda likes this.

Share This Page