NEED INFO Odd Green tint colours Online Only, but Single Player is fine.

Discussion in 'Bug Reports' started by DJCruicky, May 11, 2022.

  1. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    Graphics are different Online to Single player.

    We run online races in our league.
    We sometimes get this odd glitch where the colours of the track and car has a slight green tint, sometimes yellowish online, single player is normal.

    We do run a lot of older content in our league so it is forgiving some tracks might not be brought up to the latest standards, but my big question here is why does the track look fine in Single player but not Online?
    This does not effect everyone in our league, about 50% of us see it.
    We have ruled out the car, it happens on more than one car we have run.
    I've made sure when testing in single player I've used the same time of day and weather settings as the server, and also same graphics settings.
    Tracks that we have seen this on so far are 1966 Monte Carlo, Mills Metro Park, Zolder79, Mexico1966.

    I made a video to show problem, this is at Mexico1966...


    Some pictures:

    Online:
    20220405221535_1.jpg
    Single Player:
    20220405222252_1.jpg

    Online:
    20220426181738_1.jpg
    Single Player:
    20220425222206_1.jpg
    Even the colour of the car has changed too.

    Odd thing also, when watching a replay from a online race (from the main menu) the colours are back to normal again.
    I've tested with 2 different graphics cards in my machine and get the same.
    Anyone else seen this odd glitch in online races or is it just our league?
     
    Last edited: May 16, 2022
    Edvvc and Mauro like this.
  2. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    I forgot to say we not running any filters like Reshade or anything.
     
  3. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,060
    Likes Received:
    1,557
    It's probably something with the IBL probe. I know in the past, on a third party track, the probe was placed too close to something that was yellow, and turned everything yellow. But I don't even know if old Monaco has been updated for IBL.
     
  4. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    Thanks for reply @Coutie

    Monaco

    has no Probe, it's 10 years old.

    Mexico1966
    is not a IBL track but it does have a Probe that looks like this....
    IRRADIANCE_PROBE=IRRAD_GLOBAL
    {
    INFLUENCE_RANGE = (0.0)
    PROBE_POSITION = (0.0,0.0,0.0)
    }

    Zolder79
    has some IBL materials and does have a Probe that looks like....

    IRRADIANCE_PROBE=IRRAD_GLOBAL
    {
    INFLUENCE_RANGE = (0.0)
    PROBE_POSITION = (-33.299,3.000,-128.100)
    }

    Problem only online and not single player.
     
  5. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    This one is from todays online event. Different car and track to the above.

    Top screen Online race recorded live, and bottom screen is a direct recording of the replay file of same race.

    Feel free to pause the video at any point.

    The event we had last week and the week before that was fine, so it's very depending on the track we choose.
     
  6. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    514
    Likes Received:
    3,258
    Global IBL probe is required now to have correct lighting & color rendering (and color changes depends on clouds & time of the day), even if the track is not using IBL shader. Lacks of global IBL probe (or not set at correct position) will cause color tint & bad lighting in both singleplayer & multiplayer. This can be easily tested in DEV mode with exact same amount clouds & time condition.

    Same thing with static01 reflectionmapper, that many tracks lacks of, which is causing many visual issues.

    Edit: in following post link you can see the old version of oulton park that I had taken 2 screenshots for comparison:
    https://forum.studio-397.com/index....lashy-now-with-pbr-update.68932/#post-1088598
    One with global IBL probe, one without, under exact same clouds & sky & time condition. Green tint can be easily observed on none-probe screenshot.

    Edit2: I think maybe developer could consider to add a global probe to track while loading, if it is not found in track's SCN file. Maybe this can be done by using first starting grid position value recorded in AIW file, so it will be surely above race surface.
     
    Last edited: Jun 2, 2022
    Mauro and philrob like this.
  7. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    The important part of this thread is to ask why it just happens in multiplayer only. Whether the track maker has updated his track with probes or not, it's still not clear why it looks different between single player and multiplayer.
     
    Edvvc likes this.
  8. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,903
    Likes Received:
    1,854
    Have you checked if the conditions are the same? (Sun, clouds, hour, etc)
     
  9. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    Yes
     
    lagg likes this.
  10. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    906
    Likes Received:
    571
    We've had the same thing happen on a few tracks on our server as well. Usually older tracks and only in multiplayer.
    I was thinking it might be something in the scr that gets drawn (or doesn't) when in multi. So maybe similar to how at practice there are only a few spectators but in the race there are more drawn. (on some tracks) ??
    Just a thought, haven't really looked into it that deeply. :)
     
    Mauro and lagg like this.
  11. Coutie

    Coutie Moderator Staff Member

    Joined:
    Oct 5, 2010
    Messages:
    3,060
    Likes Received:
    1,557
    If it only happens with old tracks, it probably won't be a priority to fix. But I'll make a report about it anyway.
     
    McFlex, svictor, lagg and 2 others like this.
  12. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    Can you remember what track(s), I will give it a test. Cheers :).
     
  13. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    906
    Likes Received:
    571
    @DJCruicky

    Nemuno
    Killarney
    were a couple of them from memory.
     
    DJCruicky likes this.
  14. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    571
    Likes Received:
    253
    Vancouver street circuit is another with the exact same problem, I had race online some weeks ago.
     
    DJCruicky likes this.
  15. MileSeven

    MileSeven Registered

    Joined:
    Apr 1, 2014
    Messages:
    403
    Likes Received:
    157
    Keeper (SR4L) has reported Rouen as a problem online on a non-SR4L hosted server.
     
    DJCruicky likes this.
  16. Franek Godrecki

    Franek Godrecki Registered

    Joined:
    Jun 22, 2022
    Messages:
    1
    Likes Received:
    1
    Hello, we are having the same issue on Rouen-Les-Essarts online. It does not happen with exactly the same track / weather / car settings offline.
    [​IMG]
    As you can see everything has an unnatural greenish tint, HUD appears to be unaffected only the elements of the scene.
     
    DJCruicky likes this.
  17. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    I can add the S397 track Malaysia 2007 to the list of tracks with the problem. Malaysia is the next event we are running at SR4L. This one has a yellow tint online.

    Online
    20220628000001_1.jpg
    Offline
    20220628000707_1.jpg

    There is also the 3rd party track Ahvenisto with the green tint online also.

    Thanks for reporting other tracks guys.
    Shame about Nemuno, we raced that track last year, it was great.
     
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,836
    Likes Received:
    3,405
    again old tracks, possibly not updated to all the latest tech. Malaysia is more of an ISI track, although S397 did buy the content, but they have not done anything with almost all the ISI stuff.
     
    ebeninca likes this.
  19. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    588
    Likes Received:
    577
    Hi,
    We have reproduced this internally, and have raised an issue for it.
     
  20. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,343
    Likes Received:
    586
    Good stuff, thank you.
     

Share This Page