Nvidia users: Better visuals at the same performance? Yes! And YOUR help is needed!

Discussion in 'General Discussion' started by Robert Gödicke, Mar 30, 2014.

Thread Status:
Not open for further replies.
  1. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    EVERY SINGLE VOICE COUNTS! If you want it, please invest 3 minutes of your spare time to write a post in the Nvidia forums (details in this post). When everyone expects that "others will do this, I don't need to" to fix that issue, we won't make it! Please do those who want that feature back a favor by reading this post and posting in Nvidia's forums!
    YOUR help is needed! Thank you!


    Ok, how do I start? I believe most of you guys didn't read through all the posts of these threads:

    http://isiforums.net/f/showthread.php/18712-IS-NVIDIA-Image-Quality-A-Joke-Or-Is-It-Just-Me
    http://isiforums.net/f/showthread.php/18761-ALT-M-in-game-and-or-working-plr-entry
    http://isiforums.net/f/showthread.p...-change-adjust-it-(NVIDIA)-setting-not-broken

    That may be due to the sheer amount of text or the usage of tons of technical terms in said threads. Noone is supposed to know what every single function of their graphics card does or what all the abbreviations actually stand for. But images say more than a thousand words, so let me just provide two screenshots first to get your attention:

    You can increase your visual quality in rFactor 2 and rFactor 1 from this:
    [​IMG]

    to this:
    [​IMG]

    Left click on those images to see the full resolution screenshots and notice the differences in the power lines in front of the sky! This also applies to the white track markings you see as jaggies in pretty much every rFactor 2 track! They will be fixed as well, no more breaks in the lines, no more flickering!
    Now the best thing is: This comes with no performance loss at all! But there's one issue... Nvidia removed this functionality for newer GPUs, and that's where we need to make our voices heard...




    To make it short, Nvidia removed a feature for newer graphics cards which was working flawlessly before on older GPUs. Most of you probably know what Anti-Aliasing is. This is a method to get rid of jaggies (a form of Aliasing) in a 3D application, most noticeable on edges of 3D objects, like our car models in rFactor 2 for example. There are different methods though which provide different levels of visual quality at different impacts on performance. The better the visuals, the lower your fps.

    What most people don't know is that there are different kinds of Aliasing. The methods we know as Anti-Aliasing usually only address the jaggies we see on the edges of 3D objects (like the standard Multisampling method or the Anti-Aliasing levels you can choose in your Rfactor 2 Configurator). However, there is also Aliasing caused by too sharp texture filtering (see the first screenshot, the power lines in front of the sky!), and our Anti-Aliasing methods will not address these at all! Not Multisampling, Supersampling, Sparse Grid Supersampling, a combination of them, nothing! They can only make them less noticeable, at the cost of a much, much, much lower performance and higher input lag.

    Nvidia has a setting in their Nvidia Control Panel which actually should address these issues though. It's called "Texture filtering - Negative LOD bias", and setting this to "Clamp" should give you the visual quality you can see in the second screenshot above. However, this functionality apparently does not work anymore in DirectX applications for Nvidia GPUs from the GTX4xx series onwards, which means the last graphics cards which are using that setting was the GTX2xx series, which is obviously way too outdated to run rFactor 2 reasonably. The reason for removing this feature from Nvidia apparently was "Most users didn't understand what this feature was doing anyway".

    I was fairly surprised after upgrading from a GTX285 to a GTX770 to see that I am not able to get the same visual quality from my old GTX285 anymore. I could get a little closer using intense levels of Sparse Grid Supersampling, but at a much lower framerate than on my 5 years old GTX285 and still with worse visuals! You can see the comparisons here, I didn't know back then that Clamp wasn't working anymore on my GTX770:

    http://isiforums.net/f/showthread.php/16536-Antialiasing-GTX285-vs-GTX770



    But what can we do? Well, it's simple: We need Nvidia to understand that we need that feature back! I've already put a link in a thread here in the ISI forums to the Nvidia forums where we can ask for the feature to be working again on our shiny new graphics cards, but so far the only I recognized who was from the ISI forums was DrR1pper. We need more simracers to be heard though!

    Please help to get it working again, when there are only 1 or 2 people posting, there's a very little chance we will get any attention. But if there are more and more people posting, then maybe Nvidia will realise that it would be a good idea to re-activate that feature for us simmers! Spread the word!

    Greez Rob
     
    Last edited by a moderator: Apr 4, 2014
  2. Knight of Redemption

    Knight of Redemption Registered

    Joined:
    Jun 23, 2012
    Messages:
    882
    Likes Received:
    56
  3. Golanv

    Golanv Registered

    Joined:
    Nov 7, 2012
    Messages:
    1,042
    Likes Received:
    9
    I wannit !!!
     
  4. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    Thanks guys. :)
     
  5. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    561
    Likes Received:
    212
    Is this an issue with other games as Well or is it an issue because rf2 is perhaps using old tecnique that everyone Else has moved away from and therefore nvidia does not support it anymore? It seems Strange that nvidia has decreased graphics quality so maybe its isi that has to change something? Either Way i hope it gets fixed owning a gtx770.
     
  6. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    It helps with a lot older games yes, I am not playing too many different games at the moment, so I don't know if some current games would benefit from a working clamp setting, but I doubt it.
    If you want it to be fixed for rFactor 1 and 2 as well as for some other games, feel free to post in their forums. Link is in the first post of this thread. :)

    The more people post in Nvidia's forum about this, the more likely they'll re-implement this feature.
     
  7. Mibrandt

    Mibrandt Registered

    Joined:
    Apr 4, 2013
    Messages:
    561
    Likes Received:
    212
    Have anyone asked isi if they could make it better? I mean nvidia is a Big Company and isi small dev so maybe it makes more sense that isi makes Their game look good with the new gpus and not old ones?

    Edit. Just posted a +1 in GeForce forum
     
    Last edited by a moderator: Mar 30, 2014
  8. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    Well, if Nvidia would re-implement the feature, it would help with other (older) games too. So instead of having a lot of different game companies fixing their titles, why not provide a fix for all of them via the graphics driver) :)
    This feature is available in the Control Panel after all - it just doesn't work anymore.
     
  9. Ivan Baldo

    Ivan Baldo Registered

    Joined:
    Oct 7, 2010
    Messages:
    57
    Likes Received:
    1
    I am not on Windows right now and too lazy to reboot (sorry), but I don't have that problem and I have a GTX650Ti BOOST.
    There is an option called Transparency Antialiasing that by default is off (ugly) but you can put in Multisampling (my recommendation) or Supersampling (too slow with little benefit).
    Don't confuse with FXAA or the other options for antialiasing, this one works at the texture level pixel by pixel.
    If you don't find that option then let me know and I will reboot in Windows, upgrade my drivers (months since I don't update them), and then see if the option is still there, maybe I can even take a screenshoot and highlight it for you though it will be in spanish, but by the position of the options it could be helpful anyway.
    Bye.
     
  10. DurgeDriven

    DurgeDriven Banned

    Joined:
    Mar 20, 2012
    Messages:
    6,320
    Likes Received:
    42
    I believe in Nvidia engineering way back when I read about it is the way DX10 changed things.

    They even mentioned something along the lines ..... " yes , in some old games there could be reduced quality "

    Same thing happened with DX9 cards and XP, suddenly DX6/7/8 sims looked off. :)
     
  11. Joe Campana

    Joe Campana Member

    Joined:
    Jan 19, 2012
    Messages:
    129
    Likes Received:
    2
    Probably a much simpler and saner solution would be for me to just add a plr file option to make the alt-M toggle selectable from the UI, and sticky.
     
  12. nipzon

    nipzon Registered

    Joined:
    Dec 23, 2011
    Messages:
    242
    Likes Received:
    34
    +1 from me, thanks for your effort
     
  13. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    This has nothing to do with Transparency Antialiasing sadly Ivan, the flickering white lines, fences etc. are not fixed using that - neither in the *.plr nor in Nvidia's Control Panel or the Nvidia Inspector. It's the filtering of the textures, not the rasterization of the image.

    In the thread I linked a guy called Guzz posted a modified driver which apparently has the clamp feature working for newer GPUs (i didn't try it yet, but his d3d9.dll worked as well, so I believe his driver will probably work too), so it shouldn't be too hard for Nvidia to fix this actually. To be honest I believe it's as easy as flipping a switch, just re-activating that feature. With the same driver, Clamping the negative LODs works on older GPUs. So it's probably something like "IF (graphics card >= GTX4xx) THEN (Clamp = disabled)"...

    If a user can fix it in the driver as fast as he apparently did, it should be no effort whatsoever for Nvidia to repair their drivers. And to be honest I don't see a reason why current GPUs shouldn't support a simple texture filtering setting.

    That would be much appreciated Joe, especially if Nvidia decides not to re-activate the Clamp feature. But without Nvidia fixing their drivers, rFactor 1 will still be extremely aliased since it doesn't have an Alt+M feature... :(
    Besides that, I play some other games which would benefit from that too. I think it would be easier if Nvidia listens and fixes this setting. :)
     
    Last edited by a moderator: Mar 31, 2014
  14. joker68

    joker68 Registered

    Joined:
    Jan 12, 2012
    Messages:
    54
    Likes Received:
    5
    I'm running with LOD bias clamp using NVIDIA Inspector. It works really fine here. GTX660. No need to wait for Nvidia change anything.
    View attachment 12173
     
  15. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    You are using Sparse Grid Supersampling which makes this issue less noticeable. Try running rFactor 2 with Multisampling only - Clamp shouldn't work, and if it doesn't, you should get a lot of aliasing.
     
  16. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    646
    Likes Received:
    31
    Hmmm ..I seem to have the feature as well in my 780ti stock NVIDA Control Panel list ,it shows as> 'Texture filtering-negative LOD bias' I can set it to "CLAMP", "Allow" or "Use global setting clamp" with the drop down that appears when selecting it , I set mine to 'clamp' and use alt-M in game it rely smooth's things out , it looks like your 2nd pic as far as wires ,chain link fences , tips of trees ect.. ! are you thinking this setting is not working ? I can see the deference's in the 2 settings clamp or allow on my end ...

    strange .. heh ...
     
  17. Robert Gödicke

    Robert Gödicke Registered

    Joined:
    Oct 5, 2010
    Messages:
    410
    Likes Received:
    11
    Yes, the setting is still in the Control Panel, but it is not working on all newer cards than a GTX2xx card I was able to test so far. You wrote that you are setting it to clamp AND use Alt+M additionally. A working clamp setting makes Alt+M redundant, So you shouldn't see any difference at all when pressing Alt+M ingame while having your driver set to clamp. Is that the case? Everything's smooth including white track markings/lines, fences, powerlines etc. without using Alt+M and without Supersampling?
     
  18. kro388th

    kro388th Registered

    Joined:
    Jan 10, 2012
    Messages:
    646
    Likes Received:
    31
    strange then , mine is set to clamp but I can clearly see the deference when I toggle alt-m on the fences, wires ect... maybe the clamping in the nvid ctrl pnl is doing nothing? anyway it looks a lot better with alt-m ! ;-)
     
  19. Dnelpm

    Dnelpm Registered

    Joined:
    Dec 14, 2012
    Messages:
    5
    Likes Received:
    2
    I installed the modified driver from the nvidia forums and it did the trick. It looks like when alt+M is enabled, I can't see any difference toggling it on and off.


    Enviado desde mi iPhone con Tapatalk
     
  20. Knight of Redemption

    Knight of Redemption Registered

    Joined:
    Jun 23, 2012
    Messages:
    882
    Likes Received:
    56
    Sounds like a great idea Joe. :)
     
Thread Status:
Not open for further replies.

Share This Page