Nvidia SLI - Possible big framerate improvement.

Discussion in 'Technical Archives' started by ForthRight, Jul 18, 2013.

  1. C3PO

    C3PO Member

    Joined:
    Aug 31, 2012
    Messages:
    1,038
    Likes Received:
    60
    No problem here with multiview off - for me it looks distorted with it on. Of course multiview is lower, but it so happens that I think it looks worse.
     
  2. Stephen Bacchus

    Stephen Bacchus Registered

    Joined:
    Sep 12, 2012
    Messages:
    29
    Likes Received:
    1
    Edit: Scratch what I just wrote, thought this had solved my problems with SLI 780's but got into a race and realised that multiview hadn't applied. Still broken :( Shame as it used to run OK on my xfire 7970's.
     
    Last edited by a moderator: Aug 27, 2013
  3. Stephen Bacchus

    Stephen Bacchus Registered

    Joined:
    Sep 12, 2012
    Messages:
    29
    Likes Received:
    1
    SLI testing

    Carried out some testing this evening, any thoughts welcome on how I might improve matters. PC specs in my profile, testing done by sitting in the garage at MMP in the Megane, sunny weather, FOV 31. All graphics options maxed including level 8 AA and FXAA on.

    Nvidia RF2 profile
    5760*1080 | Multiview On | 23 FPS | GPU usage on both around 45-55%; CPU usage normal (spike was on taking screen shot of task manager)
    5760*1080 | Multiview Off | 44 FPS | GPU usage on both around 45-55%; CPU usage normal (two spikes shown were on exiting sim)

    Tweaked RF2 profile - SLI Compatability bits set to 0x00500005
    5760*1080 | Multiview On | 5 FPS | GPU usage on both around 45-55%; Spikes on 2 CPU threads up to 85-95%
    5760*1080 | Multiview Off | 96 FPS | GPU usage on both around 95%; CPU usage much more consistant than with multiview on, appears to be making good use of all available threads (4 core 8 thread CPU - Intel i7 3820 @ 4.5Ghz)

    Link to CPU&GPU utilisation graphs

    Misc: Noticed that multiview doesn't seem to perform bezel compensation for you (unlike iracing) and it only looked correct when resolution was set to 5900*1080.

    As you can SLI works great if using the tweaked profile without multiview, under any other condition it doesn't.
     
  4. Bart S

    Bart S Member

    Joined:
    Oct 5, 2010
    Messages:
    685
    Likes Received:
    24
    FXAA on is not max settings infact turn FXAA off right now, its a crime to try and use level 8 AA and FXAA. FXAA blurs your textures, you will loose sharpness and detail.

    For a start to get best visual quality for little more fps cost please see my guide here, my guide still needs a bit of refining and updating but basically it is almost the same to what I use now. The main thing is to not use AA ingame but in nVidia inspector and to include sparse grid super sampling.

    There are a whole load of SLI compatability bits to try in the list within nVidia inspector. I would start by going through all the driving/racing ones you can find. Remember to save changes in inspector then restart the game to see changes, they wont be set while the game is running.
     
  5. Stephen Bacchus

    Stephen Bacchus Registered

    Joined:
    Sep 12, 2012
    Messages:
    29
    Likes Received:
    1
    Thanks for your suggestions Bart, I've had a break through but feel there is more to come.

    Played around changing various settings in the profile and ended up setting it so that it is the same as the base profile. Changes from the Nvidia profile for RF2 were:

    Compatability bits: 0x00000000 | Predefined GPUs on SLI rendering: Autoselect | Predefined SLI mode: Autoselect
    5760*1080 | Multiview On | 51 FPS | GPU usage on both around 95%; CPU usage normal (max settings bar FXAA off)

    Doing a lap of the circuit lowest FPS I saw was 35. Tested to see what would happen if I turned all the graphics settings down to their lowest (keeping multiview on), 129 FPS in the pits and low of 110 FPS out on circuit. I then went back to the Nvidia RF2 profile but changed predefined GPUs on SLI rendering to two and predefined SLI mode to force AFR and was up at 230 FPS in the pits. However when I switched all the eye candy back on FPS dropped back to 5! This leads me think there is definitely more performance to be unlocked and that maybe one of the graphics settings is responsible. I quickly experimented with HDR but this didn't make any difference. Going through each setting one at a time is for another day.

    For now I'm going to stick with what is effectively the base profile and start turning down a few options in game to get the frame rate up.

    Edit: Couldn't resist some more testing with the Nvidia RF2 profile but with predefined GPUs on SLI rendering set to two and predefined SLI mode set to force AFR. Now getting over 400 FPS in the pits, with everything off. Turn on HDR and it drops to 45. Turn HDR off and everything else up to max, 45 FPS. Aaaarrrgh, don't know what to think now!
     
    Last edited by a moderator: Aug 29, 2013
  6. ForthRight

    ForthRight Registered

    Joined:
    Jan 12, 2012
    Messages:
    231
    Likes Received:
    4
    Edited the first post to state that the settings don't seem to work for most multiview setups.

    I do believe it is worth trying for anyone with single monitor SLI though.
     
    Last edited by a moderator: Oct 29, 2013
  7. Liquid4653

    Liquid4653 Registered

    Joined:
    Sep 30, 2013
    Messages:
    189
    Likes Received:
    40

    Wanted to say thanks for all your info, running my game on 2x670GTX's and this has dramically improved my frame rates, I am over the moon, anyone with a nvidia card should be using nvidia inspector anyway and this configuration rocks for rF2.

    Running a single 1080p display and getting 130 to 150 fps in build 342:)
     
  8. gonedns

    gonedns Registered

    Joined:
    Oct 26, 2012
    Messages:
    6
    Likes Received:
    0
    Hi all, if i use these configuration i double my FPS, but my systems ALWAYS CRASH. I've tryed many many differents compatibility bits, and got the same result with all all them, system restarts after a random time... sometimes 2 minutes, sometimes 10 minutes...

    Any help please? Thx!!

    My system:
    AsRock Z77 Extreme6
    Intel i5 - 3750K
    8gb g.skill ripjaws x ddr3-1600
    SLI 2x Asus GTX670 Direct CUII
    Matrox Triple Head 2 Go Digital Edition
    1xDELL 2711U (2560x1440px trabajo) y 3xLG 32LS5600 (5760x1080px gaming)
    Windows 7 ULTIMATE 64bits
    Cockpit VPP Racing Rack, volante T500RS + F1 addon + GTE addon, pedales Fanatec CSPV2
     
  9. KeiKei

    KeiKei Registered

    Joined:
    May 24, 2012
    Messages:
    794
    Likes Received:
    22
    PSU powerful enough?
     
  10. gonedns

    gonedns Registered

    Joined:
    Oct 26, 2012
    Messages:
    6
    Likes Received:
    0
    Gigabyte SuperB 720W, and only 1 SSD conected (no more drives, DVD, etc..)

    Is enough? Thx!!!
     
  11. KeiKei

    KeiKei Registered

    Joined:
    May 24, 2012
    Messages:
    794
    Likes Received:
    22
  12. gonedns

    gonedns Registered

    Joined:
    Oct 26, 2012
    Messages:
    6
    Likes Received:
    0
    Thx Keikei, anyway, today im gonna try a brand new AeroCool StrikeX 1100w PSU, hope this helps... I will post my results :)

    Regards!
     
    Last edited by a moderator: Nov 14, 2013
  13. gonedns

    gonedns Registered

    Joined:
    Oct 26, 2012
    Messages:
    6
    Likes Received:
    0
    Problem SOLVED. PSU wasn't enough for this modified SLI profiles. With the new one 1100W everything works fine and stable! thanks!
     
  14. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
    Great improvments here running 3way sli of gtx580 3GB...

    Running @100 FPS 5960x1080@120hz on nordschleife 0.97k and Le Mans 0.90 !!!

    Will test Silverstone and perhaps some Feel3 tracks for validation asap !!!

    EDIT1 : same on Silverstone : great performance since tweaks from this post applied !!! Will test Feels3 tonight !!!

    EDIT2 : same on SPA !!!
     
    Last edited by a moderator: Nov 18, 2013
  15. C3PO

    C3PO Member

    Joined:
    Aug 31, 2012
    Messages:
    1,038
    Likes Received:
    60
    Bump...
     
  16. gagipro

    gagipro Registered

    Joined:
    Feb 26, 2013
    Messages:
    461
    Likes Received:
    0
  17. ForthRight

    ForthRight Registered

    Joined:
    Jan 12, 2012
    Messages:
    231
    Likes Received:
    4
    The tweak in the first post doesn't work for everyone, but when it does work it can make a massive difference to framerates. I think this thread should hang around for that reason.
     
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    5,787
    Likes Received:
    1,891
    If people can't find this thread with a search for 'nvidia SLI' when they find they're getting poor performance from their nVidia card(s) in SLI, do you think they'll be able to even find this forum section?

    Are we going to start bumping all the threads we think are important every 3-4 weeks so they don't drop to the next page? Am I going to stop asking questions?
     
  19. ambig88

    ambig88 Registered

    Joined:
    Mar 31, 2013
    Messages:
    10
    Likes Received:
    0
    Ok, so I changed my bits to 0x00500005 and saw a great increase! At Malaysia I was at about 100 FPS in pit road, vs 33 with the default bit. Excellent! But, the reflection is flickering, constantly. Also, the AI's reflections don't seem to appear properly either. Anyone else with this issue?

    Specs:

    i5-2500k
    8 GB RAM
    Nvidia 760 GTX x 2
    Yamakasi Catleap 2560x1440.

    The other bit, 0x82482005, doesn't show in the drop down menu, but I added it manually and it made no difference to the default.

    Also it Crashes to desktop at Silverstone. :(
     
    Last edited by a moderator: Feb 3, 2014
  20. C3PO

    C3PO Member

    Joined:
    Aug 31, 2012
    Messages:
    1,038
    Likes Received:
    60
    I think it's useful, so yes in this instance. I'm sure some will find this informative and would have missed it. :)
     

Share This Page