[SOLVED] No Sound (Menus and In-Game)

Discussion in 'Technical & Support' started by XxRedBullF1xX, Dec 22, 2018.

  1. XxRedBullF1xX

    XxRedBullF1xX Registered

    Joined:
    Dec 22, 2018
    Messages:
    4
    Likes Received:
    2
    Hello all, I just purchased the game a few days ago. I've been a hardcore AC player for a couple of years now and I wanted to give rFactor 2 a shot. Everything was going great until yesterday afternoon. I've downloaded several tracks, cars and car mods since Thursday, when I fired up the game yesterday there was no sound whatsoever. I have sound in AC, F1 2018 and YouTube so I know it's not a PC issue. I'm at a loss here as I played with several tracks and mods before the ones I installed Thursday without any issues.

    Does anyone have any ideas or suggestions? This is pretty frustrating as I bought the game and then purchased the Winter Pack that included the GT3, Endurance and Sebring track/cars and now it's pretty much unplayable when you have no sound.
     
  2. XxRedBullF1xX

    XxRedBullF1xX Registered

    Joined:
    Dec 22, 2018
    Messages:
    4
    Likes Received:
    2
    Hello all, I just purchased the game a few days ago. I've been a hardcore AC player for a couple of years now and I wanted to give rFactor 2 a shot. Everything was going great until yesterday afternoon. I've downloaded several tracks, cars and car mods since Thursday, when I fired up the game yesterday there was no sound whatsoever. I have sound in AC, F1 2018 and YouTube so I know it's not a PC issue. I'm at a loss here as I played with several tracks and mods before the ones I installed Thursday without any issues.

    Does anyone have any ideas or suggestions? This is pretty frustrating as I bought the game and then purchased the Winter Pack that included the GT3, Endurance and Sebring track/cars and now it's pretty much unplayable when you have no sound.

    PS: I posted this in the Technical & Support forum, but it hasn’t had any responses all day and this is very frustrating.
     
  3. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,480
    Likes Received:
    1,299
    Is it muted by windows? There is no other reason why there would be no sound.
     
  4. XxRedBullF1xX

    XxRedBullF1xX Registered

    Joined:
    Dec 22, 2018
    Messages:
    4
    Likes Received:
    2
    It does not appear to be, but perhaps I’m not looking in the right place. I know I didn’t make any changes to my sound so I’m not too sure why that’d happen. Where can I double check to ensure RF2 isn’t muted?
     
  5. marvelharvey

    marvelharvey Registered

    Joined:
    Apr 25, 2013
    Messages:
    402
    Likes Received:
    269
    Hmm, that's odd. Never heard of such an issue (pun not intended). Keep asking in the support channel though, as the (main) devs were asleep when you asked for assistance.
     
  6. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,480
    Likes Received:
    1,299
    I think you just right click the speaker icon on the task bar and select volume mixer. Rf2 will have to be running.
     
  7. metalnwood

    metalnwood Registered

    Joined:
    Dec 31, 2011
    Messages:
    164
    Likes Received:
    4
    I currently have exactly the same issue.

    I don't know but it could have something to do with this in my case. One of my oculus headphones stopped working so I took them off and went to headphones. Every other game uses my headphones OK as it is my default soundcard.

    RF2 has no sound at all, I am not sure if it is stuck somehow trying to send audio to the rift or not but I get no sound in my headphones at all wither in menus or game.
     
  8. XxRedBullF1xX

    XxRedBullF1xX Registered

    Joined:
    Dec 22, 2018
    Messages:
    4
    Likes Received:
    2
    I just solved my issue actually. My sound in-game was set to SRS Surround. I switched it back to Stereo and everything works now.
     
    Marcel Offermans and Lazza like this.
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,731
    Likes Received:
    3,298
    Windows Settings lets you assign outputs for each app ("App volume and device preferences"), might be worth checking in there that rF2 hasn't somehow ended up with a strange setting.

    @XxRedBullF1xX Nice!
     
  10. metalnwood

    metalnwood Registered

    Joined:
    Dec 31, 2011
    Messages:
    164
    Likes Received:
    4
    Yes @Lazza, that was is. As there seems to be no way to change the output audio in RF2 I had to disable the oculus audio so it would move over. No problem in doing that though.
     
  11. Kiepe65

    Kiepe65 Registered

    Joined:
    Dec 26, 2018
    Messages:
    1
    Likes Received:
    0

Share This Page