Night light glow bug

Discussion in 'Track Modding' started by Coutie, Dec 30, 2013.

  1. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,360
    Likes Received:
    1,235
    It seems the the glow objects turn off during the night and come back on randomly. The omni lights still are on, but the glows turn on and off. Is this bug or have I done something wrong(I think it's a bug)? For instance, the lights will come on at 6:30pm, then turn off at 7:10pm, then come back on at 9:00pm.
     
  2. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Do these glow objects use a transparent glow texture, or do they use the High Lum Sun shader?
    If it's the latter, bloom may be playing tricks with it.
     
  3. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,360
    Likes Received:
    1,235
    They are using a T1 with alpha(maybe chroma on some) transparency.
     
  4. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,360
    Likes Received:
    1,235
    Solved... I had the wrong visgroup. I read it was K(1024), but it's actually C(36).
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,963
    Likes Received:
    2,774
    Hmm... 36 is 32 + 4, which unless we're talking different visgroups is mirrors (off) and low detail. Any single value has to be a power of 2.

    *The ISI sample track max file shows 1024 as "Night time". Are you sure this isn't working right?
     
    Last edited by a moderator: Jan 1, 2014
  6. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Should link a glow object to an omni, e.g. NightLighting01 and NightLighting01Glow. No need for VisGroups that way AFAIK (you may want to use 32 though; no need to render it in the mirror). Can't double check right now though.
     
  7. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    In my case the problem I am having is that objects light on and off randomly while driving at night. Not all of them at the time. It is strange. I for sure am doing something wrong but don't know what. :(

    enviado mediante tapatalk
     
  8. Luc Van Camp

    Luc Van Camp Track Team Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    1,030
    Likes Received:
    14
    Hmmm, try testing with just a handful of omnis? If that doesn't produce correct results, PM me a copy of the SCN please.
    I've never had that happen, so I have no idea what could possibly cause this, hence the 'back to basics' style comment ...
     
  9. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    I'll try to upload a video later. I'm enjoying in the snow with my family but I brought my laptop so I hope I have time later. Happy new year BTW.

    enviado mediante tapatalk
     
  10. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,360
    Likes Received:
    1,235
    It wasn't the visgroups at all actually. I just made them all nightlightxxglow objects and they work fine now.
     
  11. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    https://www.dropbox.com/s/uwmpzlx05iqvymx/OcioKart.scn

     
  12. PlickBadger

    PlickBadger Registered

    Joined:
    Jan 12, 2012
    Messages:
    534
    Likes Received:
    8
    Spaskis,

    Move your lighting up to the top of the SCN file right below your skybox. I had a track do the exact same thing and this fixed it.

    GroupMethod=Dynamic
    MaxShadowRange=(350.00)
    AmbientColor=(126, 126, 126)
    ReflectPlane=(0.000, -1.000, 0.000, 1.0)

    FogMode=LINEAR FogIn=(50.00) FogOut=(3000.00) FogDensity=(0.0002) FogColor=(205, 215, 235)

    Instance=skyboxi
    {
    Moveable=True
    MeshFile=skyboxi.gmt CollTarget=False HATTarget=False
    Pos=(0.0,-17.0,0.0) Orient=(0.0,0.0,0.0) // move and rotate whole skybox if required
    }

    //--------------------------PORTABLE LIGHTS----------------------------

    Light=NightLight00
    {
     
  13. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    Thanks a lot I'll try and post my feedback.

    enviado mediante tapatalk
     
  14. PlickBadger

    PlickBadger Registered

    Joined:
    Jan 12, 2012
    Messages:
    534
    Likes Received:
    8
    Spaskis, did this work?
     
  15. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    Havent tried yet. I will try soon. I havent worked in the track for 2 weeks

    enviado mediante tapatalk
     
  16. PlickBadger

    PlickBadger Registered

    Joined:
    Jan 12, 2012
    Messages:
    534
    Likes Received:
    8
    Cool! Please let me know if it resolves the issue. I'm trying to compile a list of issues I've run into and their fixes.
     

Share This Page