New UI..how to delete a mod (not installed through steam?)

Discussion in 'Technical & Support' started by Haris1977, Dec 25, 2020.

  1. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    236
    Likes Received:
    98
    Greetings!

    How can i uninstall / delete a mod (track or car mod) which was not installed through the steam workshop, within the new ui?

    I know how to do it in the old one (through packages) but now what? Is this possible?
     
    Last edited: Dec 25, 2020
    Mauro and Obbzy_XR_ like this.
  2. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    151
    Likes Received:
    58
    Did not work for me either, I reverted back to old UI and uninstalled. With the new UI I had got lots of "new" versions on some local installed tracks that did not exist, the "new" ones had layout names but to track image. Was visible in the selection only not in packages.

    Now I have unsubscribed to all workshop items, uninstalled all local content, deleted all local folders and starting fresh. Lets see if it works better after that.
     
  3. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    236
    Likes Received:
    98
    The devs should definitely add one more page (the packages page of the old ui) into the new one. I do not know why they opted out the old one without migrating all the stuff into the new ui. At this time, i will too revert into the old one
     
  4. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    236
    Likes Received:
    98
  5. Wergilius

    Wergilius Registered

    Joined:
    Jul 5, 2017
    Messages:
    151
    Likes Received:
    58
    Great, will work until in-game!
    After re-install everything in the new UI to remove created dummy tracks one would avoid going back and forth between the old/new UI.
     
  6. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    2,012
    Likes Received:
    1,358
    Select Content. Then Packages.
    Click the "Sort" column to group the "Local" (non workshop) together.
    Then select whatever Location or Vehicle you want, click Uninstall and if you want then Delete.
    Anything labelled "Mod" will likely be the little file downloaded from a server you joined.
    Worked fine on my end.
     
    Corti likes this.
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,017
    Likes Received:
    4,146
    Try it on a car or track that's installed from Packages. Doesn't work here.
     
  8. ADSTA

    ADSTA Registered

    Joined:
    Nov 19, 2011
    Messages:
    2,012
    Likes Received:
    1,358
    Worked fine, just tried it. Although I only installed it then uninstalled it without actually loading the track.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,017
    Likes Received:
    4,146
    Ok, interesting. I did exactly the same using a track, and I couldn't uninstall it. Seems like most of the rest of the UI is working properly for me, but perhaps not this one :)
     
  10. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    803
    Likes Received:
    1,183
    As ADSTA says, it works but the funny thing is that the WorkShop content uninstalls it and removes it from the list. After closing rFactor and rebooting, reinstall the package.
    The local content uninstalls it but continues in the list with a red cross to indicate that it is uninstalled.
    ui1.png ui2.png ui3.png ui4.png
     
    Last edited: Dec 26, 2020

Share This Page