New UI - Bugs (27+3 and counting) listing, detailed reports.

Discussion in 'Bug Reports' started by Havner, Dec 7, 2020.

  1. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    550
    Likes Received:
    63
    When using VR, when watching other cars on the replay screen, there is enormous lag, and it is unwatchable.
    This is reflected the same on the desktop mirror.

    Playing with VR disabled, the problem does not exist
     
  2. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    82
    Likes Received:
    60
    There is no countdown before the race. (distance: laps)
    upload_2021-1-11_11-12-30.png
    Distance: minutes. There is :)
    upload_2021-1-11_11-15-5.png
     
    Havner likes this.
  3. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    550
    Likes Received:
    63
    Using custom liveries is now broken.
    Some people get booted at the race start, some just see white cars, others see standard livery instead of the custom liveries.
    It's a mess.
     
  4. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    550
    Likes Received:
    63
    I participated in a league race last night, 20 drivers, and the lag in vr graphics has gone up tenfold.
    After spending many hours to get really good settings, it's all gone to pot again.
    Dropping graphics settings, using motion projection etc have no real effect on this.
     
  5. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,731
    Likes Received:
    2,078
    Please create a separate/new bug post as this may have nothing to do with the UI, thanks :)
     
  6. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    I don't have VR. Please report this rather as something VR related. I'd like this thread to contain UI related bugs that I can easily reproduce and verify.
    The livery issue also I feel doesn't belong here so please @Andy Bonar report those issue in a separate thread.

    @helyesadi I'll add this to the main post.
     
    helyesadi likes this.
  7. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    550
    Likes Received:
    63
    Yes, I'll do that, but the problem only started when the new UI was forced out
     
  8. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    I'm not saying it's not related, but I can't really reliably reproduce/verify it easily.
     
  9. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    @helyesadi The countdown works only in multiplayer, right?
     
  10. Flaux

    Flaux Registered

    Joined:
    Oct 5, 2010
    Messages:
    948
    Likes Received:
    380
    1. When I watch the cars in the race/replay screen, the picture starts to stutter when the Overlay is visible.
    2. Using a widescreen with the not-streched UI there are black lines left and right of the Overlay.

    Not a bug but, using anything above Full HD results in grainy and blurry fonts. Seems to be optimized for 1080 only.
     
    Last edited: Jan 11, 2021
    Havner likes this.
  11. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    82
    Likes Received:
    60
    Yes
     
  12. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    838
    Likes Received:
    242
    @Havner You could add 3 more Bugs to you list

    1. In replays of MP races with driver swaps only the last driver which was driving the car is shown all the time as current driver.
    2. In replays the position of the drivers isn't shown correctly in the UI.
    3. No car information in replay. No pedal input, no speed info, no gear info.
     
  13. Haris1977

    Haris1977 Registered

    Joined:
    Nov 25, 2019
    Messages:
    236
    Likes Received:
    98
    I do not know if this is a bug of the new ui or not. If i unsubscribe from an official (paid) dlc - eg reiza’s mcr 2000 - when i restart rf2 it re-downloads it from scratch, thus i can not remove it. Is that normal or not?
     
  14. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,137
    Likes Received:
    2,330
    That is normal behavior for all paid dlc. I think you can choose an option in Steam to disable automatic downloads. But when you do enable them for an update, all your deleted stuff will come flooding back.
     
  15. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    1. I have no means to reproduce this.
    2. You mean something different than Bug 21?
    3. Ok
     
  16. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    I don't know how to reproduce this. Please post full set of settings that triggers it.
     
  17. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    838
    Likes Received:
    242
    Yes that's the issue. Sorry for double posting :oops:
     
  18. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    Bug 16
     
    juanchioooo and yossaneed like this.
  19. ThomasJohansen

    ThomasJohansen Registered

    Joined:
    Dec 27, 2019
    Messages:
    326
    Likes Received:
    776
    In replay when watching from spectator view and using "u" to rotate cam with mouse, when leaving/deactivating mouse rotation, the mouse pointer keeps being hidden until leaving session.
     
  20. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    114
    Likes Received:
    122
    Can't reproduce it. The cursor returns back to me properly. In rare cases when cursor gets bugged though you can use "Other/Toggle Cursor" binding. It has been added recently.
     

Share This Page