New UI - Bugs (27+3 and counting) listing, detailed reports.

Discussion in 'Bug Reports' started by Havner, Dec 7, 2020.

  1. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,954
    Likes Received:
    1,767
    I know what you mean.
    For me it's a Question of intuitive Usage of something.
    And for me it feels wrong (same in Track Selection BTW) and i would prefer to get the red Dropdown hidden, when the List View is selected.
    Asked the other Way around: Would you open the Car Selection Menu to select a Series?
     
  2. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Yeah, fine. That's purely subjective. I'm not saying you're wrong, I just wouldn't consider this a bug, but a design choice.
    Menu named "Car Selection" not, but the Series menu that's there in the list view I use all the time, as I use list view exclusively. Truth told I didn't even know that it changes to anything else before we had this conversation :)
     
  3. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,954
    Likes Received:
    1,767
    Yes it's partly subjective, i agree.
    But from intuitive Usage and Menu Structure Side, i still find it wrong (OK, not really a Bug).
    It "feels" as if you go to a Bakery to buy some Meat. ;)
    But it will not be changed anyway i guess, so we can stop to discuss about it.
    Have a happy new Year. :)
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,274
    Likes Received:
    5,892
    I think this is useful the way it is; if I go to select a car and then find I can't find the one I want because I'm on the wrong series, I can just change the series right there. Having to go back, click on Series selection, select the series, go back, and finally click on car selection, would be a convoluted way to achieve the same thing.

    In fact, in my mind this is one thing the new UI does very well - under Single Player the 3 options are visible and clickable, and when you click either the track or the car you're able to still change the series as needed.
     
  5. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,954
    Likes Received:
    1,767
    2 different People, 2 different Opinions.
    No Problem.
     
  6. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Bug 18:
    1. Register for some competition session.
    2. Wait on the countdown screen that says that you'll join when the timer hits zero.
    3. Wait for the timer to hit zero.
    4. Observe: "You're too late" on the screen.

    Afterwards it will try to connect to this session anyway, but when I was doing that for the first time it was a big WTF moment for me. Especially off putting that it was the last quali for Imola. So I though that I won't be able to join even though I did everything correct. Seriously misleading.
     
  7. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Bug 19:
    There is some serious issue with saving controller profiles. I constantly find that after saving my profiles contain other settings that I saved. Profiles that I have loaded earlier. I started to take extra care to see what I save and what I found is that:
    1. The correct file is getting saved, the one I actually had in the file name window
    2. What is getting saved is not correct. It's not the profile I have right now in the settings, but it's some profile that had been loaded earlier.
    I use 2-3 wheels and have separate profiles for them and this is starting to really get to me as I constantly have to restore my profiles.

    To reproduce it probably something like this will be sufficient. Have ~4 profiles and do the following:
    1. Load the game
    2. Load profiles 1-3 few times.
    3. Load profile 4
    4. Modify it
    5. Save profile 4. There is big chance that inside the file of 4 might be one of profiles 1-3.
     
    Last edited: Jan 3, 2021
  8. Paulfield

    Paulfield Registered

    Joined:
    Feb 18, 2012
    Messages:
    226
    Likes Received:
    234
    Assigned buttons don't highlight when activated as in the old ui.
    If pressed the onscreen function assigned button would turn orange.
     
  9. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    I'd say this is a more of a missing feature, but still, it was available in the old UI, so taking their goal of having everything in the new UI that old UI had I'd agree.
     
  10. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    This is a f&*(^ buggy mess. I'd like to tell you to fire your whole QA department but at this point I honestly DON'T believe you have one at all...

    Bug 21:
    Load a race replay. The 3 tabs next to the video (info, sectors, position) don't work completely. Like at all... They stay on the position they were at the race start.
     
    Last edited: Jan 5, 2021
  11. MerlinC2000

    MerlinC2000 Registered

    Joined:
    Apr 14, 2012
    Messages:
    42
    Likes Received:
    4
    Is there a trick to avoid using the NewUI?
     
  12. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    You can go to the last build containing the old UI in the Steam beta tab. But the old UI build will not get updated anymore.
    Also, the new competition system is only in the new build so in the long term the answer is 'no'.
     
  13. MerlinC2000

    MerlinC2000 Registered

    Joined:
    Apr 14, 2012
    Messages:
    42
    Likes Received:
    4
    ... and very likely I will not be able to run online sessions because the dedicated servers will move soon to the most recent release.

    Doing now a third fresh installation - if it's not working again I will refund the track/cars I paid recently and will wait a view years until rF2 get's it issues with managing packages resolved. How can someone develop an UI not telling the user what went wrong
     
  14. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Most likely.
     
  15. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    3,043
    Likes Received:
    1,955
    There is a short time to do this.
     
  16. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,854
    Likes Received:
    872
    48 hours for store items I believe.
     
    lagg likes this.
  17. Ike Tews

    Ike Tews Registered

    Joined:
    Jan 10, 2021
    Messages:
    17
    Likes Received:
    2
    BUG 22:
    Race time in garage menue shows always "5minutes"instead of the race lenght value i've set in the session settings. When starting the race the duration is corect. The time for the practise or qualifying session is corect displayed in the menue.
     
  18. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Sorry, I can't reproduce it. What do you mean by garage menu? The one with Watch/Setup/Drive?
    Session time is displayed there in 3 places:
    1. Watch tab at the top
    2. Watch tab, Event info subtab, below the map
    3. Setup tab at the top

    They all 3 work fine for me. Do you need to use some specific settings and/or session type?
     
  19. Ike Tews

    Ike Tews Registered

    Joined:
    Jan 10, 2021
    Messages:
    17
    Likes Received:
    2
    please see my screenshots:
    Settings: 2 sessions:
    Qualifying - 60 min
    Race - 30min

    Quali Time in Garage is displayed correct in upper main window.
    Wenn switching to race with <Next Session> the the race duration is shown as 5 minutes instead 30 minutes. When starting the race its 30 minutes, but in the garage there is a fals value shown.
     

    Attached Files:

  20. Havner

    Havner Registered

    Joined:
    Jul 14, 2020
    Messages:
    328
    Likes Received:
    338
    Ok, I reproduced it. It's related to the Race session only and comes from underlying model of how race session is handled.
    When you set 30 min race the session is indeed set to 5 minutes before you hit drive. When you hit drive it sets to 1:00:45 seconds (probably for the formation lap and similar), and only when green lights starts to appear it is set to the final value of what you set.

    So this is not really a UI bug, but I guess that for the end use it doesn't really matter. The UI could show the final value nonetheless.
    Will add this to the first post later on.
     

Share This Page