New Sound Engine - Settings

Discussion in 'Technical & Support' started by Lazza, May 14, 2022.

  1. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,901
    Likes Received:
    6,292
    Can you describe again what options you get for HRTF?

    I get these 4 (on the RC build, but same as I had on the normal build before the RC came out):
    Default HRTF
    0-Default HRTF
    1-CIAIR
    2-irc_1016

    So those 3 numbered ones match what's in my UserData\HRTF\default folder.
     
  2. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    As per my first post in the UI I see two so can select "Default" and "Built-in", same as you I have those other ones in my folder as well as a new one but they do not show up in the UI.
     
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    7,122
    Likes Received:
    4,206
    RC
     
    MarcG likes this.
  4. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    Oh this is weird then, I'm on Win11 you? I can only fathom that could be a reason.
     
  5. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    7,122
    Likes Received:
    4,206
    LOL SAME, WIN11(Not wierd Marc, this IS rF2 after-all!)
     
    MarcG likes this.
  6. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    Hehe ok, I'll take another look later but seeing as all I've done is add another file to the folder it's odd, the others weren't detectable in the UI before I did that anyway so something is off.
     
  7. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    Nope it's a mystery, I simply do not get the option to chose more than two (Default & Built-in), I updated Audio drivers, thought it was my bluetooth headphones so used a plug in pair, made sure Win11 is upto date and nadda...no luck :(
     
  8. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    @Lazza @Devin In my sound.conf file I have this line:

    hrtf-paths = $RF2_HRTF_DIR\default,$RF2_HRTF_DIR\custom,$AppData\openal\hrtf

    What does the $AppData\openal\hrtf refer too? As I don't have any such folder in my AppData named openal, so wondering whether this might be the cause of my issue?

    Thanks

    Edit: clutching at straws perhaps but I've tried everything else I can think of!
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,901
    Likes Received:
    6,292
    Can't say for sure, but it can only really point to the usual Appdata and I doubt its absence would change/add any entries. I'm not at my pc to check but I'd guess I have the same.

    I'm thinking more that something in your specific device is giving you different options, but I don't know. I've never seen anything about built-in anyway.
     
    Corti and MarcG like this.
  10. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,359
    Likes Received:
    920
    Mine has the same, I also don't have an openal folder anywhere in there, perhaps if you have a custom HRTF you need to create the openal folder and drop it in there....just guessing here.
    Code:
    hrtf-paths = $RF2_HRTF_DIR\default,$RF2_HRTF_DIR\custom,$AppData\openal\hrtf
     
    Corti and MarcG like this.
  11. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    764
    Likes Received:
    2,190
    I don't know if this will be of help to any of you. The folder path is rFactor2/Userdata/HRTF/default folder. I dropped a mhr file into this folder and it worked fine.
     
    Corti likes this.
  12. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    Yep that's what I have been doing @Highlandwalker but absolutely no joy, custom folder as well does nothing for me.

    I wonder now if it's because my RF2 installation isn't on the C: drive. I'll create that folder later @Goanna and see if that does anything. It's a complete mystery and probably something extremely simple like always :) thanks chaps
     
  13. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,244
    Likes Received:
    2,294
    Here also running and the Rfactor Installation Directory is D:\Steam\Steamapps\Common\Rfactor 2\ Userdata\HRTF\default\

    upload_2023-2-22_14-51-51.png
    OpenAL It is a multiplatform audio API developed by Creative Labs for the efficient rendering of positional and multichannel audio in three dimensions https://openal-soft.org/ (I don't think the error is there)​
     
    Last edited: Feb 22, 2023
    MarcG and juanchioooo like this.
  14. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    I've tried creating 'openal\hrtf' in appdata & in the userdata/hrtf area but alas still no joy o_O
    I mean this isn't actually that important but it's more of a niggling brain sponge that I need to deal with :D I want to know why I can't get them to show up....why?!?! :)
     
    Corti likes this.
  15. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    "Selected HRTF Dataset":-1,
    "Selected HRTF Dataset#":"-1->None selected, 0-MAX->Index of selected MHR according to internal enumeration (see trace). Dataset used for virtual 3D sound",

    That's in the player.json, I've put various numbers in that and manage to get the word "error" show up in UI in the HRTF bit, but that's it...!
     
  16. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,244
    Likes Received:
    2,294
    i have this value
    "Selected HRTF Dataset":3

    i have this lines in trace file
     
    Last edited: Feb 22, 2023
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,901
    Likes Received:
    6,292
    Presumably your trace file shows the same 2 options you see in the UI. That'll be all you can choose from. Can you find that bit and see what it says about your audio device?
     
    Corti likes this.
  18. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    If I have "Selected HRTF Dataset":3 then I get the "error" in the UI, this is from the trace file:

    5.29s sound.cpp 1317: Entered Sound::Enter()
    5.32s SoundEngineA 2026: Successfully initialised OpenAL
    5.32s SoundEngineA 1760: Using default device: Speakers (Realtek(R) Audio)
    5.32s SoundEngineA 184: OpenAL Found: OpenAL Community
    Version: 1.1 ALSOFT 1.21.1
    Renderer: OpenAL Soft
    5.32s SoundEngineA 186: Available OpenAL extensions: AL_EXT_ALAW AL_EXT_BFORMAT AL_EXT_DOUBLE AL_EXT_EXPONENT_DISTANCE AL_EXT_FLOAT32 AL_EXT_IMA4 AL_EXT_LINEAR_DISTANCE AL_EXT_MCFORMATS AL_EXT_MULAW AL_EXT_MULAW_BFORMAT AL_EXT_MULAW_MCFORMATS AL_EXT_OFFSET AL_EXT_source_distance_model AL_EXT_SOURCE_RADIUS AL_EXT_STEREO_ANGLES AL_LOKI_quadriphonic AL_SOFT_bformat_ex AL_SOFTX_bformat_hoa AL_SOFT_block_alignment AL_SOFTX_callback_buffer AL_SOFTX_convolution_reverb AL_SOFT_deferred_updates AL_SOFT_direct_channels AL_SOFT_direct_channels_remix AL_SOFT_effect_target AL_SOFT_events AL_SOFTX_filter_gain_ex AL_SOFT_gain_clamp_ex AL_SOFTX_hold_on_disconnect AL_SOFT_loop_points AL_SOFTX_map_buffer AL_SOFT_MSADPCM AL_SOFT_source_latency AL_SOFT_source_length AL_SOFT_source_resampler AL_SOFT_source_spatialize AL_SOFTX_UHJ
    5.32s SoundEngineA 188: Available ALC extensions: ALC_ENUMERATE_ALL_EXT ALC_ENUMERATION_EXT ALC_EXT_CAPTURE ALC_EXT_DEDICATED ALC_EXT_disconnect ALC_EXT_EFX ALC_EXT_thread_local_context ALC_SOFT_device_clock ALC_SOFT_HRTF ALC_SOFT_loopback ALC_SOFT_loopback_bformat ALC_SOFT_output_limiter ALC_SOFTX_output_mode ALC_SOFT_pause_device ALC_SOFTX_reopen_device
    5.32s SoundEngineA 192: Max Auxiliary Sends (EFX): 2
    5.32s SoundEngineA 192: Max Auxiliary Sends (EFX): 2
    5.32s SoundEngineA 197: Devices list:
    5.32s SoundEngineA 199: OpenAL Soft
    5.32s SoundEngineA 2107: Available resampler: Nearest
    5.32s SoundEngineA 2107: Available resampler: Linear
    5.32s SoundEngineA 2107: Available resampler: Cubic
    5.32s SoundEngineA 2107: Available resampler: 11th order Sinc (fast)
    5.32s SoundEngineA 2107: Available resampler: 11th order Sinc
    5.32s SoundEngineA 2107: Available resampler: 23rd order Sinc (fast)
    5.32s SoundEngineA 2107: Available resampler: 23rd order Sinc
    5.32s SoundEngineA 2111: Using resampler: 1 Linear
    5.32s SoundEngineA 2125: Max supported gain limit is 0
    5.35s SoundEngineA 2129: Enabled ALC_OUTPUT_LIMITER_SOFT
    5.35s SoundEngineA 2974: ALC_SOFT_HRTF supported!
    5.35s SoundEngineA 2983: Available MHRs:
    5.35s SoundEngineA 2988: 0: Built-In HRTF
    5.35s SoundEngineA 3002: Using default MHR...
    5.35s SoundEngineA 2953: Resetting AL Soft Device...
    5.42s SoundEngineA 3052: HRTF enabled, using Built-In HRTF
     
  19. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,244
    Likes Received:
    2,294
    same for me only this line is diferent (Will it be where the error is?)
    5.35s SoundEngineA 2988: 0: Built-In HRTF
    i have the options list here
    17.73s SoundEngineA 2988: 0: 0-Default HRTF
    17.73s SoundEngineA 2988: 1: 1-CIAIR
    17.73s SoundEngineA 2988: 2: 2-irc_1016
    17.73s SoundEngineA 2988: 3: MIT_KEMAR-96000
     
  20. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,827
    Likes Received:
    2,202
    could be the reason but it still renders the question, Why? :D I'm baffled!
     

Share This Page