[SOLVED] My Mas utility dont create the rFm file

Discussion in 'Technical & Support' started by Tom Track, Apr 20, 2021.

  1. Tom Track

    Tom Track Registered

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    My problem is, when I create my offline race with the More utility tool it does not create the rFm file
    This is a good one upload_2021-4-20_18-56-46.png
    and this is mine
    upload_2021-4-20_18-58-32.png
    I have reinstalled the game and the same thing keeps happening, I don't know if it is a problem with my Mas utility if it is corrupt or something

    any solution?

    Thanks
     

    Attached Files:

  2. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,545
    Likes Received:
    632
    What is the "More utility tool"?
     
  3. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    Tom is Spanish, I think me means "Microsoft Access Stored Procedure Shortcut file" i.e. MAS as "more" in Spanish.

    I've been trying to help him as he was following my videos to try and create packages to use as offline series files.
    For some reason when he generates a package using the MAS Utility it is not creating the .RFM entry correctly so then the game can see the series in the series list but it cannot open the file
     
  4. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    Tom has tried
    - running the MAS tool in admin mode
    - deleting the .dat files from \AppData\Roaming\
    - cleaning out the ~MASTEMP directory
    Nothing has worked - I am assuming that its some kind of local file rights issue on his PC, or at least that a basic assumption at this point
     
  5. Tom Track

    Tom Track Registered

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    Is the Mas utility
     
  6. Tom Track

    Tom Track Registered

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    Yes i can confirm this
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,495
    Likes Received:
    4,515
    @Tom Track Why do the dds files in yours have spaces in the filenames?
     
  8. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    I was wondering the same but I didn't see empty spaces in the file names as issues.. but maybe worth a try to see what happens if no spaces are included
     
  9. Tom Track

    Tom Track Registered

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    upload_2021-4-20_23-23-54.png
     
  10. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    884
    Likes Received:
    557
    So you've made the .rfm file and saved it somewhere other than within rF2 before you start making the mas file? I have my rfm saved to my desktop and don't have problems like I used to when I had it saved within rF2.
     
  11. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    The RFM files are being saved in rfactor2/installed/rfm/ which is the default location the MAS Utility will save files too. I don't think the location of the files are an issue.
     
    JimmyT likes this.
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,495
    Likes Received:
    4,515
    @Davy Jones MASTEMP is under the user folder isn't it? Any chance of spanish characters in the windows username causing an issue there? Do you know if the default .rfm is appearing in that folder during the process?
     
  13. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,425
    Likes Received:
    1,485
    That could be a good reason.
    Tom in spanish is Tomás
     
  14. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    I had been wondering the same - maybe Spanish localised Windows or special characters.

    When you run MAS Utility and get to the last screen and click "Package" it creates a .MAS file in
    C:\Users\[UserName]\AppData\Roaming\~MASTEMP

    And a .RFMOD file in \steamapps\common\rFactor 2\Packages

    And then when you click "Install" is places the .RFM file in
    \steamapps\common\rFactor 2\Installed\rFm

    I suggested to Tom that he reinstall the game (which he did) and maybe trying using another PC. I don't think he's tried that yet. I suspect its some kind of file rights issue or as you suggest something to do with special characters to character encoding or something.

    As a test I had setup a server using the same content Tom had locally been trying to create a Series for. When he joined the server the downloaded .RFM worked just fine for offline Series usage. So in effect the .RFM created on my end was ok for his PC but his PC cannot seem to properly generate the files so yes it would seem to be something with his PC. Or at least that's the only thing I can think of...
     
  15. Tom Track

    Tom Track Registered

    Joined:
    Jun 19, 2020
    Messages:
    5
    Likes Received:
    1
    Exactly there was the problem, I changed my username from the c: \ Users folder to another without the accent and it worked.
    "Tomás >> Tomas"
    upload_2021-4-21_15-51-6.png
    Now the rfm its load in the program
    upload_2021-4-21_15-54-14.png
    And when im load the game i select the series and works
    Thanks for the help
     
    JimmyT likes this.
  16. Davy Jones

    Davy Jones Registered

    Joined:
    Jul 18, 2018
    Messages:
    67
    Likes Received:
    16
    Indeed it seems that C:\Users\Tomás to C:\Users\Tomas fixed things... :D
     
    lagg likes this.

Share This Page