My dedicated server doesn't show in Multiplayer

Discussion in 'Technical & Support' started by GBJsch, Aug 27, 2020.

  1. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    For the last 2 days I was trying to open a dedicated server to play with some friends, but when i open it, then cannot find my server, not even my can find my own server, I already tryed to disable my firewall, port forward, restart my router but nothing!

    Every time i try to open the dedicated server, the "Matcher Status:" doesn't show anything. upload_2020-8-27_13-57-6.png

    I really don't know what to do!

    I forwarded this port:
    I just put the Protocol in ALL to see if something change but nothing, the Common Server i just didn't selected any option
    upload_2020-8-27_13-59-19.png

    HELP!
     
  2. Loano da Silva

    Loano da Silva Registered

    Joined:
    Aug 27, 2020
    Messages:
    8
    Likes Received:
    0
    already restarted the modem through the modem manufacturer's own website?
     
  3. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    yes
     
  4. Michael K.

    Michael K. Registered

    Joined:
    Feb 12, 2018
    Messages:
    30
    Likes Received:
    13
    That the Matcher Status is empty is no Problem.
    You and your Friends should try to connect to the Server with a direct Connection Link in a Shortcut of the Launcher, to see if the Server is online and accessible.
    You can also search this Forum, because there are a lot of Threads about such Problems.
     
    GBJsch likes this.
  5. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    439
    Likes Received:
    150
    You have to make sure that the ports are open for the ip the server is on.
    Is the server your pc or another you have set up?
    The router must point to the ip the dedi is on.

    SS
     
    GBJsch likes this.
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,907
    Likes Received:
    4,064
    @GBJsch while I don't think you've hidden anything important, note that 192.168.* IP addresses are private - they don't identify you to anyone else. (you might have your PC on 192.168.1.1 in your network, and I have mine on the same on my own network) There's no need to hide those on screenshots.

    *I'll edit with some actual advice: although it's not really recommended, you can work out whether port forwarding is your issue by putting your PC (the local IP, as above) in the DMZ section so your router sends everything to your PC. If it still doesn't work, the port forwarding isn't the issue (yet).
     
    GBJsch likes this.
  7. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    I tried the DMZ and nothing
     
  8. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    I already have set up the ports on my router, but when I use some online "Open Port Check Tool" or some software, it always says that the port is closed and idk what i have to do to open it!
     
  9. Michael K.

    Michael K. Registered

    Joined:
    Feb 12, 2018
    Messages:
    30
    Likes Received:
    13
    @GBJsch Did one of your Friends try to join your Server by Direct Connect?
    And did it work or did he get any Error Message?

    EDIT I just remembered something.
    Scheck THIS Site, especially the Point 3 and the red marked Note.

    BTW If it is a WLAN Router, you maybe get Lags on the Server.
     
    Last edited: Aug 28, 2020
  10. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    439
    Likes Received:
    150
    You didn't say what pc is running the dedi server.
    The ports MUST use that pc's IP or it won't work. And if you have restarted your router the IP can change check it again.
    This does work you have to be 100% correct with the path.

    SS
     
  11. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    I don't even know how to join by direct connect, when me and my friends tries to join them just search the name of the server and find nothing
     
  12. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    yea I use the same pc for running the dedi server and play
     
  13. Michael K.

    Michael K. Registered

    Joined:
    Feb 12, 2018
    Messages:
    30
    Likes Received:
    13
    Did you also read THIS Site and especially the Point 3 and the in red written Note?

    To direct Connect to a Server, tell your Friend to do this:
    They shall go into the Folder
    ..\Steam\steamapps\common\rFactor 2\Launcher
    rightclick on the "Launch rFactor.exe" and select "create Shortcut"
    then rightclick on the Shortcut and select "Properties"
    In the Field "Target" , they shall adapt the below Line to the Values of your Server:
    Path to their Steam Folder\steamapps\common\rFactor 2\Launcher\Launch rFactor.exe" +connect=The IP of the Server:The Port of the Server
    If the Server uses a Password:
    Path to their Steam Folder\steamapps\common\rFactor 2\Launcher\Launch rFactor.exe" +connect=The IP of the Server:The Port of the Server +password The Password
    They have to take care for the Spaces in the Entry.
    If they have saved the Changes, they shall only start Steam and start the Game by doubleclicking the Shortcut.
    That should lead them directly to the server
    This Method is useful, to test if a Server is accessible, even if it is invisible in the Server List.
     
  14. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    ok now I get it, it's working now, but the only problem is that I cannot select my race events, when I select my own race events in the dedi server, I hit the button to go to the Vehicles Menu it just changes to another random rave event, my friend is having the same problem:



    that only happends with the race events that i create my self
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,907
    Likes Received:
    4,064
    We can't see what's in the event you've selected, from that video it's possible you've just put the wrong content in the event instead of the selected event itself changing.

    Since that's a dedi server, get rid of all events except the one you want. That way there can't be any weird switching - and if the content in it is wrong, it'll be the event itself that's wrong.

    Also please delete your duplicate post in the other thread, people will answer the earlier posts from the thread you dragged up and things will get confusing.
     
  16. GBJsch

    GBJsch Registered

    Joined:
    Aug 4, 2020
    Messages:
    60
    Likes Received:
    118
    I deleted all the raceevents i not use and just let the race events that i created ahd got this upload_2020-8-29_22-35-16.png
     

Share This Page