Must disable 3D Vision service or horrid performance

Discussion in 'Technical Archives' started by Ball Bearing Turbo, Jan 13, 2012.

  1. Ball Bearing Turbo

    Ball Bearing Turbo Registered

    Jan 11, 2012
    Likes Received:
    Running an
    i7 920 @ 3.5Ghz
    2 GTX470s SLI
    6GB Ram

    Initially got from 10 to 20 FPS depending (lol...)

    Lowered details to medium, got a few more FPS.

    3D Vision did not work with SLI enabled.

    Heard that SLI is bugged, so disabled that - got a few more FPS, and 3D Vision worked with one card but still piss poor performance

    Then got the brainwave to turn 3D Vision completely off, now able to put every single setting on maximum and get 60+FPS everywhere all the time.

    Not sure if this is nVidia's problems or if ISI is not playing nice with their drivers but thought I'd report it.


    We already knew SLI is bugged, but so is even having 3D Vision service running (whether you have it engaged or not). Both give dreadful performance.
  2. mmed

    mmed Registered

    Oct 15, 2010
    Likes Received:
    I donĀ“t have that problem on my system. Although I recognize that problem from other games.
    I can run with every setting maxed out and 3DVision enabled and still get 60+ FPS.
    If I disable 3D with Nvidia shortcut key (ctrl+t) I get the normal FPS boost that is expected.
    When I disable 3DVision driver from Nvidia Control Panel I still get same FPS.

    My specs
    i7 2600K
    GTX 580
    Win 7 X64
    Nvidia beta driver 290.53

Share This Page