ModManager crashes in Steam version

Discussion in 'Hosting Help' started by Dave-NRT, May 15, 2016.

  1. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    I usually am the one trying to help others with there Server issues..but this one has me baffled.
    I tries searching the Forums for any-one else having the same issues, But likely did not enter the correct phrase.
    Anyways

    When I try to launch the Mod Manager..I get a stop running.
    Bellow is the crash dump info.

    Server is up to date with all Server 208 r2 update and patches..

    Any help would be appreciated

    Dave

    NRT Servers


    Problem Event Name: APPCRASH
    Application Name: ModMgr.exe
    Application Version: 0.9.3.24
    Application Timestamp: 57068292
    Fault Module Name: ModMgr.exe
    Fault Module Version: 0.9.3.24
    Fault Module Timestamp: 57068292
    Exception Code: 40000015
    Exception Offset: 0018ff28
    OS Version: 6.0.6002.2.2.0.272.7
    Locale ID: 1033
    Additional Information 1: c854
    Additional Information 2: c9010d4c30e9141f7c677c2c15173db3
    Additional Information 3: 922d
    Additional Information 4: 1017c19945424d26bf8074ae09de8937
     
  2. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    I believe I have this fixed..

    Could some-one connect to :

    NRT Steam Test

    and see if it lets them join?

    Appreciate this

    Dave
     
  3. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,312
    Likes Received:
    6,035
    It looks good to me, but which Stockcar version are you running?
     
  4. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    ModManager

    I had saved there Packages Directory Chris and created a package using it.

    Sorry never thought of that..so it likely wanted to download the version from the server instead of the latest release I bet.

    Sorry again if it wanted you to download it...MY BAD..

    All seems to work..so I will return it back to the client..and let them go from there with there Packages creation.

    Thanks Sir

    Dave
     
  5. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,312
    Likes Received:
    6,035
    No problem, glad it's now working :)
     
  6. gornes

    gornes Registered

    Joined:
    Dec 7, 2011
    Messages:
    184
    Likes Received:
    0
    I suddenly had the same problem yesterday with one of my few SteamCMD installations. ModMgr as well as MAS2 were crashing with stop running error.
    I opened each with 'Run as administrator' and the issue disappeared. It still does crash if opened normally.
     
  7. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,312
    Likes Received:
    6,035
    Thanks for reporting that.
     
  8. expdom

    expdom Registered

    Joined:
    Oct 6, 2010
    Messages:
    26
    Likes Received:
    0
    MAS2 started crashing today as well. It was working well until last nite.

    It crashes when trying to create a VMOD. Running as administrator will not solve the issue. Packages location is correctly specified

    One file does not pass verification thru Steam when verifying cache but it gets "reacquired". Steam won't tell which file but MAS2 keeps crashing just the same.

    ModMngr works without problems.
     
  9. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    375
    Likes Received:
    103
    expdom when you make a lot of vmods the file that contains them somehow fills up and won't let you make anymore.
    Noel Hibbard found the fix for this, "Look in Users\name\appdata\roaming\. But look in there for a cmpinfo.dat and pkginfo.dat. My guess is the pkginfo.dat got corrupt. You should be able to delete that file and the MAS tool will work again."

    SS
     
    yashiman likes this.
  10. expdom

    expdom Registered

    Joined:
    Oct 6, 2010
    Messages:
    26
    Likes Received:
    0
    Yeap, that did it.

    Deleted pkginfo.dat and MAS2 worked again, cmpinfo.dat was not there though..

    Thanks a lot!!
     
  11. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,264
    I now have this issue. We have had it before and used this work around on NON STEAM and fixed it. BUT now with the STEAM VERSION we can not fix.

    I only had pkginfo.dat (which I deleted) but there was no cmpinfo.dat file. Still mod manager crashes.

    I have even re-downloaded the STEAM CMD Server into a different location and STILL mod manager crashes.

    ISI what other files can cause this? The server runs win10
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,972
    Likes Received:
    2,787
    Have you searched for pkginfo.dat and cmpinfo.dat, in case they're in a different location to that which you expect?
     
  13. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,264
    Yeah I have I should of mentioned that.

    My only thought now is to create a new user profile and reinstall in that.
     
  14. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,264
    I have checked that the indexing is looking for .dat files. (which it was) BUT searched the entire pc for pkginfo.dat and cmpinfo.dat and no results come up.

    I created a new account on the server and started up the same mod manager and it works!!!!

    There has to be a user profile FILE that is causing the issue.

    ISI any ideas?
     
  15. Paul Swire

    Paul Swire Member

    Joined:
    Jan 21, 2012
    Messages:
    168
    Likes Received:
    6
    Dave, I have the same problem with my server. Can you explain how you fixed this?

    Thanks
    Paul
     
  16. Wishmaster

    Wishmaster Registered

    Joined:
    Nov 30, 2012
    Messages:
    307
    Likes Received:
    29
    I had this issue also a few time. I could always solve it deleting one entry from the registry. Seam something is messed up there. I have create a small bat file which will do the job. You can also look inside which key will be deleted and delete it manually.

    http://www.mediafire.com/download/84vduf44edlvvgp/DeleteModManagerRegestrykeys.bat
     
    SPASKIS likes this.
  17. Paul Swire

    Paul Swire Member

    Joined:
    Jan 21, 2012
    Messages:
    168
    Likes Received:
    6
    Thanks Wishmaster, that cured my problem
     
  18. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    698
    Likes Received:
    462
    Good one Wishmaster, your solution also fixed our non working modmgr.exe

    cheers

    G
     
  19. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    29
    Likes Received:
    16
    Thanks a lot!
     
  20. Bryan Birtwell

    Bryan Birtwell Registered

    Joined:
    Jan 12, 2012
    Messages:
    620
    Likes Received:
    29
    Thank you, thank you, thank you!

    Worked like a champ!

    Bryan
     

Share This Page