Memory problem when loading anything with 30 or more AI

Discussion in 'Technical & Support' started by LiquidKameleon, Sep 8, 2019.

  1. LiquidKameleon

    LiquidKameleon Registered

    Joined:
    Sep 8, 2019
    Messages:
    5
    Likes Received:
    0
    Hi,
    I am getting this apparently common error when loading up a game with a lot of AI, but none of the posts I found online offer a solution:
    "critical memory allocation error"
    Rfactor2 failed to allocate a section of memory

    I am running the 64bit binary and using DX11. My specs are:

    Intel i5 (haswell)
    8GB DDR3 RAM
    Radeon R270
    Windows 10

    I tried deleting the bin64 directory and having steam redownload the files, but it didn't help. It used to work flawlessly back on windows 8.1, but I believe I was using DX9 back then. Does DX11 have higher hardware requirements?

    Thanks in advance.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,860
    Likes Received:
    2,655
    What are your windows swapfile / virtual memory settings? If you've limited that it could cause issues with that many AI, because you are simply running out of available memory.

    I imagine recent builds do use more memory than the old dx9 ones, yes.
     
  3. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,007
    Likes Received:
    478
    8 GB Ram is not that much nowadays.
    Check how much gets used from all running programs, when you load the game with "a lot of AI".
     
  4. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,409
    Likes Received:
    1,706
    Try:
    - Lowering opponent detail in the graphics settings.
    - Lowering texture detail in the graphics setting.

    It also depends on what car/mod you're loading, more resource hungry mods mean more power is needed, which mod are you trying with and which track?
     
  5. LiquidKameleon

    LiquidKameleon Registered

    Joined:
    Sep 8, 2019
    Messages:
    5
    Likes Received:
    0
    I was trying to load Hockenheimring with a Tatuus open wheeler. But IIRC the same issue also appeared when I was trying to load a replay of an old race I did a year ago that worked perfectly back then, I just dismissed that as a random crash back then.

    I kept the task manager up while it loaded to see if it really ate up that much memory. The system didn't even pass the 70% of total memory used when rF2 crashed. I tried running it in admin mode as well, I thought maybe it didn't have some permission to allocate more memory or something, but no cigar.

    It's not a problem for me to buy more RAM, but I want to know if that is really the problem, so far it doesn't look like it. Are there any actual hw requirements specifically for DX11 rF2? Could it be my GPU?
     
  6. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    332
    Likes Received:
    75
    Radeon R270 only has 2gb of GDDR ram, either do as MarcG suggests, or get a modern graphics card with more GDDR ram.
     
  7. LiquidKameleon

    LiquidKameleon Registered

    Joined:
    Sep 8, 2019
    Messages:
    5
    Likes Received:
    0
    I found the issue, there was a checkbox in the graphical options of the game to always force 32bit that was on. I hope this helps someone with the same issue.
     
  8. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    822
    Likes Received:
    94
    Having the same problem since a week or so, when joining the Nurburgring P1 gaming practice or race servers.
    I have 16 Gb of RAM and I have been using the 64 bit build since it first came out.

    The critical memory error dialog usually reports 6.xx Gb of RAM contiguous, which is a lot...

    Any ideas?
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,860
    Likes Received:
    2,655
    @cosimo What are your virtual memory settings?
     
  10. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    822
    Likes Received:
    94
    @Lazza Hey, I'm using 2Gb of page file. Virtual memory is 17Gb, but that should be irrelevant, as I have about 8-9 Gb of physical memory free when the "failed to allocate memory" error occurs?

    Will now try to increase that, but I honestly don't understand why I have never needed this, even with the same track and car, and now suddenly for this particular mod (P1 gaming race) I started having these troubles.
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,860
    Likes Received:
    2,655
    Worth trying to either increase it or let windows manage it, I've seen issues in the past when people disable or limit it to 'low' values. I can't explain why, I just think it's worth trying :)
     
  12. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    822
    Likes Received:
    94
    It seems that setting up virtual memory to "windows managed" worked. I haven't got any memory errors the last two times I joined the server. Fingers crossed.
     

Share This Page