McLaren not working in DX9 (2 installs)

Discussion in 'General Discussion' started by SmellySkidmark, Aug 4, 2017.

  1. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    375
    Likes Received:
    103
    I have 2 installs of rFactor2, DX11 & DX9.
    So the McLaren works fine in the DX11 install, but does not show up in the car selector list of DX9.
    It is installed in the DX9, as I can see them both 1.0 & 1.01 in the mod manager with the "Installed Tick", but no car to select in game.
    I want to be able to use the DX9 version as my preferred driving version at the moment because of TrackMap, it's better for car tuning IMO, and I want to get the best out of this car.
    Anyone have this working on their setup? What did you do to get it working?

    SS
     
  2. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    587
    Likes Received:
    2,609
    Please make sure that you have the Steam Client running when you start the DX9 version.
     
  3. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    I use DX9 and McLaren works on my end. I didn't do anything special to get it working after it was downloaded and installed.

    How are you switching from DX11 to DX9?
    Do you have separate installs? If so probably the one linked to Steam is the DX11 one and the DX9 is "frozen" in the build that it was installed and would need to be updated to be able to use paid DLC.
     
  4. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    375
    Likes Received:
    103
    Yes it's running, it won't let me use it unless I launch the DX11 version first, then it's good for offline & online.
    For example I got the update for Silverstone on both versions when I launched them today(separately).


    The DX9 runs anytime I have already run the DX11 version, so no it's not frozen, it's current. And yes separate installs.

    SS
     
  5. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,416
    The fact that it works means nothing. Go to rF2 properties in Steam and check the folder to which Steam is linked to. It is for sure pointing at dx11 install where you can drive MCL.

    I also have a working separate dx9 install but it remains in an older version, the active one when it was created. That version won't properly run Radicals or MCL which require dx9 being updated to its latest version.

    If you want to run MCL go to rF2 properties in steam and switch to dx9 build. Or make a new separate dx9 install.
     
  6. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    375
    Likes Received:
    103
    So I tried another install of DX9, the install went fine but the McLaren was not installed...
    " Component Already Installed / McLaren_650S_GT3_2017 1.01"

    Looks like the only way to get it into my DX9 is to Opt Out of DX11.

    SS
     
  7. unknwn

    unknwn Registered

    Joined:
    Aug 11, 2015
    Messages:
    132
    Likes Received:
    10
    I have only DX11 install and Mclaren doesn't show up in game. Both 1.0 & 1.01 files are installed. Is there a fix for this?

    EDIT: RF2 launcher startup logs show:
    Component "McLaren_650S_GT3_2017 1.0" failed to verify, removed from inventory
    Is this normal?
     
    Last edited: Aug 5, 2017
  8. SmellySkidmark

    SmellySkidmark Registered

    Joined:
    Jan 11, 2012
    Messages:
    375
    Likes Received:
    103
    If you need to Verify Files go onto Steam, Library then right click for properties (RF2), then Local Files and then Verify from there.
    Hope that helps.

    SS
     
  9. unknwn

    unknwn Registered

    Joined:
    Aug 11, 2015
    Messages:
    132
    Likes Received:
    10
    Steam verify was the first thing I tried upon noticing this message but it didn't help.
    Anyone knows if "Verify files" is supposed to verify the installed packages (from workshop)? When you use "delete local content" it doesn't delete tracks/cars so probably those files aren't counted as part of the original game?
     

Share This Page