MATCHER STATUS: NETWORKING ERROR : TCP error

Discussion in 'Hosting Help' started by ceecee, Dec 12, 2017.

  1. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    285
    My dedi server (standalone license, no Steam dedi) has suddenly come up with the following message :
    MATCHER STATUS: NETWORKING ERROR : TCP error
    Nothing changed, modem rebooted, ports double checked, server and client rebooted.
    Client can join, packets getting lost a bit, ping seems same.
    Has anyone experience with this message ?
     
  2. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    587
    Likes Received:
    2,609
    Your server, and all others, will show that message, but it is completely harmless. Earlier today ISI (finally) shut down the matchmaker they were still running. However, for about two years now, all dedicated servers report to both the Steam matchmaker and ISI's one. The former is obviously still working, your server will still up there and you should see it in the Launcher. This message is simply caused by the ISI matchmaker not being available anymore and we will remove that message on the next update.
     
  3. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    285
    Thanks for the quick reply Marcel !
    Looking forward to your next update ;)
     
    Clemenca likes this.
  4. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    Thanks Marcel... I had 18 e-mail tickets reporting the error...was starting to panic a bit... lol
    All the Best
    Dave
    NRT Game Servers
     
  5. Mike Crimlis

    Mike Crimlis Registered

    Joined:
    Jan 22, 2015
    Messages:
    12
    Likes Received:
    2
    Since last night, I'm unable to log into my RF2 account. I instead get the "UNEXPECTED NETWORKING ERROR" message.

    I am running build 1098 on PC with no Steam. I only want to log in so my content is available. I'm sure it wasn't previously necessary to log in every time I started the programme and it's an annoyance to me to have to do this, does anyone know a way to avoid it?
    My content has already been verified etc. so it's frustrating not to have access to the extra stuff just because I can't get it online.

    I have no firewall issues (obviously, I can connect to the internet and S-397 forum!) I have tried with the firewall switched off.

    I changed nothing before trying to connect in the usual way last night.

    I get the same error message if I try to reset my password.

    I have reset my connection.

    I have contacted S-397 support. They have not responded.


    https://forum.studio-397.com/index....e-to-log-in-to-rf2-account.58609/#post-925106
     
  6. ceecee

    ceecee Registered

    Joined:
    Jan 10, 2012
    Messages:
    692
    Likes Received:
    285
    Hi Marcel,
    Suddenly today my dedi server (standalone running from launcher, single licence) is no longer visible in the Multiplayer window of the client.
    Presumably this is because the ISI Matchmaker is now down. (however since our communication it was visible).
    Is there anyway to run the dedi server from the Launcher which starts from Steam (as I have been doing since 2013) or is it now necessary to run the Steam dedi server ?
    All settings/ports/etc are double checked again.
     
  7. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    587
    Likes Received:
    2,609
    For the record, if you want to "fix" this error yourself, you can simply configure your server in "multiplayer.json" to no longer announce itself with the ISI matchmaker by setting: "Announce Host": false

    We'll make that the new default (and remove it later) but for existing profiles you need to fix it yourself.
     
    Dave-NRT, wrxxy and ceecee like this.
  8. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    Thanks Marcel...

    I have reconfigured as per your instructions..
    I did a couple to see what happens..
    When changing the above line to false..with a JSON editor or just a plain note pad editor..
    saving it as Multiplayer.JSON, when you restart the dedicated...it re-writes it back to true.

    The same error appears on the dedicated GUI : NETWORKING ERROR: TCP Error
    I know this is because ISI took down there side of matchmaker and effects nothing per Steam version

    Just a FYI...there must be some-thing somewhere else in a .dll possible? pulling the URL re like rF1 does maybe?
    It doesn't effect the Steam Matchmaker..all seems to work as advertised... I have just been sending the clients the response
    from here and giving them the URL for the forums

    I thank you in advance for the response, and hope you find time
    to have a Happy Holidays over your way

    All the best to you and your Team...

    Dave
    NRT Game Servers
     
  9. wrxxy

    wrxxy Registered

    Joined:
    May 17, 2012
    Messages:
    332
    Likes Received:
    87
    What Marcel said worked for me just make sure there completely shutdown.......
     
    Dave-NRT likes this.
  10. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    Good Morning wrxxy...
    Thanks for the reply..
    Are you starting the Dedicated directly from the Bin64 and launching the dedicated using that method with a desktop link?

    Or have you installed Steam on your dedicated and using the Steam GUI to host.

    We have always set up our dedicated on our VPS Servers with the help file Chris wrote from his days at ISI
    http://steamcommunity.com/sharedfiles/filedetails/?id=553088396

    Thanks again
    Dave
    NRT Game Servers
     
  11. wrxxy

    wrxxy Registered

    Joined:
    May 17, 2012
    Messages:
    332
    Likes Received:
    87
    yes thats pretty much it .... here is our path..."C:\rF2 Dedi\rfactor2-dedicated\Bin64\rFactor2 Dedicated.exe" +path=".." +profile=playerS1
    each profile must use its own port numbers.......
     
    Dave-NRT likes this.
  12. Dave-NRT

    Dave-NRT Registered

    Joined:
    Jan 8, 2012
    Messages:
    360
    Likes Received:
    2
    OK..Thanks Again for your reply..
    That is the same way we do our VDS servers..
    That error does not effect the operation of the servers as you know and have relayed
    Marcel's posts to my client base..and it will be corrected in a future release...But you know some people..:)
    they see that and go into panic mode.. :/

    All the best for the Holidays
    and thanks again for your replies

    Dave
    NRT Game Servers
     
  13. Depco

    Depco Registered

    Joined:
    Jun 16, 2014
    Messages:
    847
    Likes Received:
    519
    I've been ignoring the error since it has no effect on the running of the server.
     
  14. wrxxy

    wrxxy Registered

    Joined:
    May 17, 2012
    Messages:
    332
    Likes Received:
    87
    Ok I just had an issue with this with guys not being able to connect (sever responded with invalid data)... had to change back that announce back to true......
     
    Last edited: Dec 23, 2017
  15. tafkams

    tafkams Registered

    Joined:
    Jan 13, 2015
    Messages:
    43
    Likes Received:
    8
    @Marcel Offermans
    I tried your suggestion to set Announce Host to false. The server started correctly without any messages in the matchmaker field.

    Now i had the problem that all clients were getting following error message: "Server responded with invalid data". They couldn't join the server using that setting. Btw. the server is passworded. When i set Announce Host back to true all client can join the server.

    Any ideas which causes this problem?
     
    Last edited: Dec 23, 2017
  16. Numrollen

    Numrollen Registered

    Joined:
    Nov 4, 2011
    Messages:
    67
    Likes Received:
    19
    We also have this problem. server responded with invalid data

    Totally new server setup but i still cant join our dedicated server. It worked with all patches before. What can i do? What info you need?
     
  17. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,264
    Check Marcels post above and make sure Announce Host = True
     
  18. JohnW63

    JohnW63 Registered

    Joined:
    Dec 13, 2011
    Messages:
    137
    Likes Received:
    0
    I found that if I changed the Announce Host to "false" I got the invalid data error other got. So, I changed it back to "true" and now my server shows up and people can join. Why toggling the setting from "true" to "false" and then back to "true" fixed the error is a mystery.
     
  19. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,264
    You should have tcp error on the dedi? but it means nothing Marcel says.
     

Share This Page