March 2021 rFactor 2 Build Release

Discussion in 'News & Notifications' started by Paul Jeffrey, Mar 4, 2021.

  1. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,220
    Likes Received:
    1,351
    Ah, you press R when you're on track?
    I've never done this, because i only play online :oops:
     
  2. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    19
    Likes Received:
    7
    Slimsysmeat
    thanks so far. the question is which cars you used on Sebring, GTE or GTE cars or others without this sheet metal damage model.
    I have already mentioned several times that the new Stochcars 2018X without sheet metal damage model runs super smooth and also other Carmods without this damage model run frighteningly fast. GTE, GT3 cars or basically all Carmods with the damage function just stutter.
    And in the replay I don't have big stutters, but exactly the ones I notice while driving. only these I can see in the replay too, other additional stutters don't exist. I only use the replay function in the UI, no other tricks. There is nothing I can do to turn off these stutters except turn off Rf2.;) The proof for my claim was provided by Studio397 itself when this damage model was turned off. Everything and really everything ran smoothly. The number of cars or a reduction of the graphics options has absolutely no influence on me. Neither CPU nor GPU show absolutely no bottlenecks during these stutters.
    The question I might still have is, at what refresh rate is your monitor running, what resolution, etc.? It may be that my system is very sensitive overall and therefore particularly susceptible to such effects, but that doesn't diminish the bad influence of this damage model.
     
  3. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    67
    Likes Received:
    16
    Hi,
    Sorry I haven't tried without damage turned off, so my system is all up to date and with latest release candidate. I'm running a RTX3080, 2k maxed out @ 165hz gysync enabled. I have tried without but makes no difference. I even edit the cam file on my cars to no popup. 9900K @5ghz, 16GB 3333hz and simucube pro V2. Mobo is a Gigabyte Master Z390. I also run process lasso. As for cars any really. 20-40 and the tracks I mainly use are Sebring, Nurburgring, Siverstone and Portland.
     
  4. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    19
    Likes Received:
    7
    Hi,
    I just now tried another run with 40 opponents at Sebring. I drove a Ferrari 488GTE, and the 40 opponents were all a colorful mix from the GTE class.
    This scenario did not impress my machine very much. Only during the start phase, when the scramble for the front positions was big, until the first turn, the frames dropped by about 10-15 frames. Min. frames were 135, max frames 226. Of course, one must not forget that not all 40 opponents are visually always on the screen. But that's the case with everyone. During the race, about 150- 185 frames. The stuttering is still there with these cars, no matter what I set. So, does this sound like a poorly adjusted machine???
     
  5. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    145
    Likes Received:
    651
    Latest Release Candidate 3 Hotfix Update

    Steam Build IDs
    Client 6496645
    Dedicated 6496649
    Changelog
    • Fixed replay stuttering with capped frame rate

    CS_blog_2021_03_24_screen_01_1080p.jpg
     
    Kahel, buzz hornet, Travis and 8 others like this.
  6. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    61
    Likes Received:
    45
    Thank you update!

    It's not a big deal...
    If I want to see two replay files, when opened one and then returning to the replay menu, I need to go back to the main menu. It is intuitively awkward to use.
     
  7. Lethal

    Lethal Registered

    Joined:
    Dec 18, 2019
    Messages:
    22
    Likes Received:
    32
    BMW M8 GTE BUG sound cockpit
     
  8. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    185
    Likes Received:
    123
    That's descriptive!
     
  9. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    185
    Likes Received:
    123
    Should be easy to fix from that.
     
  10. slimsymeat

    slimsymeat Registered

    Joined:
    Feb 7, 2013
    Messages:
    67
    Likes Received:
    16
    Replays are back nice a smooth.
     
  11. jayarrbee36

    jayarrbee36 Registered

    Joined:
    May 9, 2016
    Messages:
    556
    Likes Received:
    1,681
    Looks good, replays do seem smooth now.
    However, Space doesn't seem to be working quite right for me as a Play/Pause button anymore. I paused a replay using the overlay button, repositioned a camera, then pressed Space to play again, as I always do. But the replay only advanced if I held Space down, when I released it the replay paused again. Anyone else seeing this?
     
    Alessio Feletto likes this.
  12. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    865
    Likes Received:
    545
    I feel he's been overly verbose, I think "BUG" would've been sufficient. :rolleyes:
     
    JamesB and Goanna like this.
  13. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    778
    Likes Received:
    475
    No matter what I try doing as soon as I can see crumple damage on the vehicle my frames are all over the place regardless of graphical settings.

    @Paul Jeffrey I realise this is not effecting everyone as it would be more than 2 of us here complaining about it (or maybe some people just don't realise it), BUT is there any way we can disable the graphical damage or can we request the option to be added?
     
  14. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    185
    Likes Received:
    123
    Well this is strange, I am running the release candidate and I see no visible damage at all. I have damage set to 100%, invulnerability off, driving the s397 Aston GTE at least, I can drive it flat out into a wall and completely kill the car but there is NO visible damage.
     
    Last edited: Apr 9, 2021
  15. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    19
    Likes Received:
    7
    @Magus and Paul Jeffrey
    it gets even better. since the new build came out the other afternoon, i now have very fine microstutters at regular intervals in replay. Of course the stutters related to the bumps, scratches damage are unchanged existent.
    For my feeling, since the last update, the stuttering story has only shifted to an area that is not noticeable for most users.As Magus already mentioned, this damage function should be deselectable in the menu or the PlayerJason .
    But I think Studio397 is programming around some function or in the source code there is no other solution for it at the moment.
    In the meantime I had the Player JSON reloaded and everything reset, of course without a POSITIVE change. That was a faint hope, because the user before us, JamesB, has no damage model, despite the new build. Maybe he should delete the player JSON and have the system recreate it. I even suspected my wireless highspeed mouse yesterday. After I had tested very simple mice, also without success, I have connected my standard mouse again.
    I have not had such a frustration for a long time. It is time that this topic is treated seriously. There is no program at the moment that keeps me so stubbornly busy. If I remember correctly, everything got a bit worse with the last but one update. From then on I also noticed the subtle rhythmic stuttering away from the damage model stuttering. Whatever you did in the penultimate build, from then on it became more complicated to get a smooth run.
     
  16. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    145
    Likes Received:
    651
    Thank you @Magus and @MASERASER for the update on this. I'm going to spend some time this evening to see if I can get this replicated on my side, and may well reach out to the both of you via PM over the weekend if I need any further information.

    Likewise @JamesB will check on that damage situation for the Aston, again over the course of this evening / weekend.

    Many thanks
     
    Kahel, Brent, JamesB and 2 others like this.
  17. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    185
    Likes Received:
    123
    I doubt this will help but.......... I just saved my current player.json as a backup, deleted it in game restarted the game, had to re configure my controls grrrrr. drove the car again and deliberately smashed it and again NO visible damage, the car still looked lovely and shiny but was dead. Decided that as that had not helped I would re-instate my previous player.json and when I restarted the game i still had to re-assign some controls but not all for some weird reason, it seemed to be only my button box that had lost assignation (not important). I crashed the car again and ripped off 2 wheels and have a VERY scratched looking paint job but the actual body model seems to be unchanged. I assume I should be seeing some body deformation in the damage model? So something very odd going on. I am happy to help do some controlled testing if you can tell me what you would like me to do. I used to work in flight sim development so I know how difficult all this can be.
     
    Paul Jeffrey and DJCruicky like this.
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,120
    Likes Received:
    2,315
    From what I recall, the 'damage' shown on the DLC content is limited to scrapes and bruises. No deformation, but some parts, such as wings and wheels should detach.
     
  19. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    185
    Likes Received:
    123
    OK well I certainly scraped it! Did not loose any panels but that may just have been that particular accident. I did loose 2 wheels so definitely game over. Odd how I got it working though by going BACK to my previous player.json.
     
    Last edited: Apr 9, 2021
  20. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    778
    Likes Received:
    475
    See if you can manage to damage the car panel (with scratches) & continue to race with it (so keep you wheels on), does this then effect your fps with some spikes in frame time causing lots of drops in frames?
     

Share This Page