[REL] March 2021 rFactor 2 Build Release

Discussion in 'News & Notifications' started by Paul Jeffrey, Mar 4, 2021.

  1. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147
    I will test, cannot do it now, will be tomorrow.
     
    Magus likes this.
  2. Bostrom

    Bostrom Registered

    Joined:
    Jul 1, 2018
    Messages:
    118
    Likes Received:
    532
    Thank you for the quick hotfix. The replay now runs smoothly. :)
     
    Rogger likes this.
  3. Rod Wilson

    Rod Wilson Registered

    Joined:
    Apr 10, 2021
    Messages:
    2
    Likes Received:
    0
     
  4. Rod Wilson

    Rod Wilson Registered

    Joined:
    Apr 10, 2021
    Messages:
    2
    Likes Received:
    0
    Hi, I hope I am in the right place to ask this question.
    I have just loaded & set up Rfactor 2, I got it working beautifully until I get around half a lap in on a single race. The computer just freezes up & I have to restart the computer. I have tried a different track but same thing.
    Any help would be appreciated.
    Thanks Rod
     
  5. Rogger

    Rogger Registered

    Joined:
    Dec 18, 2019
    Messages:
    27
    Likes Received:
    25
    The replay works now, thank you for that.

    But sometimes, unfortunately, my mouse cursor disappears during replays, which is very annoying.

    This is the fourth time that I have the problem that rFactor2 got stuck after selecting a repetition while loading the replay and I could not exit the program.
     
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,663
    Likes Received:
    2,583
    Have you tried pressing the DEL key when the cursor disappears?
     
    Rogger likes this.
  7. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147

    @Magus Tested this a little tonight using the Aston GTE at Le Mans 2018. I took AI out so it was just me on track, drove a lap watching the frame rate which was rock steady at 60fps (my max monitor refresh rate and my G-Sync settings). I then deliberately scratched up both sides of the car by driving along the barriers, bounced off a few times and did enough damage to see it all down both sides and the car was not quite driving straight, unfortunately at least in terms of this experiment it seemed to have no adverse effect on my framerate and I saw no stutters or any other odd behaviour.

    @Paul Jeffrey I still cant explain my lack of a damage model at all until swapping the player.json file yesterday. Does the game re-create any other files if it finds the player.json file missing and has to re-create that? I only installed RF2 for the first time back in December, since that time I have never had any visible bodywork damage although the underlying damage model has been working as I get the crew chief warnings, so all I have been missing is the graphical representation of damage. I cant really see how removing my player.json letting the game re-create it and then deleting that new version and going back to the previous one could trigger the damage to work graphically as it certainly did not appear to when I ran the newly created player.json. I certainly did not make any mistakes with re-instating the file as it has quite a number of changes in it relating to AI behaviour etc all of which are present.

    For completeness:
    AMD Ryzen 7 3700X 8-Core Processor 3.59 GHz
    16.0 GB RAM
    1TB SSD
    Nvidia GeForce RTX 2070 Super
    5670x1080 triples


    If there is anything else I can have a look at for you guys let me know.
     
    Paul Jeffrey likes this.
  8. B. Gant

    B. Gant Registered

    Joined:
    Dec 9, 2011
    Messages:
    121
    Likes Received:
    15
    As DaveHenrie said, press the Delete button on keyboard...I was thinking the same thing for awhile like it was a bug. But DEL will make pointer appear/disappear. I Guess when watching it disappears on its own.
     
  9. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    21
    Likes Received:
    7
    @Paul Jeffrey
    @JamesB
    @Magus
    I had recommended you to delete the playerjson exactly because inevitably the game creates a new playerjson when restarting. Of course, this is to reset in all settings, but this takes only a few minutes.
    I had to reinstall Win10, Office and all software due to a hard drive crash in January this year. In the case of RF2, I had several hours to download the program as well as all tracks and vehicles. Thank God Steam has saved everything.
    After everything was ready, I made the first runs. I also noticed the lack of scratches and dents after I drove somewhere against. Also interesting was that I read all over the forum that the UI had been assigned its own thread or core, which should be in the playerjson under "UI autonomous render thread".
    In my playerjson there was no such entry, even though I had the latest build at the time. Since I knew from the past that deleting the playerjson can remove errors that have arisen over time, I deleted the actually brand new PlayerJson that was sent with the reload of the game from Steam.
    After restarting RF2, I had to do the previously described procedure of setting again, of course. I make myself meanwhile photos of each side of the UI, so that I really always choose the same settings again. The controller settings are stored in the controller json under the json for my wheel/motor). So I need only a few minutes and everything is as before but with a fresh fast Playserjson without ballast and accumulated idiosyncrasies.
    And, what else can I say, of course I had the missing entry for the UI also in my playerjson. This I do for years with the desired success. In case of doubt and in case of a problem, like the current one with the scratch and dent damage model and the stutters this triggers, this is one of the first things I do. Of course it's annoying, but what are you supposed to do when the program doesn't do what it promises, you have to help it along.

    And Paul, I deleted the latest Nividia driver 465.89 yesterday and reinstalled my previous driver 461.92. I'm not saying that the old driver is bug free, but it seems that the rhythmic stutters and micro stutters have been alleviated, not disappeared and are not as noticeable in replay. The enormous stuttering in a crash has remained.
    Have you not also changed the refesh times of the tracks, i.e. shortened them? Can this not cause the rhythmic stuttering in the replay (just much more often noticeable)?
    But JamesB brings me to an idea, namely to drive completely alone on the track, I guess that there are then no stutterers or only a few, because it could be related to the AI. One thing is certain, the bumps, scratches - damage model is the main cause of stuttering in accidents.
     
  10. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,495
    Likes Received:
    4,515
    Just a minor note, the game doesn't come with any JSON files. The game itself creates those when you first run it, same way as when you remove them later for a fresh start.
     
  11. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    21
    Likes Received:
    7
    @Lazza
    Thanks Lazza for clarification, but as you can read at the beginning of my post I said exactly that. I only once in between mentioned Steam as the producer by mistake. But that doesn't detract from the point, because exactly what I wrote is happening.
    But maybe you (as an old user) have a useful contribution to why the game creates different playerjson or in doubt even incorrect.
    The next would be , can you give a useful explanation for the problems I described with the sheet metal scratch damage model, with which I have so much stuttering problems in accidents by the AI?
     
  12. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,495
    Likes Received:
    4,515
    That's why I said it was a minor note.

    I've personally found that taking out only the player.json in order to create a new one, also recreated (replaced) at least one of the other .json files (controller.json in my case). So it's possible other files were changed when you did that. It's difficult to know without a before and after; a broken player.JSON seems very unlikely in itself.

    If I had any ideas or experience with the stuttering issue I would have said so.
     
  13. JamesB

    JamesB Registered

    Joined:
    Dec 28, 2020
    Messages:
    230
    Likes Received:
    147

    Well that explains why I had to reassign several controller functions after swapping the player.json file around, Think I will back up the controller.json file when I mess around with the player one in future, not that its a big deal to re configure a few buttons.
     
  14. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    21
    Likes Received:
    7
    @Paul Jeffrey
    @Magus

    I actually went through some more testing today and think I can focus the stutter symptom even better for cars with scratch-dent damage.
    After switching back to the 461.92 driver, I could already see significant reductions in this stuttering. In fact, the latest Nividia driver 465.89 actually produces microstuttering in replay and of course during the race. It also reinforced the negative impression as far as the stuttering of the tin damage function is concerned.

    I did my laps today with the 461.92 on Silverstone-Endurance, Sebring-12H road course and Targa Florio alone without AI opponents. I used the Ferrari 488GTE for this. I had no stutters on any track and the replays all ran flawlessly.
    However, when I hit the guardrail, I experienced stutters.

    In addition, I drove the same runs with a Honda GT500, obviously without a fender bender feature. The same positive results but with the difference that when I hit the guardrail there were no stutters. The replay works cleanly.
    Then I switched back to the Ferrari 488 GTE and took 9 AI opponents on the track. Immediately it started to stutter again on Silverstone, especially when the AI collided with each other, no matter if graphically not visible, so behind me or far in front of me.
    In the replay I could see this stuttering again.

    What I noticed in the replay, however, was that my own car actually ran clean and stutter-free and apparently only the AI_opponents stuttered or were unsteady.
    I basically drive online and against AI opponents, have all graphics options fully on, Ultra, no driving aids turned on, no G-sync, 144hz, on silverstone I get about 175-206 frames under these conditions.

    If I then leave the race after a stutter orgy and have made a restart, I could strangely drive a stutter-free race.
    Only the tin damage function triggered stuttering again at the time of the touches.
    If this function or the related AI opponents were fixed, RF2 would run flawlessly.
    Paul, what do you think about this?
     
    atomed likes this.
  15. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    281
    Likes Received:
    1,167
    Fantastic, thank you for these in depth tests and analysis @MASERASER that is certainly some interesting food for thought that you have uncovered - thank you. I'm still very much looking at this at the moment, so I'm going to filter in your findings to the testing, thank you!

    Inevitably the weekend conspired to ensure I had less time on the rig than I would have liked, so hopefully today is more productive!

    Many thanks
     
  16. MASERASER

    MASERASER Registered

    Joined:
    Feb 14, 2021
    Messages:
    21
    Likes Received:
    7
    @Paul Jeffrey
    Paul, thank you very much for your initial response.
    I must correct something, I do not know if it is significant. I saw a typo.
    But I wrote that I drive mainly online, that was wrong, I drive mainly offline against AI. Sorry.
    I look forward to your results and further suggestions.
     
    Paul Jeffrey likes this.
  17. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,546
    Likes Received:
    7,415
    Latest Release Candidate 3 Update

    Steam Build IDs
    Client 6532194
    Dedicated 6532199

    Changelog

    - Fixed sporadic freeze of the UI in fullscreen mode
     
    Rogger, Travis, jayarrbee36 and 5 others like this.
  18. Luprosx

    Luprosx Registered

    Joined:
    Apr 6, 2013
    Messages:
    99
    Likes Received:
    55
    Just tested.
    Oreca and GTE at Spa 1.15 only training.
    After this update, the small stutters in the replay are back on the full screen.
    Sometimes the FPS break from 75 to 43 only briefly.
    Then it runs smoothly again, only to jerk slightly again.
    That was not the case before the update.
    It's not all the time, but always?
    System: 6700 K / 1070 GTX / 16 MB Ram
     
  19. burgesjl

    burgesjl Registered

    Joined:
    Feb 2, 2013
    Messages:
    206
    Likes Received:
    385
    Latest version:
    Stutters are back and worse than ever in replay screen. This is in an active driving session, either with the replay in the small screen, or in full screen. I reselected the actual GPU I use (2070) rather than Auto in the setup, prior to running the game. Monitor selected is 1920x1200 and 60Hz as it should be (though of course the issue of ingame UI showing 1920x1080 and 50Hz still remains, previously reported). Session was at LeMans and with about 16 GTE cars.

    I also noticed with the last release, and now this one its doing it elsewhere, the FPS in the track loading screen and in the replay screen which shows track loading and the spinner in the top left, the FPS is down to 11 or 12. Once in the session its showing "normal" FPS of between 70 and 170. In the main UI, when first entering the sim, that screen often runs up to 330. Not sure quite why you are trying to limit FPS in different screens or modes. I suspect in the track loading fps was reduced since really it is only displaying the spinner and updating the track map 4 times with each sector, and there's no actual user interaction going on (you can't abort the load, for example) but the reduction seems excessive and not related to anything else.
     
  20. Luprosx

    Luprosx Registered

    Joined:
    Apr 6, 2013
    Messages:
    99
    Likes Received:
    55
    It mainly happens when you switch from the small screen to the full screen.
    Sometimes the FPS break down from 75 to around 8-20, only to recover shortly afterwards.
    If I don't switch from the small image to the full image, the FPS remain constant at 60-95 FPS.
    Small mini-jerks are still sometimes present.
    As I said before today's update, it was better.
     

Share This Page