Main menu flickering / objects invisible

Discussion in 'Bug Reports' started by Shawn Jacobs, Dec 30, 2017.

  1. Shawn Jacobs

    Shawn Jacobs Registered

    Joined:
    Aug 7, 2016
    Messages:
    101
    Likes Received:
    91
    Hi

    I've recently started getting an issue when in the main menu that the screen is partially flicking black and items are disappearing (still able to click them just can't see them)



    In an attempt to resolve the issue I first tried a completely new install of RF2, when that didn't work I've done a complete new windows install, still no luck.

    I have the latest drivers installed.

    No setting in graphics seem to make a difference, this issue does not occur once you get to the track it's only in the menus, occurs in both single player and multiplayer.

    Does not occur in DEV mode (same graphics settings)

    Definitely doing my head in!

    Thanks in advance.
     
    smigiel likes this.
  2. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,197
    Likes Received:
    1,263
    I got this with the latest nvidia driver.
     
  3. smigiel

    smigiel Registered

    Joined:
    Feb 9, 2011
    Messages:
    36
    Likes Received:
    10
    same here ;(
     
  4. Shawn Jacobs

    Shawn Jacobs Registered

    Joined:
    Aug 7, 2016
    Messages:
    101
    Likes Received:
    91
    so rolling back drivers got rid of it? It's weird it started before I updated drivers, but it did seem to start after a windows update.
     
  5. smigiel

    smigiel Registered

    Joined:
    Feb 9, 2011
    Messages:
    36
    Likes Received:
    10
    @Shawn Jacobs no it want, After clean instalation of rF2 it is all fine till You touch options/ video resolutions/hid . multi or UI stretch ... then all start :(
    No idea what to do with it
     
  6. Juergen-BY

    Juergen-BY Registered

    Joined:
    Jun 16, 2012
    Messages:
    2,865
    Likes Received:
    293
    I have the missing preview pics for the HUD`s since a couple of builds, should be reported allready, but seems not on the "fix" list...

    GRAB_051.JPG
     
  7. Shawn Jacobs

    Shawn Jacobs Registered

    Joined:
    Aug 7, 2016
    Messages:
    101
    Likes Received:
    91
    Yeah those missing pics seem to be an issue since dx11, surprised to hear itsnot on a to do list.

    This one's a bit different half the screen will flicker black, and items like session setup will be mostly invisible,makes it really hard to set anything up.
     
  8. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,559
    Likes Received:
    2,436
    Just to clarify, is this happening with the latest geforce/nvidia provided drivers? As opposed to Windows update drivers?
     
  9. Shawn Jacobs

    Shawn Jacobs Registered

    Joined:
    Aug 7, 2016
    Messages:
    101
    Likes Received:
    91
    Latest driver, think it was released on 20 December.

    I have a 1070 for further info.
     
  10. BoogerMac

    BoogerMac Registered

    Joined:
    Jul 3, 2016
    Messages:
    31
    Likes Received:
    3
    Sorry to resurrect an old thread, but I'm still suffering from this issue. Was there ever a fix?
     
  11. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    576
    Likes Received:
    2,521
    Can you tell us more about your system specs, exact video and display configuration in rF2, etc?
    This could be a graphics driver issue, or maybe you're out of memory somehow. Without more specifics this is hard to pinpoint.
     
  12. Saetta_McQueen

    Saetta_McQueen Registered

    Joined:
    Mar 10, 2019
    Messages:
    1
    Likes Received:
    0
    I suffer the same problem after upgrading Windows 10 to version 1809.
    I have a gtx 1070 and the latest nVidia drivers.
    rFactor 2 run at 2560*1440 (single monitor).
    Any solution?
    Thank you.
     
  13. Shawn Jacobs

    Shawn Jacobs Registered

    Joined:
    Aug 7, 2016
    Messages:
    101
    Likes Received:
    91
    I can't remember exactly what fixed, it just stopped doing it. Sorry not much help there.
     
  14. BoogerMac

    BoogerMac Registered

    Joined:
    Jul 3, 2016
    Messages:
    31
    Likes Received:
    3
    Yeah, I haven't had the problem for a few releases now. Still don't know what fixed it. An rF2 update? Driver update? I may never know, but I don't care as long as it's good from here on out.
     
    Shawn Jacobs likes this.
  15. Stefan Wukovatz

    Stefan Wukovatz Registered

    Joined:
    Feb 26, 2018
    Messages:
    5
    Likes Received:
    0
    Same for me. I also don't know after which update on NVIDIA or WINDOWS it has started.
    Estimated I have this issue, since mid of January 2019.
    Let me know, what you need and I will try to provide it.
     
  16. Max.B18

    Max.B18 Registered

    Joined:
    Jun 17, 2019
    Messages:
    25
    Likes Received:
    68
    any infos about it. I have the same problem long time with many updatet drivers

    RTX2080
    I7 8700
    16 GB Ram
     
  17. Leige

    Leige Registered

    Joined:
    Aug 6, 2019
    Messages:
    7
    Likes Received:
    1
    Same error

    AMD 3700X, 2070 super and 16GB of RAM
     
    Last edited: Nov 14, 2019 at 5:18 PM
  18. Max.B18

    Max.B18 Registered

    Joined:
    Jun 17, 2019
    Messages:
    25
    Likes Received:
    68
    I think we must waiting for the new ui. A other problem i have it also in the pits and replay.
     

Share This Page