Low GPU usage since update

Discussion in 'Technical & Support' started by richirichi, Apr 16, 2023.

  1. richirichi

    richirichi Registered

    Joined:
    Feb 21, 2021
    Messages:
    22
    Likes Received:
    3
    Hi guys. Since the update, I’m having huge performance issues. My GPU usage has gone from 99% in race, to about 30%, with a massive FPS drop. At Spa, with GT3 & a field of 26 cars, FPS is now around 35 - 50!! Before the update, everything was fine with GPU 99%/ FPS fluctuating around 70- 90. My rig is an AMD 9 3900xt, RTX 3080. I have no idea why, all my other sims run normally, so it can’t be the hardware. Any help would be great. Cheers
     
  2. Levelup1

    Levelup1 Registered

    Joined:
    Jul 9, 2018
    Messages:
    79
    Likes Received:
    102
    Same here, I also have a 3080. Rfactor 2 needs some optimization for real.
     
  3. richirichi

    richirichi Registered

    Joined:
    Feb 21, 2021
    Messages:
    22
    Likes Received:
    3
    Is your issue, post update the same as mine?
     
  4. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    797
    Likes Received:
    2,243
    The are new nvidia drivers available version 531.61, try these it may help. I also run a 3080 card and with the latest update and the latest drivers I have seen over 200-FPS running Spa 66 and the latest version of the Brabham BT44 with 32 cars. I have never seen over 200-FPS before with any combination of track or car. I run max graphics settings at 4k single screen. I would suggest doing a clean install of the latest drivers and check to see what programs you have running in the back ground and stopping any that you don't really need. Windows does tend to run a lot of crap in the back ground, automatic updates for programs is one place to start, it's surprising how many automatic update programs run in the background. I only install the video driver, I do not install nvidia experience can't really see the point. If you have it installed try uninstalling to see if it makes a difference. Open task manager and look under startup tab and disable any programs you to not need running. I personally have found rF2 runs no worse than any other sim, AMS2 is probably the worst. Maybe some of this will be of help.
     
  5. Levelup1

    Levelup1 Registered

    Joined:
    Jul 9, 2018
    Messages:
    79
    Likes Received:
    102
    Yes, before update was okay, after started having low gpu usage
     
  6. Levelup1

    Levelup1 Registered

    Joined:
    Jul 9, 2018
    Messages:
    79
    Likes Received:
    102
    I will try the driver you suggested. What's crazy is AMS 2 runs flawless on my pc in rain and night, even ACC runs well.
     
  7. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    797
    Likes Received:
    2,243
    What I have found over the years I have been running rF2 it's more affected by crap running in the background compared to other sims, probably because it is very cpu intensive compare to some other sims. When I'm running rF2 the only programs I run as well is Simhub, Fanalab and some times Crewchief. AMS2 doesn't run badly on my system just not as well rF2, ACC runs about at120-FPS. I don't run rF2 at night because I don't particularly like the look of it compare to the other sims. Do you run windows 10 or 11, if you run windows 10 this video may be of help but be carful of some of the suggestions though. It shows how to get rid of a lot of crap, when I ran some of the suggestions it cleared about 10-gig of space on my c-drive and also stopped a lot of crap running in the background.

    Hope this is helpful
     
    Levelup1 likes this.
  8. Caretaker

    Caretaker Registered

    Joined:
    Feb 1, 2017
    Messages:
    10
    Likes Received:
    2
    Same issue, with the realease of D4 i had to update my drivers and now my gpu runs ~50% usage in rf2. And no, it's not caused by the crap running in the backround, switching back to 516.94 driver, everything is fine.
     
  9. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    797
    Likes Received:
    2,243
    I'm using driver version 531.79 at the moment without any problems, this driver seems to give more consistent performance. There are two newer versions but these did not work so well for me. Maybe try using 531.79 driver could help. If you try this driver install as a clean install.
     
  10. Caretaker

    Caretaker Registered

    Joined:
    Feb 1, 2017
    Messages:
    10
    Likes Received:
    2
    What resolution are you running? My monitor is 5120x1440 and i discovered if i set rf resolution to 2560x1440 then the gpu runs nicely at 97% load in rf. On native resolution it runs 40% load. Something else i discovered is if i alt tab then there's a chance that the gpu will start running 97% load, but only for 30-60 seconds, then just drops back to 40%.......:D
     
  11. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    797
    Likes Received:
    2,243
    If this is aimed at me, the resolution I run is 4K-3840x2160. Ensure you set your graphics card, the resolution and refresh rate of your monitor in the Steam graphics config, I need to do this every time I start the computer, it doesn't permanently save the settings. Ensure you have the same settings in game settings and also in the windows settings, especially the refresh rate. Instead of using alt tab try left Windows key and D, this will take you to the desktop. Pressing just the Windows key will bring up the task bar at the bottom.
     

Share This Page