Logging Out-of-Realtime Physics Freezes [public-test]

Discussion in 'Technical & Support' started by Christopher Elliott, Mar 19, 2019.

  1. Marcel Offermans

    Marcel Offermans Administrator Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    595
    Likes Received:
    2,637
    The purple bar is showing usage of the CPU core that deals with physics, so it's not showing usage of all cores.
     
    The Iron Wolf and Ari Antero like this.
  2. Ari Antero

    Ari Antero Registered

    Joined:
    Jul 27, 2012
    Messages:
    1,882
    Likes Received:
    825
    Last edited: Apr 24, 2019
  3. Riccardo Corazzari

    Riccardo Corazzari Registered

    Joined:
    Jun 11, 2018
    Messages:
    11
    Likes Received:
    9
    Hello. This is the log from the driver swap issue had during the Fanatec 12h of Sebring.
    Car 30 / Corazzari-Schoonvliet. (I was getting into the car)
    This is the usual issue happening (when/if it happens, because is totally unconsistent. We run the 3hrs prelude without any issue)...
    https://drive.google.com/open?id=1nRKwnvijgq6imBxEEdHXeidhHZFzZMBy
     
  4. Viktor Jim

    Viktor Jim Registered

    Joined:
    Mar 21, 2019
    Messages:
    9
    Likes Received:
    0
  5. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Riccardo Corazzari and some other users, thanks for your feedback, but this thread should be focused on a specific issue that is rubberbanding and out-of-realtime.
    Please post your issues in other related threads or create a new one that matches your current issues.
    thanks

    @Viktor Jim Could you specify in your post if you had issues in those logs attached and gives us details/context of your test?

    thanks.
     
    Last edited: Apr 24, 2019
    tafkams likes this.
  6. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    Build update ID [3764767] :
    - Sync with public branch
    - Improvements on FFB thread/update. (this is a critical area that can generate the physics issues)

    Also note that the CTRL+C at the moment seems broken for physics usage since we made some changes in that area, I will look into it for the next builds.

    branch name: public-test
    password : UpERYPhIblEHorTiO
    verify your files via Steam after joining the branch

    1. Select rFactor 2 from steam game library, right click and select properties.
    A dialog box with a number of tabs will appear, your looking for one that says "BETAS".
    2. select the "BETAS" tab it by clicking on it.
    You will see 2 things now, a drop down menu and a text box to enter a beta access code.
    3. enter the password provided,
    4. select public-beta from the dropdown menu
     
    Last edited: Apr 24, 2019
    Daniele Vidimari likes this.
  7. Viktor Jim

    Viktor Jim Registered

    Joined:
    Mar 21, 2019
    Messages:
    9
    Likes Received:
    0
    @4thworld , The last test i have no problems, the game run smooth , before this "beta builds" i got several problems with the game online and ofline, the test are with official content , track and mod (radical and sao pablo track) , i have to say i try today the same track with the mod we use in our league (f1 2018 trird party mod), and just notice the replay got the slowmotion after a few laps, so i can image that is more mod issue then game, maybe,
    So far i have just the steam plugin on and all another off , i will try now with the "anticheat" on(simracing tools ver 4.07), in my league is mandatory , next monday i have official race, i will keep the "RealTimeLogging activated" but im afraid, the last time i used in a official race, after pass session from warm up to race, take too much time to record the log file, and when finally pass the ssesion for me (in my screen) the race was already started so i just start from pit lane..loosing my clasification position. I hope this is the information you was asking for .
     
    Last edited: Apr 24, 2019
  8. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Viktor Jim , thanks Slowdowns in replay is a different issue as replay don't use physics.
    If you're in the public-test now the realtime logging uses way less resources so you shouldn't have any problem
     
  9. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    313
    Likes Received:
    96
    @4thworld Don't know what has happened with the last update, but in-game it seems to have bound steering with the throttle input. So, when I press the throttle it is showing input on the throttle bar and the steering. I am currently opting out of the beta to try and fix.
     
  10. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Mark Fuller have you tried to re-bind the controls when using the latest build?
    or did it just started doing that when you run it?
     
  11. Mark Fuller

    Mark Fuller Registered

    Joined:
    Dec 10, 2016
    Messages:
    313
    Likes Received:
    96
    Yep, tried to re-bind but not able to. Was doing it when I started and tried to sort, but won't let me. Opting out has cleared it though and might try again later, but have an official session this evening.
     
  12. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Mark Fuller , sure please let us know about all the details, since me or chris can't reproduce this one yet.
    You can send me a PM about it, so we can keep the conversation on the physics-related issues.
     
  13. Mario Bayer

    Mario Bayer Registered

    Joined:
    Apr 22, 2019
    Messages:
    4
    Likes Received:
    0
    @Marcel Offermans
    Unfortunately, I do not know where I have to make these settings. Besides, I do not know where to find the event information. Can you tell me how to proceed and what to look for when the problem recurs?
     
  14. Brent

    Brent Registered

    Joined:
    Nov 5, 2015
    Messages:
    173
    Likes Received:
    71
    I used the passcode for the public beta 3764767, confirmed I'm using that buildID and then verified the files via Steam after joining the branch. I'm still getting stuttering, it seems more when I enter braking zones and giving wheel input etc through turns but still occasional stutters in the straights.

    Log and trace files of two laps with AI control and one lap myself around Silverstone in the C6R with Build ID 3764767:
    https://www.dropbox.com/s/86p9h7iwu16epzj/2019-04-24 RF2 Trace and RTL files ID3764767.zip?dl=0

    Stream of the above 3 laps with CPU GPU and FPS data on and replay of those laps:
     
  15. Joggel_3000

    Joggel_3000 Registered

    Joined:
    Jan 18, 2012
    Messages:
    2
    Likes Received:
    0
    Hey all,

    so I am sorry to upload this late but here is some more data for you guys

    The Sim was setup with: no plugins active and the attached PLAYER.JSON

    1h race Silverstone 40 GT3s: https://drive.google.com/open?id=1iokkCqx3LLjtE8cvz4UWbe6fZQmEgdah
    6h race Silverstone 40 GT3s: https://drive.google.com/open?id=1zCwAzfC0E-G5sZyvmFj4U1Pq4j2Ljcf0

    player Json: https://drive.google.com/open?id=1vzUTXkN4oiiiCk6J6EyCZiK-EfJIEWeX

    I tried to do more logs (of a 10h race - and just yesterday with a 6 hour race including plugins and streaming) - however when i clicked leave race and the logs shall be finished, every single time rf2 sort of died and went straight to desktop rather than into the main menu. Both times no logs or replays got created. Its like soemone pressed alt+F4 - anyone any clues?
     
  16. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Joggel_3000 can you give me access to download those logs? thanks
     
    Last edited: Apr 25, 2019
  17. Seven Smiles

    Seven Smiles Registered

    Joined:
    Oct 5, 2010
    Messages:
    828
    Likes Received:
    886
    Don't know if this helps but I ran a lap of Riverside with the AI driving (just to have a look at the circuit) and there was a pause of a second or two shortly after the race started. Logging, trace and replay
     

    Attached Files:

    Last edited: Apr 25, 2019
  18. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949
    @Seven Smiles , thanks could you switch to public-test branch and try there with Realtime Loggin on?
    thanks
     
  19. Viktor Jim

    Viktor Jim Registered

    Joined:
    Mar 21, 2019
    Messages:
    9
    Likes Received:
    0
    @4thworld Hi, today i activate the anticheat and i got the "Freezes" several times, here are the logs and replay
    PS: Same mod and track (radical/sao paulocircuit)


    Logs
    https://www.mediafire.com/file/m68vy8656uur6ip/Log.rar/file
    Replay
    https://www.mediafire.com/file/s7mr42uuf2ry2dy/SaoPaulo_GP_R1_4.rar/file

    Now i run with steam and Motec plugin on, no "Freezes" so looks like in my PC is the anticheat .dll making some problems, here are the logs and replay from this test.
    Logs
    http://www.mediafire.com/file/pvc6wib0ng6zzug/SaoPaulo_GP_R1_5_V5__RealTimeLogging_PSPFP.rar/file
    Replay
    http://www.mediafire.com/file/nldkmqdb16sarb8/SaoPaulo_GP_R1_5.rar/file
     
    Last edited: Apr 25, 2019
  20. 4thworld

    4thworld Staff Member

    Joined:
    Dec 17, 2016
    Messages:
    284
    Likes Received:
    949

Share This Page