[SOLVED] Lighting looks very flat and toxic grass syndrome (TGS)

Discussion in 'Technical & Support' started by adadadpd, Apr 23, 2015.

  1. adadadpd

    adadadpd Registered

    Joined:
    Apr 22, 2015
    Messages:
    5
    Likes Received:
    0
    Hey yall I've gotten Rfactor 2 recently and upon seeing some of others peoples videos I noticed that my game looks worse than it should. Noteabley the lighting is really flat for all courses and some courses have "TGS" as in, grass so bright I can't look at it directly. I run my graphical settings from medium to low so I realize that it might be an issue with my settings but I haven't really found any setting that relates directly to shading. Does anyone know of a solution either via tinkering or just changing some settings? thank you.

    Here are some picture so yall can see what I mean.

    View attachment 16469
    View attachment 16470
    View attachment 16471
    View attachment 16472
     
    Last edited by a moderator: Apr 23, 2015
  2. woochoo

    woochoo Registered

    Joined:
    Nov 3, 2010
    Messages:
    1,248
    Likes Received:
    2,555
    Hi,
    Well, the track in the first screenshot is mine, and it has suffered badly from the new filmic tone mapper changes in the last build. I had tried to tune the textures to the previous modified Reinhard (i think) mapping, but now a lot of things are too bright, including the grass. I'm not sure, but as a part of it it seems the white point has changed, which makes a lot of things that are fairly bright become too bright. Personally, a part of me died when I saw it for the first time. However, it makes more sense for me to change my stuff than ISI to change all of theirs.

    Just this morning I've made a list of things which i think I need to change, and I expect to be working on it not long after I've finished this post. Until the next Longford release, running it either side of the middle of the day is the best option to avoid the glare (maybe before 0900 or after 1500).
     
    Last edited by a moderator: Apr 23, 2015
  3. Guimengo

    Guimengo Guest

    Those images look like you either have something prior to build 880 or HDR off. ISI is gradually migrating to their version of HDR as standard, no LDR.
     
  4. adadadpd

    adadadpd Registered

    Joined:
    Apr 22, 2015
    Messages:
    5
    Likes Received:
    0
    My current build is 930 and I've always had HDR on.
     
  5. adadadpd

    adadadpd Registered

    Joined:
    Apr 22, 2015
    Messages:
    5
    Likes Received:
    0
    The lights at Sebring look incredibly odd too, I'm not sure if the two are related but they might be.

    View attachment 16473
     
  6. adadadpd

    adadadpd Registered

    Joined:
    Apr 22, 2015
    Messages:
    5
    Likes Received:
    0
    I took a picture at interlagos with the settings maxed, I don't really see much of a difference but I guess you guys can tell me if it seems correct / fine.

    View attachment 16474
     
  7. cosimo

    cosimo Registered

    Joined:
    Apr 14, 2013
    Messages:
    823
    Likes Received:
    94
    Build 946 has a new "tone mapper", and that has affected lighting very much, mostly for the better.

    Try it. You will see a big difference.
     
  8. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,819
    Likes Received:
    568
    +1, go to b946 with HDR ON
     
  9. McFlex

    McFlex Registered

    Joined:
    Feb 23, 2012
    Messages:
    737
    Likes Received:
    174
    and disable "legacy HDR profiles" if you perviously enabled them
     
  10. adadadpd

    adadadpd Registered

    Joined:
    Apr 22, 2015
    Messages:
    5
    Likes Received:
    0
    I had no idea that I wasn't on the most current build, thanks guys sao paolo looks a lot better now!
     
  11. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,819
    Likes Received:
    568
    Good, screens to compare? please.
     
  12. Guimengo

    Guimengo Guest

    Remember to go to your Userdata/Log folder and clear both Shaders and CBASH. It may do you well to get a new player.json file.
     

Share This Page