[REL] LeMans (S397) Mod without Chicanes

Discussion in 'Locations' started by redapg, Jan 5, 2021.

  1. philrob

    philrob Registered

    Joined:
    Jan 12, 2012
    Messages:
    590
    Likes Received:
    1,239
    great news on the Waypoints
     
  2. Manfredk2

    Manfredk2 Guest

    Interesting, looking forward to your find. The function add waypoint in AIW editor seems to work only once without crashing
     
    svictor and atomed like this.
  3. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    If you want to know what i have done, provided it works properly, i can write a short Description about what i have done, here in this Thread.
    But be prepared, it will look a bit strange. :D
     
    makan, Manfredk2, svictor and 2 others like this.
  4. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    The new Version, with the fixed Cut Warning at the 2nd Chicane can be downloaded.
    The Link is in the first Post.
    @Flatspotter It would be nice if you could test it and post if it works for you too now.
    @Manfredk2 If i get a Confirmation, i will write what i have done. ;)
    @DJCruicky This Update should be visible in the Mod Manager. ;)
    IMPORTANT HINT: the new rfcmp File has the same Name (intentionally) like the old one.
    So if you have the old Version installed, do this:
    Before you start the Game, delete the Folder ..\rFactor 2\Installed\Locations\LeMans_2018\2.83noCh
    Then download the new rfcmp File, put it into the Folder where the old one is and overwrite the old one.
    Install the new one.
    Any Feedback is welcome.
     
  5. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    I drove the left lane, right lane, and straddling the center line through both chicanes and got no track warnings, so it looks like it's fixed! I deliberately cut the track in another place to verify track warnings were active.

    Thank you so much for fixing this! :)
     
  6. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    You are welcome and thank you for testing and Confirming. :)
    So @Manfredk2 here is the announced Description from what i have done:
    WARNING: long Text ahead. :D
    Just to remember, my Target was, to keep the 7 original AI Pathes in my Version, where the Chicanes are removed, because i didn't wanted to create them all again, what would have been necessary, when i would have made a complete new AIW File, with complete new Waypoints.
    In the first Version, i just deleted the Waypoints of the Chicanes and smoothed the Pathes in that Area.
    Unfortunately i only let the AI drive for testing, so that i didn't notice that there always was a Cit Track Warning in the 2nd Chicane.
    The Reason for the Warning was the missing Waypoints in that Part of the Straight, where the Chicanes are.
    So i had to find a Way, to add Waypoints in a Way there, that the AI would drive properly and the human Player doesn't get a Cut Warning anymore.
    I don't want to bore you with all what i tried out , that didn't work, so i only write what does work, that probably is not the only working Way to do it, but it works. :)

    To avoid, to get the modified AIW File crashing the DevMode, i used a combined Method, with using some Features from the AIW Editor and also manually Editing, because when you remove Waypoints, by using "delete Waypoints" in the AIW Editor, some Things get adapted automatically, like the Connection of the first Waypoint of the Pit Lane Waypoint Path with the main Track, for Example.

    What i did:
    I loaded the original AIW File and deleted (AIW Editor) the Waypoints of the Chicanes.
    At the first Chicane for Example, i deleted the Waypoints 1011 to 1059, that are 49 and saved Waypoints.
    Then i did add a new Waypoint Path in the 2 Gaps on the Straight (Waypoint Editor ->record a Path ->add new generic Path) and saved Waypoints again.
    Then i left the Track to the main Menu, reloaded it, took the Index Numbers of the new Waypoints and left the DevMode.
    Then i copied the Entries of the new Waypoints and pasted them into a new File, one new File for each Chicane and counted them.
    Let's say that i got 44 new Waypoints for the Gap of the 1st Chicane, so i had 49 old and 44 new Waypoints.
    Because, as said above, the AIW Editor manages some Things automatically, it is necessary to know the Count of the removed and the new Waypoints, because in the next Step, i only delete the old Waypoints, that are more than the new ones.
    In Case of the 1st Chicane it is 49-44=5.
    So i loaded the original AIW again and deleted (AIW Editor) the Waypoints 1055 - 1059 (5 Pieces) from the first Chicane, did the same Thing at the 2nd Chicane, saved Waypoints and left the DevMode.
    Now, from this last saved AIW, i cutted the Waypoints 1011 - 1055 (for the first Chicane) out of the AIW File and pasted them into a new File too.
    (I did use separate Files for the Waypoints that had to be replaced, to get a better Overview).
    Now i took only the Waypoint Positions from the new Waypoints, transfered them to the old Waypoints and pasted them back into the AIW File.
    After i did that for both Chicanes, i saved the edited AIW, made a Copy of it and loaded it into the DevMode again.
    Now the old Waypoints are moved to the Straight, but because the Corridors are the old ones (calculated in Relation to the Waypoint Position), they look a bit funny now.
    So i did "find Corridors", to get them aligned to the new Waypoint Positions, save Waypoints and leave the DevMode.
    BUT now, due to executing "find Corridors", all Corridors were affected, also the new Corridor of the PitOut, that is necessary for the new Cut Detection, that we of course want to keep.
    So i took the Copy of the AIW, took only the Sections with the new Waypoints at both Chicanes from the last saved File, where i did make the "find Corridors", pasted that into the Copy and used that as the new AIW.
    I loaded that new AIW and now i "only" had to edit the Corridors and Cut Track at the new Waypoints a little bit and smooth all 7 Pathes in that Areas.
    After that i tested it and the AI worked as it should and also the Cut Warnings for the human Player were gone.
     
    svictor, makan, atomed and 6 others like this.
  7. philrob

    philrob Registered

    Joined:
    Jan 12, 2012
    Messages:
    590
    Likes Received:
    1,239
    great job, quite a lot of work, just finding a way to manually do this.
     
    redapg likes this.
  8. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,609
    Likes Received:
    1,167
    Thank you for the explanation. I got lost after you said "WARNING: long Text ahead. :D".
    Just joking, I think I understood it :). Well done.
     
    redapg likes this.
  9. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Thank you.
    Yes, the most Work is to find the Way. ;)
    @DJCruicky Thank you
     
    Eric Rowland likes this.
  10. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    974
    Likes Received:
    6,599
    A great technical break through, this will help save a lot lot time, thanks for sharing.
     
    redapg, Eric Rowland and atomed like this.
  11. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    One thing I noticed that I missed before: The AI hit the brakes hard around the entrance to the 2nd chicane and lose a lot of speed.
     
  12. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    Thanks for reporting.
    With which Car does it happens?
    I just need to know that, because the AIW File, besides of the FASTEST (that works normal), has 3 more AIW Pathes.
    And because i smoothed all Pathes in the same Way, i only tested the FASTEST.
    Sorry for my Laziness in Testing, but after 17 Years of doing it, i've gotten a bit tired of it, to be honest. :D
     
  13. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    It was with the GTPC 1984 cars. Don't worry about testing, I'm just happy we have people like you helping the community!
     
    redapg likes this.
  14. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    The cars are traveling in the right lane, if that helps.
     
  15. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    @Flatspotter I could replicate it, but i also have seen, that not all Cars brake there.
    It seems to be influenced by how close the Cars are together and on which Path they drive (a FAST or the Block Path).
    I will investigate... :)
     
    Eric Rowland likes this.
  16. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    @Flatspotter I think i've found the Problem, even if it's a bit strange.
    2 Waypoints, an old and a new one were too close together and that made some Cars braking there.
    The strange Thing is, that, when i smooth the Pathes, i, of course, always focus on if the Cars slow down in the smoothed Area and that wasn't the Case.
    But it's rFactor, so.... :D
    Tomorrow i will package it and test with the GTPC 84 and some other Cars in the main Game.
    If the Problem is fixed there too, the new (and hopefully last :D) Update will be available Tomorrow too.
     
    Corti and pkelly like this.
  17. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    I think they're braking closer to the exit of the chicane before the kink.
     
  18. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    The new Version, with the Fix, to avoid some Cars braking after the 2nd Chicane is available and can be downloaded in the first Post.
    Just to tell it: After i fixed the Problem in DevMode, i packaged the Mod an tested it in the main Game.
    But there, the GTPC and also the Porsche RSR 1973, were still braking after the 2nd Chicane.
    BUT other Cars, like the Peugeot 207 (SMMG), IR18, M6 GT3, Oreca 2007 didn't do it.
    So at first, i thought that there must be something wrong with these Mods.
    Then i took the RSR 1973 into the DevMode, to try to fix it for that Car too and after some more Smoothing, also in Areas that i didn't have modified, it seemed to work.
    I have also made a short Test with the GTPC 1984 Lancia LC2 and Porsche 956 in the main Game again and it seems to work for these Cars too now.
    But who knows.
    If Problems appear, please report here again. :)

    IMPORTANT HINT: the new rfcmp File has again the same Name (intentionally) like the old one.
    So if you have the old Version installed, do this:
    Before you start the Game, delete the Folder ..\rFactor 2\Installed\Locations\LeMans_2018\2.83noCh
    Then download the new rfcmp File, put it into the Folder where the old one is and overwrite the old one.
    Install the new one.
     
    svictor, vava74, Flatspotter and 3 others like this.
  19. Flatspotter

    Flatspotter Registered

    Joined:
    Oct 7, 2010
    Messages:
    381
    Likes Received:
    122
    I did a quick test and most cars go through the 2nd chicane correctly. I did see one car brake and swerve to the right, though. It was in the right lane and swerved almost to the guardrail. I wasn't able to figure out which car it was, but I'll keep testing.
     
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    4,207
    Likes Received:
    3,044
    It also would be good to know, if that Car did have another Car in Front and in which Distance, because it also can just be the Effect of the AI using the BLOCK Line or just leave their FAST Line, in Combination with the AI still not always try to overtake, even if they are faster, coming out of the Slipstream from a Car that is in Front of them.
    They brake, instead of trying to overtake.
     

Share This Page