[SOLVED] Launcher will not launch

Discussion in 'Technical & Support' started by Ivor Thomas, Jan 10, 2020.

  1. Ivor Thomas

    Ivor Thomas Registered

    Joined:
    Jun 19, 2017
    Messages:
    12
    Likes Received:
    1
    Hi, I have insufficient privileges to post where it should go, but here goes.

    I have the steam version of the game, have had it for a long time and never had a problem but after a recent reinstall of windows, the game launcher won't start. I can start the game by creating a shortcut to the game exe and removing 'bin32' from the target and the game will start. It's just the launcher, therefore I can't get online. I have tried...verifying files, installing on a different drive, manually installing redistributables, running cpu, memory, gpu at stock speeds, no overclocking, clearing all references to rfactor from the registry and then reinstalling, trying to manually install a mod as never get as far as synchronising with the workshop.

    Will attach DXdiag report. Thanks in advance
     

    Attached Files:

  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,879
    Likes Received:
    2,668
    The support question section is posted in via the Launcher, so here is fine.

    Did you run all 4 files in the Support\Runtimes folder?

    Does the windows event viewer show anything from the launcher when it fails to start?
     
  3. Ivor Thomas

    Ivor Thomas Registered

    Joined:
    Jun 19, 2017
    Messages:
    12
    Likes Received:
    1
    No, only the 2 x 64. No you dont see anything other than windows showing its starting the launcher. No activity from the launcher.
     
  4. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    6,879
    Likes Received:
    2,668
    Run all 4, including 32 bit. It sounds strange, but you need to do it.
     
  5. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,336
    Likes Received:
    1,226
    You can also try deleting the player and controller json files, back them up first though. I had that issue before and that solved it.
     
  6. Ivor Thomas

    Ivor Thomas Registered

    Joined:
    Jun 19, 2017
    Messages:
    12
    Likes Received:
    1
    Thanks everyone, I installed the 32 bit runtimes and that did the trick :)
     
    Lazza likes this.

Share This Page