Launcher EXE for those affected by 7/18-7/20 DNS change

Discussion in 'General Discussion' started by 88mphTim, Jul 23, 2013.

Thread Status:
Not open for further replies.
  1. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    125
    Hi folks,

    Here is a launcher for those of you affected by the DNS change (forgetting credentials). Just replace your existing one in the core folder.

    -snip-

    Thanks,

    Tim
     
  2. Sentri

    Sentri Registered

    Joined:
    Jan 11, 2012
    Messages:
    71
    Likes Received:
    0
    That worked, didn't even have to re-enter my log in info. (we need a thumbs up emoticon)
     
  3. Don Fryman

    Don Fryman Registered

    Joined:
    Nov 3, 2011
    Messages:
    35
    Likes Received:
    6
    Yep, worked great here!!
     
  4. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    +1, seems to be remembering the login info now, haven't managed to make it misbehave yet.
     
  5. ProTraX

    ProTraX Registered

    Joined:
    Jan 16, 2012
    Messages:
    271
    Likes Received:
    3
    Thanks! Worked perfect
     
  6. Max Angelo

    Max Angelo Registered

    Joined:
    Oct 5, 2010
    Messages:
    4,958
    Likes Received:
    10
    Thanks guys, it works well! :)
     
  7. renard

    renard Registered

    Joined:
    Jan 12, 2012
    Messages:
    91
    Likes Received:
    1
    That's fixed it! Thanks. :)
     
  8. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    What's happening about the 'Manage Account' option, is this coming back?

    Edit:

    Just made it misbehave.

    Opened the launcher, logged in, clicked 'remember', then closed and reopened launcher a few times just to check the log in was sticking ok which it appears to.

    I then fired up the MAS tool (I'm logged in at this point or I should be) and made a vmod. The moment I clicked on the 'Package' button, the 'Register Package' came up as expected but the 'credentials' file was deleted. Therefore the email and password fields were empty which of course mean't I had to log in again.
     
    Last edited by a moderator: Jul 23, 2013
  9. Noel Hibbard

    Noel Hibbard Registered

    Joined:
    Oct 5, 2010
    Messages:
    2,744
    Likes Received:
    28
    Works perfect for me. Thanks Tim/ISI!
     
  10. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    125
    Congrats! I let them know. :)
     
  11. yulius

    yulius Registered

    Joined:
    Dec 23, 2011
    Messages:
    3
    Likes Received:
    0
    perfecto;);)
     
  12. Sylpheed

    Sylpheed Registered

    Joined:
    Jul 4, 2013
    Messages:
    6
    Likes Received:
    0
    Thanks ! it was quite annoying, now working perfectly :)
     
  13. Black Dice

    Black Dice Registered

    Joined:
    Jun 9, 2013
    Messages:
    426
    Likes Received:
    0
    Thanks Tim
     
  14. ceSniper

    ceSniper Registered

    Joined:
    Oct 14, 2012
    Messages:
    17
    Likes Received:
    0
    oh man!
    I used to have zero problems, lately I seem to have them all...

    I saw the post on facebook about the replacement "launcher rfactor.exe" so I went and check if mine was ok.
    first difference, it is asking me to log in, I do, click on "online race" and take a looong time to load and then the server list is emptly.
    So I assume my "launcher" is not good, download this fix, replace the old one and click....again it asks me to log in but now I get this message: "Login attempt resulted in unknown server response. Login attempt was not successful." but I am logged in, the "online race" box is not grey anymore, so I click, go to online and now the server list appear. However, when I click on a server and try to use the "get mod" feature (to see what tracks Im missing), the game does nothing, and when I click on "cancel" it freezes and I have to "ctrl+alt+delete" to open the task manager and shut it. what may be wrong?
     
    Last edited by a moderator: Jul 23, 2013
  15. Jorgen

    Jorgen Registered

    Joined:
    Oct 5, 2010
    Messages:
    558
    Likes Received:
    3
    Thanks for the update Tim! Auto-login now works. It's very slow though, it takes several seconds before the bottom pane welcome message appears. The account details function in the purchase tab is still broken though, I can log in and receive the welcome message, but it stops there. Previously I could look at my account details, register and unregister Mod IDs, etc. Now I just see the "Purchase" and "Activate" options. I also get a "Purchasing Temporarily Unavailable" error message when clicking on the logout button. Known issues?
     
  16. Eaglerapids

    Eaglerapids Registered

    Joined:
    Jan 19, 2012
    Messages:
    33
    Likes Received:
    0
    Ty Tim, works great!
     
  17. Arnao

    Arnao Registered

    Joined:
    Nov 23, 2010
    Messages:
    338
    Likes Received:
    26
    Thanks Tim ... same issue here
     
  18. Foxiol

    Foxiol Registered

    Joined:
    Nov 23, 2011
    Messages:
    380
    Likes Received:
    8
    Now the Launcher works again.

    Thank you Tim. :D
     
  19. Jonathon LeFaive

    Jonathon LeFaive Registered

    Joined:
    Jan 11, 2012
    Messages:
    70
    Likes Received:
    0
    The manage account option is being moved to an account tab in the launcher that will be introduced in a future build. The reason for this move is so that we can expand on the abilities of the user account.

    Mod registration can be done through the MAS2.exe until the account tab is ready. Considering that the "Remember" issue may have caused a lot of you to reset your passwords recently, I will plan on reimplementing a "change password" page under the purchase tab in the coming days.
     
  20. Jorgen

    Jorgen Registered

    Joined:
    Oct 5, 2010
    Messages:
    558
    Likes Received:
    3
    Sounds good Jonathon, thanks for the heads-up! :)
     
Thread Status:
Not open for further replies.

Share This Page