Released Latest Release Candidate - June 2021

Discussion in 'News & Notifications' started by Christopher Elliott, Jun 10, 2021.

  1. Alexandr Meshkov

    Alexandr Meshkov Registered

    Joined:
    Jun 20, 2017
    Messages:
    166
    Likes Received:
    72
    With RC build I have many CTDs in DevMode. Every time trace files ends with

    main.cpp 321: onFatalError 11

    it happens when I work with material editor
     
    Last edited: Jun 11, 2021
  2. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,237
    Likes Received:
    309
    If we update our server to the RC version will people that are on the standard version be able to join the server still?
    At the moment we are running the standard version but people that are on the RC version can not join.
    20210611123423_1.jpg
    Thank you for the updates.
     
  3. bobbie424242

    bobbie424242 Registered

    Joined:
    Oct 17, 2017
    Messages:
    222
    Likes Received:
    317
    Come back in 2035.
     
  4. Andy Bonar

    Andy Bonar Registered

    Joined:
    Mar 17, 2011
    Messages:
    614
    Likes Received:
    76
    All have to be on the same version with this RC update.
    People can easily change back and forward if they need to though.
     
  5. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    76
    Likes Received:
    83
    Great job S397! SSR and Cloud are fine.
    But please add Skip button in setup wizard.
    Thank you ;)

    P.S.
    contents.jpg
    Please allow multiple selections:D
     
    Last edited: Jun 11, 2021
  6. philman

    philman Registered

    Joined:
    May 7, 2011
    Messages:
    357
    Likes Received:
    137
    It is certain that the latest graphic developments made by S397 have greatly improved the perception of rfactor2 especially with the SSR.
    Unfortunately, there is still a lot to do with the reflections of artificial lights on wet track for example. Currently the headlights of the cars do not reflect on the track; the same for the rear lights.
    Since I mentioned rain, there is also a lot of work to be done with water splashes from vehicles. Currently, the spray seems to come from under the car when it should be coming from the front and rear tires.
    And I won't even mention the sparks!
     
    Alexandr Meshkov likes this.
  7. Comante

    Comante Registered

    Joined:
    Nov 20, 2013
    Messages:
    1,409
    Likes Received:
    919
    In truth the matter is more complex, because aero car suck water from the undertray and propel it upward, so the spray should be generated by tires AND carbody. I can actually live with the actual graphic development, I tried a rainy track and while not a rendering, it look very immersive and credible.
     
  8. bo1210

    bo1210 Registered

    Joined:
    May 6, 2018
    Messages:
    58
    Likes Received:
    15
    Tried that, but still getting "Core component 397HUD v.108 is missing, invalid or damaged."

    NEVER MIND, RESOLVED!

    I deleted a few more of the rF2 core files, then ran Goanna's new SteamCMD command with the added switches. Server now 1125. THANK YOU, GOANNA!
     
    Last edited: Jun 11, 2021
    Goanna likes this.
  9. Dady Cairo

    Dady Cairo Registered

    Joined:
    May 11, 2017
    Messages:
    219
    Likes Received:
    123
    As you are waiting,try AMS 2 it has these features.:)
     
    leseb64 likes this.
  10. AlexHeuskat

    AlexHeuskat Registered

    Joined:
    Feb 21, 2020
    Messages:
    535
    Likes Received:
    350
    AMS 2 is casual, here you are at the rF2 forum...a sim where you we can spin with GT3/GTE/LMP....I understand you like pushing the throttle without any control or nuance, but I think it's for that we play rF2.
     
    Pawel44 and juanchioooo like this.
  11. bobbie424242

    bobbie424242 Registered

    Joined:
    Oct 17, 2017
    Messages:
    222
    Likes Received:
    317
    Here's a bug report, not sure if this is new.

    When you start a race and it is raining, the game automatically enable wipers (and yes, I have them bound to a wheel button in settings). Not only this is annoying because it enables them at fast speed (would be more sensible to use slow speed), but cycling wiper modes (off, slow, fast) using wheel button does not work until you do a full cycle, as if current wiper state was not in sync with what wheel button think it is.

    Is there a way to disable automatic wipers enabled if race starts with rain ?
     
  12. Dady Cairo

    Dady Cairo Registered

    Joined:
    May 11, 2017
    Messages:
    219
    Likes Received:
    123
    Yes,8 years expirience can't be beat'n...and you where there when it happend.
    (sarcasm off)
     
  13. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,029
    Likes Received:
    209
    Hi, I found an issue. If a practice sessioin start with rain, I can hear only rain falling. No engine sound no tyres just rain FX. In my case it was a McLaren MP4/8 at Silverstone. I'am able to reproduce the issue. Dry session was fine.

    EDIT: I had also some strange volume chages in a dry session.

    However reboot of my system solved the issue for now. :)
     
    Last edited: Jun 11, 2021
    Magus likes this.
  14. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,746
    Likes Received:
    2,660
    yes, there are new settings that control wipers, headlights, & several other new options. (well, new a month or so ago). So, not a bug. Look in the difficulty settings before you launch to a track.
     
  15. 3NPV5IRR

    3NPV5IRR Registered

    Joined:
    Feb 27, 2014
    Messages:
    99
    Likes Received:
    45
    This was the only line of Player.json causing the FPS drastic drop: ""Max Framerate":92,". Returning the value to "0" solved it. In previous builds it helped not to overload too much GPU.
     
    juanchioooo likes this.
  16. bobbie424242

    bobbie424242 Registered

    Joined:
    Oct 17, 2017
    Messages:
    222
    Likes Received:
    317
    Thanks, I missed these. However, the fact that wiper button is not synchronized with automatically enabled wiper state is a bug.
     
    Last edited: Jun 11, 2021
  17. AlexHeuskat

    AlexHeuskat Registered

    Joined:
    Feb 21, 2020
    Messages:
    535
    Likes Received:
    350
    9 years ago, and even in 2021, nothing beats rF2 physics....so AMS2....

    I think you have posted in the wrong forum, here what you want:
    https://forum.reizastudios.com
    About the new release, I will post beauty screenshots later, I have so much to do...
     
    Last edited: Jun 11, 2021
  18. leseb64

    leseb64 Registered

    Joined:
    Jul 6, 2020
    Messages:
    192
    Likes Received:
    528
    with the same physics bug for XX years...track/tire/air temperatures with no correlation or dependency... If rf2 was the best on the physics of the tyre, today it is not the case any more if you do not want to see it or to understand it it is not serious, I follow and support rf2 since the beta and I note that other games arrives at the same level to see lu passes before on the physics, even if I have a good feeling flying because yes the FFB is really a must it has enormously of prioblemes and advances too slowly compared to the others
    For mo ACC makes better GT3, raceroom has an online ranked with nice complete series and if the future update keeps its promise it will be very good, AMS2 comes to rand not the physics and FFB are really better and better, in short rf2 has to worry!
     
    Pawel44 likes this.
  19. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,535
    Likes Received:
    7,420
    Please stay on topic ;)
     
    atomed, Reiche and lagg like this.
  20. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    811
    Likes Received:
    515
    Had some strange audio issues too. Engine/rev sound would cut out on bumps, could faintly hear the tires but no engine sounds. Cuts in/out. Exited game, reloaded, same issue. Didn't try a PC reboot.
     
    Juergen-BY, Corti and TJones like this.

Share This Page