[REL] Latest Build Update rFactor 2 - 1.1118 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, May 21, 2020.

  1. Keeper

    Keeper Registered

    Joined:
    Feb 17, 2011
    Messages:
    23
    Likes Received:
    17
    I'm having my own issues now. rF2 simply has stopped working. Back to the old UI, it will lock up and not allow any buttons to be clicked, except for a split second every few minutes. I returned to the new UI and that works smoothly, but it stops at about 96 or 98 percent of track loading. I've let it sit there for over 15 minutes on two different occasions.

    EDIT: Solved. For some reason my audio driver settings changed and no applications were able to play sound. rF2 thus was hanging as it tried to activate the sound driver.
     
    Last edited: May 24, 2020
  2. Mark Lloyd

    Mark Lloyd Registered

    Joined:
    Mar 18, 2020
    Messages:
    27
    Likes Received:
    10
    Yes
     
  3. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,575
    Likes Received:
    3,208
    Technically it's just copying your view - so if you turn your head that's what it will show. For you to turn your head but it to show the 'straight ahead' view, would be rendering a second view - which is what they don't do for those screens as it would add a lot of processing. Same as showing a trackside cam or another on-car camera view.
     
    buzz hornet likes this.
  4. atomed

    atomed Registered

    Joined:
    Jul 9, 2019
    Messages:
    244
    Likes Received:
    148
    Yes, I understand the reasons and repercusions of it and agree with you, I'm not talking about that. What I am saying is that you see the VR effect in the track screen and just feels wrong, sometimes can even produce motion sickness even if you don't pay attention to the screen.
     
    Ariff likes this.
  5. Jaileh

    Jaileh Registered

    Joined:
    Sep 6, 2018
    Messages:
    5
    Likes Received:
    3
    Where are located the files of the overlay? I'd like to mess around with the css.
     
    mixer61, lagg and buzz hornet like this.
  6. mesfigas

    mesfigas Registered

    Joined:
    Oct 15, 2015
    Messages:
    1,325
    Likes Received:
    668
    Day to night transition is really smooth
    graphical update is good
    i hope for more improvements in the future
     
    atomed and Jaileh like this.
  7. Balazs Magyar

    Balazs Magyar Registered

    Joined:
    May 8, 2017
    Messages:
    145
    Likes Received:
    112
    Dear Devs,
    What have you done in this update? My fps rate is significantly! (30-40%) higher in wet conditions.
    I can drive on a wet circuit for the first time, without graphics compromise.
    Excellent job, thanks!
     
    Emery, pkelly, atomed and 1 other person like this.
  8. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,308
    Likes Received:
    6,524
    Parc Ferme works in the new UI, this is just an issue with 'caching' the open setup. The setup seems open, but once you toggle one value it will show you the locked version. We tested this today. If you have any other details please feel free to report those, thanks.

     
    Last edited: May 25, 2020
    juanchioooo, Travis, Davvid and 2 others like this.
  9. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    196
    Likes Received:
    42
    thanks for update and for the new GUI. :)
    With the new GUI, i only see a grey loading screen, while loading the track .
    I do not see the xx_loading.jpg and the other icons.
    Did i missed something to switch on?
     
    Last edited: May 25, 2020
  10. Leonardo1962

    Leonardo1962 Registered

    Joined:
    Feb 12, 2012
    Messages:
    196
    Likes Received:
    42
    The track now get's really dammed slippery, when getting wet.
    Great job, really great. I didn't notice that so far.
     
  11. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    2,917
    Likes Received:
    1,677
    No, the track map is generated and that is what has replaced all the other loading graphics.
     
  12. fireballR18

    fireballR18 Registered

    Joined:
    May 10, 2018
    Messages:
    261
    Likes Received:
    244
    Someone checked if forced setups for car/track releations work for AIs as well?
    I mean it did not work in the previous build.
     
  13. RoWo

    RoWo Registered

    Joined:
    Jul 16, 2014
    Messages:
    312
    Likes Received:
    364
    Can someone help, please! Can not find, where to select showroom in the new UI.

    "We’ve now included options to select a custom showroom and HUD."
     
  14. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    964
    Likes Received:
    136
    If I'm not wrong, it's in the graphics options.
     
  15. RoWo

    RoWo Registered

    Joined:
    Jul 16, 2014
    Messages:
    312
    Likes Received:
    364
    Yes, you are right. Thanks.
     
    TJones likes this.
  16. wmann

    wmann Registered

    Joined:
    Feb 19, 2012
    Messages:
    159
    Likes Received:
    98
    Yes, I've tried, but to no avail.
    By the way, a question about the overlays: when can we see them as players while driving? At the moment they can only be seen in replay, but when will the driver be able to see them while driving?
     
    Leonardo Nogueira likes this.
  17. Stefan_L_01

    Stefan_L_01 Registered

    Joined:
    Nov 18, 2012
    Messages:
    425
    Likes Received:
    244
    In the P2 event, when server was closed in 2 red flag situations, me and a team driver encountered total hangup of rf2 (old gui). This is really new, so far the disconnect worked well when server closed.
     
    buzz hornet likes this.
  18. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    1,070
    Likes Received:
    1,089
    ok perfect, everything is solved, thank you very much and sorry for the inconvenience
     
  19. Keeper

    Keeper Registered

    Joined:
    Feb 17, 2011
    Messages:
    23
    Likes Received:
    17
    The broadcast overlays are never seen while driving. They're for broadcast streams.

    In the new UI, vehicle labels are always off. Any reason for that? No key assignment works to enable them.
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,575
    Likes Received:
    3,208
    I think they haven't been activated yet in the new UI.
     

Share This Page