Latest Build Update rFactor 2 - 1.1115 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Aug 20, 2019.

  1. Gonzo

    Gonzo Member

    Joined:
    Oct 5, 2010
    Messages:
    821
    Likes Received:
    240
    great stuff, good that all those issues get finally adressed. i always knew you would do at some point. sad that some other bugs came up, but thats life in development. Improved loading times is important to me.

    keep on going, a lof of issues are left, hunt them! :D
     
    Rui Santos likes this.
  2. edilsoncarneiro

    edilsoncarneiro Registered

    Joined:
    Feb 15, 2013
    Messages:
    3
    Likes Received:
    0
  3. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,234
    Likes Received:
    5,553
    Latest Build Update rFactor 2 - 1.1114 Now Available!

    Steam Build IDs
    client: 4128876
    dedi: 4128877

    Note: Admins must update all dedicated servers

    Changelog:
    - fixed server log outputting too much info
    - fixed server steam matchmaking info announcement
    - fixed dedicated server installation crashing when no steam client was installed on the machine
     
    emha76, McKiernan, lagg and 11 others like this.
  4. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    58
    Likes Received:
    34
    Does anyone use plugins? (Liveracers, realweather) They are not working on our server since 1114.
    However, the latest build update is cool. The server is online!
     
  5. gorgias1976

    gorgias1976 Registered

    Joined:
    Feb 25, 2012
    Messages:
    927
    Likes Received:
    82
    Servers up and running
     
  6. GrimDad

    GrimDad Registered

    Joined:
    Oct 9, 2010
    Messages:
    488
    Likes Received:
    291
    Thank you!

    Edit: @helyesadi
    My liveracers is working
     
    Last edited: Aug 22, 2019
  7. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    77
    Likes Received:
    7
    Gents,

    Sorry for the dumb question but if I do
    Code:
    steamcmd +login anonymous +force_install_dir ../rFactor2-Dedicated +app_update 400300 +quit
    It says that "App 400300 already up to date", however I have only v1112.
    How can I get the latest release ? (BuildID: 4128877)

    Do I need to use the -beta v1114 parameter ?
     
  8. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    608
    Likes Received:
    388
    No, it should update with the command you have...add validate to the command line between 400300 and +quit ie
    steamcmd +login anonymous +force_install_dir ../rFactor2-Dedicated +app_update 400300 validate +quit
     
  9. zmitya

    zmitya Registered

    Joined:
    Jun 29, 2011
    Messages:
    77
    Likes Received:
    7
    it does work now, maybe it was not there in the repo when I tried I am not sure...
    Thanks ! :)

    also thanks for S397 for the quick fix...
     
    Goanna likes this.
  10. helyesadi

    helyesadi Registered

    Joined:
    Feb 8, 2017
    Messages:
    58
    Likes Received:
    34
    The plugins working now. We solved this problem.
     
  11. MaD_King

    MaD_King Registered

    Joined:
    Oct 5, 2010
    Messages:
    1,799
    Likes Received:
    558
    Working, thank you for the efforts and fixes.
     
  12. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    1,059
    Likes Received:
    709
    It's working now.
    Thank you very much.
     
  13. Ralffan

    Ralffan Registered

    Joined:
    Jan 30, 2014
    Messages:
    37
    Likes Received:
    3
    Working fine now.

    Thank you!
     
  14. Mr.Thor

    Mr.Thor Registered

    Joined:
    May 25, 2013
    Messages:
    223
    Likes Received:
    15
    Thanks for the update.
    But when i exit the dedi server, the confirmation window pops up but i can't do anything anymore. Have to kill rf2dediserver with task manager.
     
  15. Ralffan

    Ralffan Registered

    Joined:
    Jan 30, 2014
    Messages:
    37
    Likes Received:
    3
    Same here. but we have this problem since a while ago that we execute some servers with different player profiles but same installation.

    A new issue we have: Number of players is not refreshed in Steam server list. There were 21 cars ingame, then 0 but steam kept saying 21, then I entered and when I left there are 22 players in Steam list. I don't know if it will increase until maximum xD.
     
  16. Mr.Thor

    Mr.Thor Registered

    Joined:
    May 25, 2013
    Messages:
    223
    Likes Received:
    15
    correct, it did not start with build 1114. it was already with 1112, maybe earlier, don't remember. But i am pretty sure, somewhere here in the forum i read from someone of S397, they know about it and will be fixed with a comming update. Just don't want this bug to be forgotten.
     
  17. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,234
    Likes Received:
    5,553
    Latest Build Update rFactor 2 - 1.1115 Now Available!

    Steam Build IDs
    client: 4130253
    dedi: 4130254

    Note: Admins must update all dedicated servers

    Changelog:
    - Fixed an issue with 'fixed setup' servers that caused all garage parameters to stay open.
    Please note: this latest fix reverted a previous fix where after a disconnect/rejoin in-car pit-menu options are locked. We are working to fix this issue again asap.
     
    Travis, Gonzo and McKiernan like this.
  18. DanaSmoky

    DanaSmoky Registered

    Joined:
    Dec 25, 2018
    Messages:
    2
    Likes Received:
    0
    after rFactor 2 -1.1115 update
    Can't see any servers in the lobby
     
  19. nonamenow

    nonamenow Registered

    Joined:
    May 3, 2017
    Messages:
    355
    Likes Received:
    178
    Right now I see 74 servers up with new build.
     
  20. Discovery.Tv

    Discovery.Tv Registered

    Joined:
    Nov 6, 2016
    Messages:
    4
    Likes Received:
    2
    After this new build we are getting huge freezes in race sessions when someone DNF's and leaves the server.
     

Share This Page