[REL] Latest Build Update rFactor 2 - 1.1112 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Nov 30, 2018.

  1. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,067
    Likes Received:
    4,591
    We don't delete anything from your folders, if a skin is not showing in the UI, go to:
    ...UserData\player\Settings\carname\yourteamname\alt_....dds
    Try making a new team with that skin and that should solve it.
     
    Hocician, JimmyT and lagg like this.
  2. gluon

    gluon Registered

    Joined:
    Jan 27, 2019
    Messages:
    57
    Likes Received:
    114
    For what it's worth, I can confirm that the last build fixed the AI livery issue. All my custom liveries work perfectly now as virtual rides and also during replays.
     
    mr.Sw1tchblade and Hocician like this.
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,549
    Likes Received:
    909
    I got the one skin I've been testing with to show up as an available car. It's the #95 GTE WEC skin for the Aston Martin. It shows up as that yellow green car in the tuning hanger and loads to the track, but once at the track, the custom yellow/green skin was not shown. It had the same silver/grey as the GT3 01 car it was alt'ed from.
    I'll try one more method, that listed by Christopher above. gettin' there..
     
  4. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    179
    Likes Received:
    518
    I have 242 custom skins installed for the older GT3 cars and the endurance pack and not one works. This is a problem S397 has created by not beta testing before release. When you shut down RF2 the list of beta testers is really long, why did't any one of them see the glaring bugs created by these updates. If beta testers are being paid, there not doing what there paid for. This situation has really annoyed me because I really enjoy this sim, I have over 6000hrs on this sim according to steam.
     
    Bostrom, bears and GrimDad like this.
  5. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    891
    Likes Received:
    1,615
    Easy fix for skins not working.
    Open the car you are working on in he showroom. Create a alt for one off the new cars, Click CREATE DIR.
    upload_2019-2-22_7-39-31.png
    This will put a folder in your setting. All you need from this is the new veh name.
    upload_2019-2-20_16-43-48.png

    Copy the folders name (veh) and pasd in the rcd file
    upload_2019-2-20_16-46-37.png
    Now the skins will show.

    Known issue. These cars don't have a region. They don't really need one because they will load and use the default one in the Main car Mas that contains all the cars textures.
    Issue is the person who put that folder (Mas) together annoyingly but all to common put a livery and it's region into the Main Mas instead off a blank White car and a base region.
    This means the region will ghost through your livery add-on so those "who can" will have to make a base region with Car Paint. Which "should" be the default !!! To cover over someone else's rubbish.
    Sorry for that, Wasn't me. I know better!
     
    Last edited: Feb 21, 2019
    Ernie likes this.
  6. BullGod

    BullGod Registered

    Joined:
    Jan 15, 2012
    Messages:
    14
    Likes Received:
    6
    Thanks for the info.
    I am not opposed to correcting some errors that skin creators make (like being added to the main mas), and am willing to do the work to make an alt to try and get the skins working again, but I am afraid I might need to ask for help/guidance. The above mentions creating an ALT. Is that accomplished using the MAS tool? I will poke around and try and figure it out myself, i just thought I would ask the community.
    (I always backup my custom "stuff", so that is not an issue, I have multiples iterations available.

    I will also verify the version my rig is running to be sure that is correct and up to date. I saw the content update, but it is possible it has another small update that was missed and it will be corrected next time i fire up the sim.
    I will do that before i monkey with the mas editor for an alt.
    Thanks all!! great community here.
    -BG

     
  7. Yuriznikov

    Yuriznikov Registered

    Joined:
    Nov 29, 2016
    Messages:
    19
    Likes Received:
    6
    Sigh, i got the skins to work in the tuning screen but the AI arent showing in them on track :(. The crappy thing is i was about to do a 12hrs endurance race with an all IMSA field. Turns out nothing works after some update and i get to spend hours and hours to figure out how to get it working again.

    I did change all the .rcd files for the skins to the new VEH file name, and for the skins which iddnt have it added xxxxxalt.dds to the filename and .rcd file that belongs to it..

    Pretty clueless now, ive fiddled alot with RF2 files and settings but cant figure this one out.
    p.s. skins do show up for the player driven car, thats what i find most strange
     
    Last edited: Feb 21, 2019
  8. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,549
    Likes Received:
    909
    same here Yuri, ONE of the issues is the driver name in the rcd file. From what I've read, you can't have two cars with the same driver name. That is going to be a real bug-a-boo as users try to assemble cars from different series and seasons where the same drivers appeared in numerous cars.
     
  9. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    407
    Likes Received:
    213
    With custom skins it's always been thus. Nothing has changed in that regard.
     
  10. lynx75

    lynx75 Registered

    Joined:
    Jan 8, 2019
    Messages:
    37
    Likes Received:
    28
    Sorry guys, Is a new GT3 patch is available, isn’t it ? I’ve tried this evening but I did not get any update from Steam?

    Please help.

    Thank you
     
  11. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    407
    Likes Received:
    213
    The only update I saw annonced was this one.
    Which, as stated, is an update for the game which will have an effect on custom liveries.
     
    lynx75 likes this.
  12. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    891
    Likes Received:
    1,615
    Added the step 1 to original post.
     
  13. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    891
    Likes Received:
    1,615
    No alt cars aren't loading to AI. Studio 397 are aware and are working on the problem.
    There's nothing we can do but wait.
     
    Last edited: Feb 22, 2019
  14. BullGod

    BullGod Registered

    Joined:
    Jan 15, 2012
    Messages:
    14
    Likes Received:
    6
    THANKS D, I appreciate the follow up, and your willingness to elaborate.
    Always a great community.
    -BG

    [Edit] - I attempted using this fix, but was not successful. I may be tired and more importantly doing something wrong. I am going to pull my skins for now, and wait a few days to see waht shakes out.
    For now,I want to drive, and not worry about the skins that I had working two days ago. Thanks to all that helped!
    I'll check back.
    -BG
     
    Last edited: Feb 22, 2019
  15. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    407
    Likes Received:
    213
    Skins are loading to AI for me since the small update the other day :)
    Post #84 in this thread
    "
    Christopher Elliott said:
    (A small update to fix the AI custom livery issue)
    Latest Build Update rFactor 2 Steam Build IDs
    client: 3566541
    dedi: 3566543

    Note: It is recommended that server Admins update all dedicated servers.

    >>>>Changelog is the same: <<<
    - Fixed: Sporadic corrupt textures after track load.
    - Fixed: AI cars and replays now show custom liveries.
    - Added: Button assignments for mouse controls (right/left/up/down) and mouse left click. Controls can be assigned to any button on a keyboard, button box, D-pad or other.
    "
    :)
     
  16. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,549
    Likes Received:
    909
    nevermind: very small numbers but I found it.
     
    Last edited: Feb 22, 2019
  17. D.Painter

    D.Painter Registered

    Joined:
    Oct 5, 2010
    Messages:
    891
    Likes Received:
    1,615
    Not for me. The windows load but not the liveries.
    Also the Mas files are deleting all the files out off them if you refresh the car in the showroom.

    I have done the usual checks. It's not my end.
     
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    1,549
    Likes Received:
    909
    Same, I can get a player car loaded. But if I refresh, it brings back the original skin.
     
  19. RockShark

    RockShark Registered

    Joined:
    Oct 29, 2018
    Messages:
    15
    Likes Received:
    17
    Are these the Mas files the game generates or are they ones you have made?
    I haven't created a Mas file now that the game generates them.
    The AI are using my skins in single player. I have created a driver for each one.
     
  20. Bostrom

    Bostrom Registered

    Joined:
    Jul 1, 2018
    Messages:
    20
    Likes Received:
    12
    Does not work, not even after the last patch. :(
     

Share This Page