Latest Build Update rFactor 2 - 1.1110 Now Available!

Discussion in 'News & Notifications' started by Christopher Elliott, Apr 20, 2018.

  1. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,543
    Likes Received:
    1,044
    That would be a great Test patch

    I don’t know if it’s the new build
    Or the fact I’m running at higher settings ( exposing a software fault)

    So I’m going back to min settings as a test

    Ps again running at the higher roughly rf2 medium settings gives me a fairly stable 90fps

    Put the very latest nvidia drivers on & same problem

    I wonder if it’s a sound driver issue ?
    Or some kind of loading from
    Hard drive thing ?

    Glad it’s not just me
     
  2. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,717
    Likes Received:
    1,095
    It seems my issue was contagious ! But my issue started before that performance update .
    @Guimengo could you please tell me exactly the files you deleted ?
     
  3. halfwit

    halfwit Registered

    Joined:
    Apr 26, 2018
    Messages:
    13
    Likes Received:
    14
    Running an SLI system.Pains for me to say this 1110 update is not good ,get slowdown even with high frame rates.
    I have rolled back to version 1109, much smoother now.Seems everyone gets massively different results some happy some not.
     
    Schumi, DrivingFast and Adrianstealth like this.
  4. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,543
    Likes Received:
    1,044
    So the fault is in this new build ?

    How do we roll back ?

    Just when I get my teeth stuck in to juicy rfactor2 greatness something like this happens
     
  5. halfwit

    halfwit Registered

    Joined:
    Apr 26, 2018
    Messages:
    13
    Likes Received:
    14
    Go into Steam and into R Factor under your favourites Right click into properties and top right tab is Betas.
    Select v1109 out of the list 3rd from bottom.Will then download should take approximately 10 minutes.Good luck.
     
    Adrianstealth likes this.
  6. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,543
    Likes Received:
    1,044
    thanks, that worked,

    no freeze ups or pauses on prior build even when i stress tested with high settings so the fps was constantly low, fps seemed to be an honest indication of performance

    I again reverted back to new build the freeze ups & pauses happened again even though no fps fluctuations

    I lowered settings by turning off the post process (was on low) & shadows and although the fps remained as it was before
    90fps (for VR) performace seemed smoother & more fluid, I did not encounter the freezeup or pauses

    so I hope to stay with new build but keep settings low, some method is difitnelywrong or a bug in rfactor2 software

    Halfwit & others with this problem :
    on build 1.11110 -give it a try ( shadows off, Post process off & road + enviro reflections off, track detail low, other things off or low to med )
    see if you notice a better fluidity in the visual motion + no glitches/pauses/freezeups

    smooth/fluid visuals is more important than a high fps reading if some method has been used to duplicate frames or give a false fps reading? ( & obviously causing more serious problems for a few of us )
    constant 90fps should give smooth fps regardless of settings providing PC can keep to a constant 90fps rate

    something is not right
     
    2ndLastJedi likes this.
  7. Schumi

    Schumi Registered

    Joined:
    Jan 2, 2012
    Messages:
    321
    Likes Received:
    855
    OMG. Last night I did a test race in Monaco with 19 AI. 3 qualification sessions + 100% F1 race distance. Just in case, I turned on invulnerability. All graphics settings have been twisted to the maximum except Post Effects (off). For 3 hours I had a stable 90-100 FPS. No problems have arisen. This morning without changing any settings I went to the track alone. Already at the end of second lap - freezing comes back. :mad:o_O
     
  8. ekki

    ekki Registered

    Joined:
    May 25, 2018
    Messages:
    6
    Likes Received:
    9
    RaceNut, ADSTA, DrivingFast and 4 others like this.
  9. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,543
    Likes Received:
    1,044

    Cap FPS at 90fps & turn other graphic settings down bet it doesnt happen then ( shouldn’t happen at all I know with settings up etc )
     
  10. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,717
    Likes Received:
    1,095
    pkelly likes this.
  11. Schumi

    Schumi Registered

    Joined:
    Jan 2, 2012
    Messages:
    321
    Likes Received:
    855
    Adrianstealth likes this.
  12. Adrianstealth

    Adrianstealth Registered

    Joined:
    May 28, 2012
    Messages:
    4,543
    Likes Received:
    1,044

    Does this solve the dreaded rf2 freezes ? ( at higher settings )
     
  13. hardtohandle

    hardtohandle Registered

    Joined:
    Jul 15, 2013
    Messages:
    364
    Likes Received:
    54
    Here's a crazy one to mull over!
    Hows about we have a line in the gears chart that we can actually see? Without having to squint for and closely inspect anyway? Crazy stuff! https://forum.studio-397.com/index....ap-update-april-2018.59935/page-4#post-943462 :(
    https://www.dropbox.com/s/ic4ure7w51qelqw/gears.png?dl=0
    [​IMG]
    My eyesight is not the best, even so I do not see why we cannot see the damn thing clearly! It never used to be darkish blue on a back background. Can we have it back to a sensible colour please or at least let us put a colour in the player file for heavens sake!
    Good job I'm only racing mods with fixed gears atm! Can't believe other people aren't moaning about this.
    If there is some humour intended here you might as well go the full distance and put some proper camouflage all over that chart - that'll be great!
     
    philrob and Emery like this.
  14. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,717
    Likes Received:
    1,095
    Not for me , i have actually just reenabled it after having had it off since first install of Win 10.
     
  15. stonec

    stonec Registered

    Joined:
    Jun 19, 2012
    Messages:
    3,289
    Likes Received:
    1,406
    The Windows 10 fake boot thing in my experience can cause issues if you update drivers or change clock frequencies. For example I once would put overclock settings back on in BIOS without a full reboot, and that left games stuttering and behaving oddly until the next full boot. But unless you changed a BIOS setting or driver, I don't see how W10 quick boot could be an issue.
     
    Adrianstealth likes this.
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,607
    Likes Received:
    4,621
    First got mentioned probably a year ago, none of us could see a way to mod it (even in the UI.osc 'code'), and then the new UI has been 'coming soon' for the whole time since, so didn't seem worth worrying about complaining any more. In hindsight, as with many things, a workaround would have been handy to cover this time between UI updates, but for the same reason they probably won't bother changing it now.
     
    Emery likes this.
  17. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    474
    Likes Received:
    181
    Probably you have a background process that is interfering randomly on processor or disk.

    use windows resource monitor to see the processor and disk usage by application.
     
  18. Schumi

    Schumi Registered

    Joined:
    Jan 2, 2012
    Messages:
    321
    Likes Received:
    855
    Freezes only the car, not the game. At the time of freezing, FPS remains the same normal. There are no processes that interfere with the game - it's already passed stage.


    Yesterday there was no time to do tests, I will try to do it today
     
    Adrianstealth likes this.
  19. hardtohandle

    hardtohandle Registered

    Joined:
    Jul 15, 2013
    Messages:
    364
    Likes Received:
    54
    But @Lazza! It already has been a different colour with this UI! I wasn't sure what colour, but I knew it was different because I knew I could see it.
    A quick scan on youtube can reveal I am correct about that see this video here and look at 1:47
    See that? Now that's what is officially known in the business as "red"! Put it back to red boys! This is really not that great - I'll just leave it at that. No I'll go a bit further - it's just plain dumb! Can't see it very clearly at all, and we need to. So simple!
     
  20. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,086
    Likes Received:
    761
    that vid is racing in dx9, hence the red, and if i remember correctly the blue has been "in" since the start of dx11, happy to be corrected on that though. As Lazza said with the new UI arriving in the not too distant future (hopefully) we probably won't see any changes in the current.
     

Share This Page