Keyboard Not Working

Discussion in 'Hardware Building/Buying/Usage Advice' started by vhpd085, Oct 7, 2010.

  1. vhpd085

    vhpd085 Registered

    Joined:
    Oct 7, 2010
    Messages:
    3
    Likes Received:
    0
    Would anyone have any ideas why my keyboard will not work in rfactor when trying to create a player name or save a controller set up.

    I've recently moved over to a new Win 7(64Bit) PC and have two new rFactor installs, one I've put in “C:\rFactor installs\rFactor” the other in “C:\Program Files(x86)\rFactor”

    I've double checked the BIOS settings, tried a PS2 and USB keyboard, and made sure I'm running as Administrator. It works fine in an other app I open and I can edit the plr files no problem, but when it comes to naming a new player or to save a controller set up – nothing. Have I missed something?

    (I seem to remember having this problem once, a hundred years ago, with GPL !!)
     
  2. jgmonty

    jgmonty Registered

    Joined:
    Oct 5, 2010
    Messages:
    3
    Likes Received:
    0
    Hi, sounds like a file(s) security issue i.e. File(s) are flagged as read-only. When you are using rfactor on Win7, make sure you have full admin access, not just using an admin account. If you are have problems running rfactor, right-click the rfactor.exe and select "Run As Administrator..."

    In Vista, turing off UAC (user access control) usually does the trick. In Win7, I don't believe the UAC can be turned off completely, but there will be a slider to minimise the security level. As modifying the UAC effects your overall PC security, use with discretion (last resort)...

    I have found that not using the default install path "c:\program files\..." is preferred. Personally, I only ever install system type applications to "c:\program files\...", certainly never games.

    Hope this helps.
     
  3. Jeffrey Rietveld

    Jeffrey Rietveld Registered

    Joined:
    Oct 5, 2010
    Messages:
    34
    Likes Received:
    1
    It's a bug.
     
  4. vhpd085

    vhpd085 Registered

    Joined:
    Oct 7, 2010
    Messages:
    3
    Likes Received:
    0
    now the keyboard has started to work in one of my rFactor installs, but not the other :confused:
     
  5. 88mphTim

    88mphTim Staff Member

    Joined:
    Sep 23, 2010
    Messages:
    10,725
    Likes Received:
    124
    I think there is probably something open behind rFactor back in Windows, maybe a security question and your keyboard is working on that. Try running rFactor in Window mode and see if you can see something else open.
     
  6. vhpd085

    vhpd085 Registered

    Joined:
    Oct 7, 2010
    Messages:
    3
    Likes Received:
    0
    Well I've been away working for three days and have come back to find everything working, so I'm none the wiser ! It seems to have fixed itself. But thanks very much everyone for all the help.
     

Share This Page