Released July 2022 Release Candidate Now Available

Discussion in 'News & Notifications' started by Paul Jeffrey, Jul 13, 2022.

  1. rlaycock

    rlaycock Registered

    Joined:
    Oct 15, 2016
    Messages:
    61
    Likes Received:
    21
    Hi Paul
    I am back at my sim PC
    Started rfactor 2 and it again went through the update process (It was about midnight NZ time when I first tried the update, well after your post so I believe the update was available then) However I am happy to say the BTCC cars did indeed update this time. (I could tell before I even tried the break as my mirror and force feedback settings for this car had reverted to default which it did not do at midnight last night)

    Thanks for the help, all I can think is a computer glitch prevented the update from applying last night.

    On a separate point
    In the test version of the Porsche Cup cars (my favorite car in all sims) There is a strange graphic fault when viewed the car from the outside in replay. The rear tiers show through the body of the car. Do you know if rfactor 2 developers are aware, and if this will be fixed in the final version? The normal (none test version) does not have this issue.

    Best wishes
    Bob
     
    Last edited: Jul 21, 2022
    Paul Jeffrey likes this.
  2. rlaycock

    rlaycock Registered

    Joined:
    Oct 15, 2016
    Messages:
    61
    Likes Received:
    21
    Hi thanks for the reply
    However I restarted rfactor 2 this morning NZ time it updated again and all seams fine now.
    Best wishes
    Bob
     
    GTClub_wajdi and Bill Worrel like this.
  3. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    178
    Likes Received:
    207
    Thank you for the updates! They work great here!

    One question though (sorry if this was answered before!!): all GTE cars are using GoodYear Eagle tires, including those that have Michelin decals. I painted some cars that I uploaded to the RaceDepartment site for WEC and LeMans, and all used Michelins. In these cases, all keep using the french tires. ONLY the S397 cars use the GoodYears.
    Is there a reason for this? Did I do something wrong with my installation?
    Thank you in advance!!
     
  4. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    6,293
    Likes Received:
    3,637
    Goodyear is one of the Sponsors of the Virtual series. Hence, the cars that were updated were those that just so happen to be the cars eligible for the Virtual events. Thus...all GTE & Oreca 07 now have Goodyear sidewalls. Can you replace those with Michelins for your painted cars???
     
    Art_Pereira likes this.
  5. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    178
    Likes Received:
    207
    Oh, I didn´t know that. Thank you for the answer Dave.
    As for replacing those with Michelins, the cars I painted are using Michelins but I don´t know what I should change to use Michelin or GoodYear tires. It would be great if S397 would help us, the painters, with some improvements, i.e. to get screenshots of the cars straight from rF2 without having to use the old UI or other complicated solutions.
     
  6. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    573
    Likes Received:
    3,364
    Outstanding news - glad it is sorted, and thanks for confirming.

    Regards Porsche issue, yup, this is known and will be sorted.

    Cheers
     
  7. burgesjl

    burgesjl Registered

    Joined:
    Feb 2, 2013
    Messages:
    280
    Likes Received:
    484
    I'm seeing a lot of hangs on exit of the RC, won't fully close and I have to alt-tab out to force close it. Anybody else got the same?
     
  8. Bill Worrel

    Bill Worrel Registered

    Joined:
    May 1, 2019
    Messages:
    390
    Likes Received:
    255
    I haven't seen that but I did have to end the process when in the showroom and there were no controls to exit.
     
  9. Luprosx

    Luprosx Registered

    Joined:
    Apr 6, 2013
    Messages:
    183
    Likes Received:
    115
    Have the same here.
    If you start rF2 and just go to the UI,
    exits after that, it always hangs.
    Was like that in the last build 1128!
     
  10. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    178
    Likes Received:
    207
    Is there a way to make GTE cars with real life skins that use Michelin tires, to use them now? I mean to change the GoodYear Eagles and replace them with Michelins?
    I painted a lot of GTE Astons, Corvettes, Ferraris, Porsches with real life skins. These cars used Michelin tires and so show Michelin decals. All those models are ruined now.
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    10,984
    Likes Received:
    5,690
    Mine takes ~30 seconds or more to close when I do that, but it does eventually do it. Clicking on the window during that time will bring up the windows message about it being unresponsive, asking me whether to end it - but that's normal when a program freezes.

    So, it varies.
     
  12. Simonk

    Simonk Registered

    Joined:
    Sep 29, 2020
    Messages:
    84
    Likes Received:
    66
    I get more micro stutters in this RC than in the latest stable release which also introduced stutters into my game. Disappointing as it seems that this is just going to get worse with each release full of new features.
    I’ve been doing some 2.4hrs of Spa in the GT3s. I don’t think I’m tuned in enough to feel what the car is doing to know if track temps are affecting the grip level. Grip fades as the tyres wear, grip increases as the track rubbers up. Whatever’s going on with the dynamic track is thankfully not so complex that it affects my single player jump in and drive experience. I’ve noticed the AI are about 2 seconds slower per lap in this RC. Their times don’t change throughout a stint so they don’t seem to be affected by tyre wear. I did notice in both RC and stable that they’re 2 seconds a lap slower at night.
    Really like the track limits system. Haven’t tested out anything else yet but the stutters are the main issue for me. Is this something that’s still being worked on or do I have to suck it up and upgrade my PC if I want to enjoy all the new features?
     
  13. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,128
    Likes Received:
    1,616
    try reinstalling clean rfactor
     
  14. 2ndLastJedi

    2ndLastJedi Registered

    Joined:
    Nov 3, 2016
    Messages:
    1,824
    Likes Received:
    1,172
    Have you tried to lower special FX to remove the sparks? Sparks cause massive issues for me.
     
    DJCruicky likes this.
  15. EricW

    EricW Registered

    Joined:
    Jun 2, 2017
    Messages:
    155
    Likes Received:
    111
    Try to monitor your CPU/GPU load.
    Not sure what specs you have, but light effects and shadows seem to ask a lot of resources in RF2, or cause weird CPU throttling.
    Disable as many background processes as possible.
    There are utilities to optimise throttling like throttlestop.
    Also the replay writing in the background to a HD can cause freezes, try with replay off.
     
    coasting&cruising likes this.
  16. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    6,293
    Likes Received:
    3,637
    before uninstalling rF2, which doesn't completely remove everything try the following:
    Going back to the advice @MarcG always used to give. Rename your player.json file and let rF2 build a new one.
    2nd, reduce the special effects to low, that will prevent sparks which have been impacting framerates.
    3rd. Reduce by half the number of sound effects you are using(assuming you are at the maximum of 255)
     
    RaceNut and mesfigas like this.
  17. Simonk

    Simonk Registered

    Joined:
    Sep 29, 2020
    Messages:
    84
    Likes Received:
    66
    Thanks for the response guys. I’m already running the minimum sound options and no sparks because of the stutters in the current stable build. This mostly solved them but with the same settings, the stutters are back in the RC. I have an i7 7700, GTX2060S 5760x1080. I’ll wait until RC becomes public and see how it performs and then look at a reinstall and json delete
     
  18. pedro ramada

    pedro ramada Registered

    Joined:
    Jan 4, 2014
    Messages:
    63
    Likes Received:
    52
    Hello Guys :)

    I'm very happy to see implemented all the new things that bring the simulation to a whole new level! Thanks so much for the hard work! :)

    The new sound engine and all is new sounds are amazing ( i specially love the new brake disks sound when braking... they are beautiful! :D
    However i have something that i have to share that it seems not right... the overall sounds in all cars, being onboard or track side cameras that btw are stunning... the sound itself sounds a bit to metallic... it seems that the sample of sound itself is not very "clean" ?? let's say.. i don't know what that is but that should be look at to improve it!

    I have no problems of performance, i use the full 255 effects and i use immersive, and also the correct device that for me is Headphones.

    Please fix this guys.. it's quite noticable... you guys can do better for sure! Again Thanks a lot! :)
     
    Nuno Leite Castro likes this.
  19. juanchioooo

    juanchioooo Registered

    Joined:
    May 16, 2016
    Messages:
    2,128
    Likes Received:
    1,616
    third-party mods, it is the moderers who have to adapt their work to the new sounds, the officials gradually modify them studio397
     
  20. pedro ramada

    pedro ramada Registered

    Joined:
    Jan 4, 2014
    Messages:
    63
    Likes Received:
    52
    I'm talking already about the new implementation of sounds in the new engine for the GTEs for example juanchioooo, obviously i was refering to official content only man :) even so... to me the sound samples are still not at the point that i believe S397 can make it, for sure they will improve this in the near future!

    I think you agree with me... you can hear a bit of a metallic overall sound right?? It seems not very "clean" the effects that we hear in all sound range of the sample... whatever car it may be, obviously i´m refering to the cars that take advantage of the new sound engine effects.
     

Share This Page