(json) failed to perform operation, unsupported type

Discussion in 'Technical & Support' started by Jempy, Jul 25, 2014.

  1. Jempy

    Jempy Registered

    Joined:
    Oct 24, 2012
    Messages:
    18
    Likes Received:
    0
    Hello everybody,

    Build 798 installed, W7 64bit OS, started in 32bit checking the box in Launcher Advanced tab in order to be able to use TrapMap plugin...
    From one day to the next one ... without having done even a little something on the game .... what worked nice doesn't work any longer.

    Now, launching the same way ... I immediately get the message: (json) failed to perform operation, unsupported type

    I searched a bit everywhere in the forum but didn't find an answer ... ( too many results for this search )
    Always bad moment as I intended to do my entry online for an open race .... and now impossible of course

    What does this error message exactly mean and what can I do to solve this problem ... hoping not to have to reinstall once again.

    Thanks in advance for your answers and advices.
     
  2. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    948
    Likes Received:
    123
    Hi, you can try to start in 64bit mode and check if that works.
    Normaly i would suggest to move the relevant .json file out of his folder, so rF2 will than create a new one.
    The problem is you don't know which file is forcing the message, you can try for example "player.json", maybe youre lucky.
    "unsupported type" means usally a wrong data type was given, for example "string" instead of integer.
     
  3. Jempy

    Jempy Registered

    Joined:
    Oct 24, 2012
    Messages:
    18
    Likes Received:
    0
    Thanks for your answer.
    Of course I already tried 64bit mode as 1st attempt of remedy ... but without success: the message was the same.

    That should probably or logically mean the .json file making problem isn't located in bin32 or bin64 but elsewhere in another folder.
    But 1st I'll try removing .json files .... and I might get lucky now :) ... but I'm not Mark Knopfler so ... maybe not. :p
     
  4. Jempy

    Jempy Registered

    Joined:
    Oct 24, 2012
    Messages:
    18
    Likes Received:
    0
    Bingo ! ... I got lucky ... that was it ... for an unknown reason the .json player file was .... empty !
    Deleting it and launching once was enough to settle this crazy embarassing problem.

    You were a king Tjones ;) ... many thanks for your answer and your easy to realise tip.!

    PS: I know much better other sims than Rf2 ... so I'll have to go deeper in my study of Rf2 files ... but I'm missing free time, as I'm very busy at my league.
     
  5. TJones

    TJones Registered

    Joined:
    Oct 5, 2010
    Messages:
    948
    Likes Received:
    123
    I hope you didn't use autoupdate for build798, for some people it worked for others not.
    For this build i suggest to deinstall the old build, clean up folders and perform a fresh installation.

    Good luck! :)

    EDIT: Glad you found it! :D
     
  6. Fahol

    Fahol Registered

    Joined:
    Feb 29, 2012
    Messages:
    4
    Likes Received:
    0
    I had the same problem, Im lucky also, it was player.json! :)
     
  7. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    Im confused...
     
  8. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    I deleted the player.json file but it still shows same message.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,003
    Likes Received:
    2,803
    Are you getting this error? Move your player.json file out of your Userdata\player folder and start the game again.

    You may find you need to do the same with the other .json files in there (Custompluginvariables, multiplayer) in order to make it work, they tend to break together. The second file doesn't produce any error, just doesn't work.
     
  10. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    yea, i cut and pasted player, multiplayer, controller, and the custom plugins one to desktop and started the game a few time but still got the message
    it's also not creating the new .json files
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,003
    Likes Received:
    2,803
    @FORMULAEFAN71 It won't create the new ones until it gets at least partway through loading, so that's ok.

    Try verifying rF2 files through steam, something deeper is obviously wrong. Not sure what to be honest. But try that first and see if that fixes something...

    @FORMULAEFAN71 about the only other thing I've found (basically any of these errors that have come up, have been 'solved' by deleting/moving the .json files...) is someone having a second player.json file in there (slightly different name, presumably) and the game was picking that up too. Other than that, I have no idea. I guess try installing (all) the runtimes in the Support\Runtimes folder, and maybe DirectX, but now I'm clutching at straws...)
     
    Last edited: Feb 7, 2020
  12. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    no, i think maybe because of the controller files a few weeks ago that I had to change, but yeah, I verified an am still getting. Ill continue to start the game and see what happens.
     
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,003
    Likes Received:
    2,803
    More comprehensive option is to move your entire Userdata folder to somewhere safe, reverify, and see if that runs. Then move your data files back (or copy, from that safe place) to restore your setups and settings, but being mindful one of those files might break it again.
     
  14. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    Sorry, still no. I feel like I’m doing something wrong lol
     
  15. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,088
    Likes Received:
    523
    Try that:
    Start the steam client.
    Before you start the game, rename the folder
    ..\Steam\steamapps\common\rFactor 2\UserData
    into for example UserData_backup or any other name.
    then go to the folder
    ..\Steam\steamapps\common\rFactor 2\Launcher
    rightclick on the file "Launch rFactor" or "Launch rFactor.exe"
    in the menu, select "run as administrator"
    Does that help?
     
  16. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    YES! Will it work normally from now on or do I have to keep doing this?
     
  17. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    Oof, I do
     
  18. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,003
    Likes Received:
    2,803
    Running as admin, or removing the userdata folder?
     
  19. FORMULAEFAN71

    FORMULAEFAN71 Registered

    Joined:
    Dec 3, 2019
    Messages:
    30
    Likes Received:
    3
    I have to run as admin every time now. I guess I can’t use mods either?
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,003
    Likes Received:
    2,803
    No, you should be able to, though the fact you get that error without admin makes me worry something fundamental is wrong somewhere. Are mods not showing up?
     

Share This Page