Issues with binding keys

Discussion in 'Technical & Support' started by green serpent, Oct 9, 2023.

  1. green serpent

    green serpent Registered

    Joined:
    Feb 2, 2016
    Messages:
    704
    Likes Received:
    713
    Is anyone else having a problem where they are having to constantly rebinding keys, i.e you bind all your keys and then next session those keys no longer work? It's happened to me about ten times now. Using a Fanatec CSL DD. Apologies if this has already been discussed.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,305
    Likes Received:
    6,550
    How do you handle control assignments?

    What I mean is, they are part of your controls profile. When you load a wheel profile, the keys are all set as per that profile. If you do any saving/loading of profiles (on the calibrate page) you'll need to be aware of changing key assignments. (if you don't do anything with profiles everything you assign should be set in the controller.json; so if they aren't sticking I'd be inclined to check that they actually get saved properly, and that a wheel profile isn't being loaded automatically and overwriting them later)

    That aside, if it's wheel controls that you're losing, check whether it's 'just' the controller ID that's changed. So instead of throttle being Joy1 Y- (for example) you have to reassign it to Joy2 Y- because that's what the wheel is now. That may have a solution, whereby you stop the device(s) 'moving around' and changing ID.
     
    green serpent likes this.
  3. The_Bad_Fasterd

    The_Bad_Fasterd Registered

    Joined:
    Jan 16, 2022
    Messages:
    170
    Likes Received:
    129
    Are you saving those key bindings in the user profile within the UI?
     
    green serpent likes this.
  4. green serpent

    green serpent Registered

    Joined:
    Feb 2, 2016
    Messages:
    704
    Likes Received:
    713
    I'm just binding all my controlls within the UI which I have always done and it's never really caused me any issues, but lately I've noticed that certain buttons stop working and then sometimes hardly anything works.
     
  5. The_Bad_Fasterd

    The_Bad_Fasterd Registered

    Joined:
    Jan 16, 2022
    Messages:
    170
    Likes Received:
    129
    Maybe try and save the profile in Settings>Calibrate Controls>Profiles.

    I have multiple profiles because I use different wheels and it works really well…
     
  6. green serpent

    green serpent Registered

    Joined:
    Feb 2, 2016
    Messages:
    704
    Likes Received:
    713
    Yeah thanks I'll try doing that. Cheers.
     

Share This Page