Is auto download broken ATM ?

Discussion in 'Technical & Support' started by vancstar, Jan 25, 2021.

  1. vancstar

    vancstar Registered

    Joined:
    Oct 5, 2010
    Messages:
    181
    Likes Received:
    23
    I have re installed my server machine and now I can join my server anytime as long as I have all the files installed on a client but the software wont allow auto download anymore. All of my port forwarding is unchanged and yet it still won't work. Yes Aut Download =true as well. I just get "Package unavailable"
    TIA.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,900
    Likes Received:
    4,063
    Sanity check: got the rfmod in Packages?
     
  3. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,142
    Likes Received:
    1,293
    Autodownload is working for me.
    But autodownload doesn't work with all the packages. It depends on how are them structured.
    I'm going to try to explain this, in case it's your problem
    Case 1: The autodownload will work
    • Car.rfcmp
    • Circuit.rfcmp
    • Mod.rfmod
    Case 2:
    The autodownload won't work for some users
    • Car.rfcmp
    • Update of Car.rfcmp
    • Circuit.rfcmp
    • Mod.rfmod
    This will work for the users that have previously installed Car.rfcmp
    The autodownload will download the update of the car, the circuit and the mod, but not the base car (Car.rfcmp).
    The same will happen with circuits
    That is, if you have in the server a rfcmp and an update of the rfcmp the autodownload will only work with the update. Then if the user doesn't have the base package it's not going to work.
    The Autodownload only works with the last "layer" of rfcmps.
     
  4. vancstar

    vancstar Registered

    Joined:
    Oct 5, 2010
    Messages:
    181
    Likes Received:
    23
    Yes I have all content I want auto downloaded in the packages folder, as I always have for autodownload. ;)
     
  5. vancstar

    vancstar Registered

    Joined:
    Oct 5, 2010
    Messages:
    181
    Likes Received:
    23
    I have never encountered that problem of an update being downloaded but the base mod wasnt as I had done updates to add teams on paid content but generally when I updated other mods I have re packaged the whole thing to have complete versions, so I am not thinking this is the cause either, thanks.
     

Share This Page