Installing Car in to Dev Mode

Discussion in 'Car Modding' started by Blake, Feb 3, 2018.

  1. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,275
    Likes Received:
    389
    ReferenceConditions=(101325,1.204,0.073)
    RPMBase=(0,-24,-24,0,0.96)
    VolumeFract=(0,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0,0,0,0)
    RPMBase=(250,-22.82,142,0.1317,0.995)
    VolumeFract=(0,0.4204,0.7135,0.9414,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.931,0.944,0.95,0.955)
    RPMBase=(500,-23.36,157.78,0.0527,0.993)
    VolumeFract=(0,0.3541,0.6434,0.8508,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.932,0.953,0.968,0.97)
    RPMBase=(750,-24.18,175.31,0.0263,0.99)
    VolumeFract=(0,0.3069,0.5655,0.7691,0.9642,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.933,0.961,0.975,0.98)
    RPMBase=(1000,-25.05,194.79,0.0132,0.987)
    VolumeFract=(0,0.2686,0.5006,0.6878,0.8725,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.934,0.968,0.985,0.99)
    RPMBase=(1250,-25.95,216.43,0.0053,0.985)
    VolumeFract=(0,0.2359,0.445,0.613,0.7865,0.9281,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.935,0.974,0.99,0.995)


    So the underlined values (only did the first three) are for your idle rpm. Scrap the line that you were talking about before; it has no use.
    Thats why I wanted to know what kind of file you used.

    Now I can see the highest value is at 250 rpm and it climbs up a bit two steps, but not having enough, it goes back again, through the 250 mark and stalls.
    With every engine; it is a bit of trial and error; "they" all act different according to (for instance) back torque and inertia.
    But to start off with I would suggest (for an rpm of say 850)

    RPMBase=(0,-24,-24,0,0.96)
    VolumeFract=(0,1,1,1,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0,0,0,0)
    RPMBase=(250,-22.82,142,0.0217,0.995)
    VolumeFract=(0,0.4204,0.7135,0.9414,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.931,0.944,0.95,0.955)
    RPMBase=(500,-23.36,157.78,0.0327,0.993)
    VolumeFract=(0,0.3541,0.6434,0.8508,1,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.932,0.953,0.968,0.97)
    RPMBase=(750,-24.18,175.31,0.0563,0.99)
    VolumeFract=(0,0.3069,0.5655,0.7691,0.9642,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.933,0.961,0.975,0.98)
    RPMBase=(1000,-25.05,194.79,0.0032,0.987)
    VolumeFract=(0,0.2686,0.5006,0.6878,0.8725,1,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.934,0.968,0.985,0.99)
    RPMBase=(1250,-25.95,216.43,0.00,0.985)
    VolumeFract=(0,0.2359,0.445,0.613,0.7865,0.9281,1,1,1,1,1,1,1,1,1,1)
    MixtureFract=(0.935,0.974,0.99,0.995)

    Again, according to the engine, you have to let it run up a bit; there is a fine line between going to the right rpm- not running back and going to the right rpm and not wanting to stall if you try; the engine keeps running when you brake without clutch.
    If you don't get 850 rpm out of it, try the value in the 750 rpm line and make it 0,07 or 0,08 and so on.
    The values in the higher rpm may not be that high because "the throttle will hang" and it makes how it goes back to your set rpm.
    Just play a bit and you will find what you need; trial and error as I said.
     
    Nibiru likes this.
  2. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,275
    Likes Received:
    389
    Yeah, I'm a dick. Why does that still surprise you mate?
     
    Nibiru likes this.
  3. thoraxe

    thoraxe Registered

    Joined:
    Dec 25, 2016
    Messages:
    149
    Likes Received:
    15
    I'll mess around with it a bit. Thanks for the input. The car idles fine with these settings as-is, but it could probably be better!
     
  4. Seventh-Gear

    Seventh-Gear Registered

    Joined:
    May 3, 2020
    Messages:
    12
    Likes Received:
    2
    Sorry to revive an old thread, but I'm also having CTD when trying to install a vehicle in to ModDev mode. The game loads and the new vehicle appears in the menu, but crashes if you try to use the new vehicle.

    I did read through all of the suggestions here, and set up the directory structure & .gen file accordingly. However, I noticed the Skip Barber .gen file also includes data for settings which refer to .gmt files that are specific to the vehicle.

    It seems reasonable that these references being incorrect or missing would cause CTD, but there's no way to create them without information from the new vehicle's .mas file, which is of course encrypted.

    Any suggestions would be appreciated, Thanks in advance.



     
  5. Slip_Angel

    Slip_Angel Registered

    Joined:
    Jun 15, 2019
    Messages:
    588
    Likes Received:
    297
    Can i use dev mode to see how much downforce am i generating on GTE cars ?
     
  6. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,297
    Likes Received:
    6,543
    No, even if you can get them in you can't unlock the hdv entries that stop that telemetry from working.

    * @Slip_Angel correction: having now tried a car with the aero sensor disabled, devmode does show the downforce generated in the live view. I basically assumed that wouldn't work, because if it is possible to use DLC in devmode and it doesn't hide those values according to the HDV [PLUGIN] settings then it would be a loophole to see some information that probably isn't intended.
     
    Last edited: Nov 27, 2020
  7. Slip_Angel

    Slip_Angel Registered

    Joined:
    Jun 15, 2019
    Messages:
    588
    Likes Received:
    297
    So are you saying i can check downforce levels on official GTE cars in dev mode ?
    Holy sh*t please tell me how you did that. I would love to spend hours in dev mode, tuning setup and learning stuff.
     
  8. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,884
    Likes Received:
    2,686
    Do you try to use a DLC Car in the DevMode?
    If nothing has changed, that unfortunately will not work, because, as you said already, you have no Access to the GEN Files, because of the mas File Encryption.
     
  9. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,297
    Likes Received:
    6,543
    There was a rather important 'if' in the middle of my post.
     
  10. Slip_Angel

    Slip_Angel Registered

    Joined:
    Jun 15, 2019
    Messages:
    588
    Likes Received:
    297
    Oh so it is only possible with other cars that have no confidential data or are under NDA.
     
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    12,297
    Likes Received:
    6,543
    There's another thread somewhere regarding putting DLC into devmode, I haven't personally tried to work out what's possible with cars, I do it with the tracks which is quite easy. So I honestly don't know if it's possible to get DLC cars into devmode. If there's a way for the game to do it, that may somehow block the values you can normally see in devmode - I don't know.

    As far as other non-encrypted cars, it's a circular situation - as a modder you can block certain telemetry just like S397 do, but if the car isn't encrypted anyone can put it in devmode and change those telemetry blocks in the hdv, which makes blocking them a bit of a waste of time and could also explain why non-encrypted content still shows the live telemetry values in devmode despite the actual telemetry logging not working.

    Short version: I don't know for sure, but when the DLC has blocked values I doubt they'll make it possible to view it in devmode, whichever way it all shakes out.
     
  12. Slip_Angel

    Slip_Angel Registered

    Joined:
    Jun 15, 2019
    Messages:
    588
    Likes Received:
    297
    Sigh..bad luck. I hope in future they add some sort of telemetry in-game.
     
  13. Seventh-Gear

    Seventh-Gear Registered

    Joined:
    May 3, 2020
    Messages:
    12
    Likes Received:
    2
    Thank You for the information.

    I've been working several months on a kart track project, unfortunately the Skip Barber car is the incorrect scale for the track and can't be used to generate a reasonable lap. I had assumed I could install a DLC kart into ModDev when the time came to develop the AIW.

    So I'm not trying to view or change any of the DLC vehicle's info in ModDev, I'm just trying to use it on a ModDev track. I've spoken to another kart track developer who indicated he was able to do this in the past by simply copying the DLC files to ModDev.

    Just to confirm: Am I understanding correctly that it is not possible to load DLC vehicles with encrypted content so they can be driven in ModDev mode? If so, what options do I have to complete the AIW file?




     
    Last edited: Nov 27, 2020
  14. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,884
    Likes Received:
    2,686
    You've got a private Conversation Message.
     
  15. Hinyaldee

    Hinyaldee Registered

    Joined:
    Nov 24, 2021
    Messages:
    129
    Likes Received:
    41
    Hello, I'm having the same issue as I used the Formula Pro car to create an AIW file. Would it be possible to have the solution please ?
     
  16. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,884
    Likes Received:
    2,686
    It was no Solution for the whole "Problem", i just offered to send him a Kart for the DevMode, because that was what he wanted to use.
    To use DLC Cars in the DevMode is a Question of Luck.
    Sometimes it seems to work, as some Users have reported, but there is no "do this and that and it works".
    To use DLC Tracks in DevMode is no Problem, as it was said already.

    But in the End it doesn't matters anyway which Car you use to create/edit an AIW File.
    You don't have to use the Car, that have Problems with the AI on a Track.
    It's more about how you drive the Pathes than with which Car you drive.
     
    Seventh-Gear, Hinyaldee and Lazza like this.
  17. Hinyaldee

    Hinyaldee Registered

    Joined:
    Nov 24, 2021
    Messages:
    129
    Likes Received:
    41
    OK thanks ! I swapped out to a modded F1 car instead and am tying now to do the AIW. I'll see how it works out if I did it properly :)
     
    PatientRF2fan and redapg like this.
  18. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,884
    Likes Received:
    2,686
    I always recommend to use a Car that has a good Grip and Handling, that you can drive exact Lines.
    I, for Example, use our F3 2019-2021 Mod, with increased Tire Grip.
    And the Lines should be as smooth as possible.
    When you did drive a fast Path, let the AI drive, to check where the Cars have Problems.
    One main Problem with AIWs is, that they almost never work properly for all kind of Cars.
    So you sometimes have to drive different Pathes and/or edit the Lines/Corridors, to get it working better for different kind of Cars.
     
  19. Hinyaldee

    Hinyaldee Registered

    Joined:
    Nov 24, 2021
    Messages:
    129
    Likes Received:
    41
    The modded F1 2021 car I use has heavy downforce so it's very stable to drive even with the factory setup :) Well, you can say I'm awful though, now my struggle is with finetuning the fastpath. I, for the life of me, can't edit the waypoints to smooth out the line despite using the keyboard shortcuts. And of course, the car I use doesn't allow the top down camera view apparently...
     
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    3,884
    Likes Received:
    2,686
    Which Part do you want to smooth and how do you try to do it?
    And the Car has no Swingman Camera Entry in the Cam File?
     

Share This Page