Imola tracks always updating

Discussion in 'General Discussion' started by Tony Raharidzery, May 15, 2022.

  1. Tony Raharidzery

    Tony Raharidzery Registered

    Joined:
    Sep 4, 2021
    Messages:
    25
    Likes Received:
    6
    Hello,

    Each time i launch rF2, i have a bunch of Imola tracks trying to update (Imola01_2001, Imola18_2018, Imola72_1972, Imola88_1988).
    I cannot see from where and how i can't disable them and it is really annoying.
    I already looked in ModManager but they're not there.
    Could someone help please?
     
  2. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,169
    Likes Received:
    2,114
  3. Tony Raharidzery

    Tony Raharidzery Registered

    Joined:
    Sep 4, 2021
    Messages:
    25
    Likes Received:
    6
  4. Woodee

    Woodee Registered

    Joined:
    Oct 4, 2010
    Messages:
    3,847
    Likes Received:
    853
    Corti likes this.
  5. Corti

    Corti Registered

    Joined:
    Sep 29, 2014
    Messages:
    1,169
    Likes Received:
    2,114
    oh sry, its true. excuse me :oops:

    So I think you can't be unsubscribed a DLC
     
  6. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Can't help you with this, but I have a similar issue with updates (x6 from memory upon every start) of "formula E gen 2" update failed. Figured it's due to having a formula E track (test track) in my library, got it for free from memory some time ago.
    Similar to you it's a real pain sitting through failed attempts to update every time you start the game. Hope there's a fix.
     
  7. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    609
    Likes Received:
    3,795
    Also double-check the content in question doesn't have a dependency you have installed, such as a skin pack / league pack etc. That could be the issue that is preventing the update or causing a false update related to the 3rd party addon.
     
  8. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Thanks Paul, just recently did a clean install with only official dlc etc, but same deal for me, guess I'll just have to put up with it. Skip update never really works either.
     
  9. Paul Jeffrey

    Paul Jeffrey Administrator Staff Member

    Joined:
    May 21, 2016
    Messages:
    609
    Likes Received:
    3,795
    Hmmm interesting it's still happening - ok thanks for the feedback, I'm a bit stumped now as to what it could be. Dang, sorry man
     
  10. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,259
    Likes Received:
    857
    Got a screen grab of the error, might give us some clues
     
  11. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    [​IMG]

    Sure, grab one tomorrow night.
    Thanks for the help, hope I'm not crashing the OP, just seems like my issue is similar. Figured plenty others deal with this also.

    Sorry for the crappy pic, if only I knew what I was doing....

    [​IMG]

    [​IMG]
     
    Last edited: May 16, 2022
  12. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    1,259
    Likes Received:
    857
    Navigate to ...\Steam\steamapps\common\rFactor 2\Installed\Vehicles\ and you should see these two folders
    upload_2022-5-17_6-31-32.png
    Delete the sub folders (1.36, 1.37 etc, you may have more than I've got) and then fire up rF2, that should trigger them to download again.
     
  13. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Cool thanks will try tonight, bare in mind I have no dlc formula E content, only the test circuit which I think was free when I got it, figured this is triggering the constant update which then fails. Will report back tonight.
     
  14. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Ok, I have 3 X formula E gen2 folders, a 2019, 2021 and 2022. Deleting them meant that upon starting the game, these files would re-download but fail, creating a new folder each time of about 145 MB. This happens every time I start the game, eating up disk space in the gigabytes!!!
    Explains where my free disk space disappears to.
    I'll attach some pics...(hopefully they are clear enough to read..apologies in advance.
     
  15. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
  16. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,240
    Likes Received:
    5,866
    Starting the game should only be trying to install them, not actually download them.

    Try instead going to the C:\Program Files (x86)\Steam\steamapps\workshop\content\365960\1558324776 folder. Probably delete all the files there. Then verify rF2 files in steam to download them again.

    DLC problem are sometimes solved by unsubscribing and letting the game resubscribe; right now this is how we do that.
     
  17. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,948
    Likes Received:
    1,761
    @Robert Bachmayer I didn't read the whole Thread, so maybe it was suggested before, but also ensure that no virtual Mod (rfmod File, that gets downloaded if you join a Server for Example) is using the Component with that you have the Problem.
    If that is the Case, the Component can not be updated properly.
     
  18. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Thanks Lazza, yep understand you on the point about the game trying to install those vehicles every time the game is restarted rather than re-download, but yeah still eats up disk space when failing.
    Will give the unsubscribe of the dlc ( the free (formula e test circuit) ago again, fairly certain I tried this some weeks ago but will give it another shot.I believe there is some association between having the test circuit but not actually having the formula E cars. Maybe someone else who only has the test circuit and not any formula E cars can see if they have the same issues.
     
  19. Robert Bachmayer

    Robert Bachmayer Registered

    Joined:
    May 2, 2020
    Messages:
    13
    Likes Received:
    1
    Okay whilst fresh in my mind, unsubscribed from formula E test circuit, steam removed the track. All good.
    Deleted the vehicle files associated with formula E gen 2. Deleted the files inside 365960\1558324776 folder, performed a file integrity check, steam re-downloaded 1.5GB of formula E rfcmp files which then tried to install next time I started the game, obviously failed and started the whole cycle again.

    Might look into a mod manager to disable this from happening. Thanks everyone for your efforts.
     
  20. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,240
    Likes Received:
    5,866
    Have you run the ModMgr (rFactor 2\Bin64\ModMgr.exe) and looked through to see what mods you have installed that are perhaps referencing those cars (or, indeed, if the cars show with Components ticked, and whether they say "In use by 1 mod" or similar)? I don't really understand the hierarchy that leads to this sort of thing, obviously something somewhere is causing them to be linked to your game (despite not owning them), I'm just not sure what/where that is.

    I was also going to suggest clearing out your rFactor 2\Packages folder, but I see above you tried a fresh install already.
     

Share This Page