Image freezes but audio and ffb still work

Discussion in 'Bug Reports' started by Paun Robert, May 30, 2022.

  1. Paun Robert

    Paun Robert Registered

    Joined:
    Apr 16, 2020
    Messages:
    7
    Likes Received:
    3
    Hi! I am having this really annoying issue with my game. Every few hours the image stops while I can still hear and feel the ffb. After a few seconds (around 10) game closes. I even tried reinstalling windows but had no success.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,010
    Likes Received:
    5,695
    Usually this means your display driver has crashed. Try limiting your FPS and check your GPU temps.

    This sort of thing will show in windows event viewer.
     
  3. Paun Robert

    Paun Robert Registered

    Joined:
    Apr 16, 2020
    Messages:
    7
    Likes Received:
    3
    I have nothing in windows event viewer. I limited my FPS and underclocked the GPU for better temps but looks like it didn't help.
     
  4. Dawid Mroczek

    Dawid Mroczek Registered

    Joined:
    Jan 15, 2021
    Messages:
    6
    Likes Received:
    2
    I'm having the same issue. It happened first time somewhere in early april and I have it since then. Image just stops after ~1-1.5h of driving. FFB and sound is still present for roughly 10s and then the game shuts off without any error.

    I tried limiting fps. It does not work, it still crashes after same time. GPU/CPU temps are fine. I've reinstalled nvidia drivers several times, also using DDU. I've been running the game on this PC with perfect FPS for nearly 2 years without any crashes. I don't have this sort of problems in any other games. It is clearly something that was introduced somewhere during latest game updates. At this point im completely out of ideas how to fix it.

    Also I find the idea of limiting fps unacceptable. Game runs fine with locked 138.4fps(gsync+vsync+ultra low latency mode) and as esport person i'm not going to put it lower than 120 for sure cause it already affects the laptimes/consistency etc. 144fps was fine for nearly 2 years.

    I tried turning off gsync/vsync/latency mode, I tried different combinations there and nothing seems to make any difference. Ive heard that it might be caused by gsync but im getting this even with gsync off so it's clearly not that.
     
  5. Dawid Mroczek

    Dawid Mroczek Registered

    Joined:
    Jan 15, 2021
    Messages:
    6
    Likes Received:
    2
    Also seems like this error produces 2 types of errors in my windows event viewer:

    "
    Nazwa aplikacji powodującej błąd: rFactor2.exe, wersja: 1.1.2.8, sygnatura czasowa: 0x6284e119
    Nazwa modułu powodującego błąd: KERNELBASE.dll, wersja: 10.0.19041.1706, sygnatura czasowa: 0x458acb5b
    Kod wyjątku: 0xe0000008
    Przesunięcie błędu: 0x0000000000034fd9
    Identyfikator procesu powodującego błąd: 0x2118
    Godzina uruchomienia aplikacji powodującej błąd: 0x01d86e93798ed81c
    Ścieżka aplikacji powodującej błąd: D:\SteamLibrary\steamapps\common\rFactor 2\Bin64\rFactor2.exe
    Ścieżka modułu powodującego błąd: C:\WINDOWS\System32\KERNELBASE.dll
    Identyfikator raportu: 67f57128-639c-4a3e-9602-12a30a409142
    Pełna nazwa pakietu powodującego błąd:
    Identyfikator aplikacji względem pakietu powodującego błąd: "

    and the second one:

    "
    Nazwa aplikacji powodującej błąd: rFactor2.exe, wersja: 1.1.2.8, sygnatura czasowa: 0x6284e119
    Nazwa modułu powodującego błąd: ntdll.dll, wersja: 10.0.19041.1682, sygnatura czasowa: 0x7b5414ec
    Kod wyjątku: 0xc0000374
    Przesunięcie błędu: 0x00000000000ff249
    Identyfikator procesu powodującego błąd: 0x15e0
    Godzina uruchomienia aplikacji powodującej błąd: 0x01d86ea6ffeecc2f
    Ścieżka aplikacji powodującej błąd: D:\SteamLibrary\steamapps\common\rFactor 2\Bin64\rFactor2.exe
    Ścieżka modułu powodującego błąd: C:\WINDOWS\SYSTEM32\ntdll.dll
    Identyfikator raportu: 4a15cde4-a7af-4557-af7b-60554c2938c2
    Pełna nazwa pakietu powodującego błąd:
    Identyfikator aplikacji względem pakietu powodującego błąd: "

    It is in polish but as you can see the modules that cause the error are either kernelbase.dll or ntdll.dll
     
  6. Paun Robert

    Paun Robert Registered

    Joined:
    Apr 16, 2020
    Messages:
    7
    Likes Received:
    3
    This is what I get:

    The program rFactor2.exe version 1.1.2.8 stopped interacting with Windows and was closed. To see if more information about the problem is available, check the problem history in the Security and Maintenance control panel.
    Process ID: 27b0
    Start Time: 01d8745caffd3beb
    Termination Time: 3
    Application Path: D:\SteamLibrary\steamapps\common\rFactor 2\Bin64\rFactor2.exe
    Report Id: 0558de5c-5259-4345-99a2-279bafd93c79
    Faulting package full name:
    Faulting package-relative application ID:
    Hang type: Cross-thread
     
  7. Dawid Mroczek

    Dawid Mroczek Registered

    Joined:
    Jan 15, 2021
    Messages:
    6
    Likes Received:
    2
    my pc spec:
    Geforce 2070 Super, i7 4790, 16GB RAM
    CSL Elite + CSL Elite pedals LC

    It's all stock specification, not overclocked etc.
     
  8. Paun Robert

    Paun Robert Registered

    Joined:
    Apr 16, 2020
    Messages:
    7
    Likes Received:
    3
    I run:
    Ryzen 5 1600x
    Gigabyte GTX 1660
    16gb of ram 3200
    CSL elite + Formula V2 wheel + csl pedals(no LC)
     
  9. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    Same issue here just started 2 weeks ago.

    After about 1.5 hours video freezes ,audio and ffb still ok.

    Win10
    Updated to latest video driver.
    full re-install Rfactor 2

    Gigabyte GTX 3080ti
    i9 12900K
    32Gb 3200 ram
    Not overlocked, totally stock

    Has anyone found a cause or solution yet?
     
  10. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    I am able to replicate the issue in offline and online mode 3hr AI only race

    Video freezes for 10 secs at roughly 2 hour mark and crashes to desktop with no error reported.

    Trace files attached.
     

    Attached Files:

    Last edited: Jul 9, 2022
  11. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,010
    Likes Received:
    5,695
    Doesn't appear to be anything useful in the traces. Nothing in the windows event viewer?
     
  12. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    I agree,
    I could not see anything obvious either.

    Event viewer log only reported one of the crashes to desktop.

    Faulting application name: rFactor2.exe, version: 1.1.2.8, time stamp: 0x62bc2ccb
    Faulting module name: KERNELBASE.dll, version: 10.0.19041.1741, time stamp: 0xe9b4a91b
    Exception code: 0xe0000008
    Fault offset: 0x0000000000034fd9
    Faulting process ID: 0x5118
    Faulting application start time: 0x01d893237e31faf1
    Faulting application path: D:\SteamLibrary\steamapps\common\rFactor 2\Bin64\rFactor2.exe
    Faulting module path: C:\Windows\System32\KERNELBASE.dll
    Report ID: 49b12e99-c7d7-4f53-acca-de8e96ede504
    Faulting package full name:
    Faulting package-relative application ID:

    I have stressed tested the PC for hours with Furmark and cinibench and no issues at all.

    No idea what to try next.




    [​IMG]
    ReplyForward



     
  13. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,010
    Likes Received:
    5,695
    @syntryx in the absence of anything else more concrete I would take a stab at running the various runtimes (the 4 in the Support\Runtimes folder, also more recent ones like here (x86 and x64) and explicitly uninstall them, and then reinstall them. (I'm assuming the more recent ones I've linked there allow that; I know the ones in the Runtimes folder do. Easier than manually uninstalling through windows settings)

    It's a long shot, but very occasionally only repairing/installing them doesn't quite do the trick (though with 'normal' runtime errors), so if you're really lucky that may help. If not, it's not too much time spent and you won't be any worse off.
     
  14. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    Thanks Lanza,

    I will give it a go, failing that a fresh install of Win11 is next
     
  15. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    726
    Likes Received:
    767
    If you have a rFmini.dmp file in your userdata folder from the crashes please share them
     
  16. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    Hi Alex

    could not find rFmini.dmp file in the userdata folder
     
  17. GP_NUTS

    GP_NUTS Registered

    Joined:
    Jun 14, 2022
    Messages:
    20
    Likes Received:
    10
    Maybe win11 is to blame in this case.

    I run windws 10
    Running rf2 maxed out with 42 ai (nascar 2016 edit) on the same pc as i running a rf2 server on. No problems at all i 3 hours only one minor fps drop, briefly it dropped 10 fps for a very short time, windows update was downloading/installing stuff i found out later.

    My pc is a ryzen 2700x water cooled running at 4100 mhz.
    32 gb ram 2666 mhz on top of my head.
    Running windows and rfactor2 plus server on a very fast m2 ssd.
    Gpu a 1070 gtx.
    Having 2 other ssd's and one tb hd 7200 rpm

    Temps : cpu no higher 55 degrees celsius
    Gpu running no hotter then 58 degrees celsius.
     
  18. syntryx

    syntryx Registered

    Joined:
    Jun 13, 2013
    Messages:
    12
    Likes Received:
    3
    Hi GP

    My current OS is WIN 10 and had been running fine for at least 6 months
     
  19. GP_NUTS

    GP_NUTS Registered

    Joined:
    Jun 14, 2022
    Messages:
    20
    Likes Received:
    10
    This issue you guys have can also be activated by your power supply.

    I had a simulair issue with my former pc.
    With a heavier cpu/gpu game. Screen freezes for unknown reason but sound keeps playing and no system hold.

    Later it started to cause kernell error etc.
    The reason was one of my voltage rails of my psu was running in short peak times less then the requirered voltage. On my psu it was the 5 volt rails dropping below the i believe 3 or 5 % voltage drop
    A example : 5volt rails can run at 4.98 v without any problems but when it gets below 4.98 v like 4.97 or 4.96 it can cause many kind of errors.

    Over time by wear it can loose some power. Some psu have this quicker then others, it happen more on pc's that have a psu that is running close to there max output example if you have a pc that runs under stress 420 watt and in idle let say to keep it simple 250 watt and having a 500 watt psu over time you 500 watt psu is not 500 watt any more but it loses some

    Like with car engines when you buy a brand new one with 300 hp after a few years your car dont have 300 hp any more same applies for your computer psu/power supply
     
    StoneRacing likes this.
  20. StoneRacing

    StoneRacing Registered

    Joined:
    Nov 20, 2021
    Messages:
    213
    Likes Received:
    119
    In addition to what GP_NUTS said, I like to remind that most power supplies run stable at 80% load (some at 60% only) - so if we need 800 watts stable we should run a 1kW power supply or even more.

    5 volts is a typical "digital" voltage - so voltage differences on this rail cause problems and errors most of the time (in former times 12 volts were used for HDD motors e.g. which were not that sensible).

    Having white pixels e.g. on the screen and a freeze seconds after they occur it is very likely a GPU RAM defect. Freezing without white pixels but with FFB and sound still running it may be because of PSU and / or temperatures ... keep in mind that most temperatures are taken off the surface and not the center or the GPU or CPU or whatever (I am watching temps from time to time and I have my 3080 running at around 75°C with 95 to 99% load during rF2). Also the cooling lubricant (if used) will disappear over time (years) and needs to be applied again.

    I remember that I was running my Pentium 166MMX (yes, I am that old) at 200 MHz when being on LAN events - and I had a proper cooling for it. One day I was going to such a event by car and did not notice that the cooler lift off the CPU during driving ... after around 30 to 45 minutes of playing at the event my PC started to smell ... and as I opened the chassis there was already smoke - luckily the CPU still worked and I could play on, but I was warned and checked the cooler furthermore in the future for proper fitting.

    So if it comes to temps you may be able to play / run your game for a certain amount of time before problems occur.
     
    GP_NUTS likes this.

Share This Page