IBLCARTYRE

Discussion in 'Car Modding' started by Chris Lesperance, Dec 21, 2020.

  1. Chris Lesperance

    Chris Lesperance Registered

    Joined:
    Nov 29, 2012
    Messages:
    1,071
    Likes Received:
    1,315
    Question. Is this shader fully implemented?

    I can get screenshots later today. From what I can see, the shader doesn't take into affect the animation textures. It will not work if you have set up multiple tread textures (wet tires for example)

    Just wondering if I'm missing something or if it is something that isn't fully implemented yet.
     
  2. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    440
    Likes Received:
    401
    Code bug, will be fixed in next build
     
    Chris Lesperance likes this.
  3. Dirtnz

    Dirtnz Registered

    Joined:
    Mar 9, 2014
    Messages:
    16
    Likes Received:
    9
    There is a way I found that works but it requires some manual manipulation and entries into the json file for each corresponding texture.

    For my wheels I have the base texture then 2 motion textures so i've had to change these lines in each section manually, the first albedo map and normal map sections and it seems to work fine.

    "Flags" : [ "CUBETF_AUTOMIPMAP", "CUBETF_TRILINEAR", "CUBETF_OWNEDBYMATERIAL" ],
    "FrameCount" : 3,
    "Rate" : 1,
    "Sequence" : [ 0, 1, 2 ],
    "SkipFrame0" : false,

    It's a little bit of mucking around but it works at least in the mean time.
     
  4. Alex Sawczuk

    Alex Sawczuk Registered Staff Member

    Joined:
    Oct 4, 2010
    Messages:
    440
    Likes Received:
    401
    Should have been fixed in the build that was released on Tuesday. It's more likely that made it work.
     
  5. Dirtnz

    Dirtnz Registered

    Joined:
    Mar 9, 2014
    Messages:
    16
    Likes Received:
    9
    My technique above has worked for at least the last two months while your build was clearly broken but OK it was your update on Tuesday that made it work o_O
     
    TheGame316 likes this.
  6. Chris Lesperance

    Chris Lesperance Registered

    Joined:
    Nov 29, 2012
    Messages:
    1,071
    Likes Received:
    1,315
    I'll have to check out doing it manually. I just redid the one I was working on and it still wasn't changing for me.

    I should have looked directly in the json just to see if those types of values were there
     

Share This Page