Huge Frame drops in VR (Purple lag spikes) - unplayable on each setting with the Reverb G2 / 3080

Discussion in 'Bug Reports' started by TurboHenk, Jul 16, 2021.

  1. regged

    regged Registered

    Joined:
    May 25, 2012
    Messages:
    35
    Likes Received:
    11
    I don't think it has been mentioned here but some people have found locking the GPU frequency using MSI afterburner helps, may be worth a test if nothing else.
    The following youtube link is a 2 minute video about crypto mining but it details how to lock the frequency of your card using MSI afterburner.
     
  2. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,515
    Likes Received:
    3,187
    rF2 is at least tangentially tied to Steam/Valve which means the Index 'should' be the focus. MG probably hopes to transfer one or more of the upcoming titles to consoles, which means AMD graphics. It may be not that they don't care, just they can't afford to chase a rabbit down the hole when all of it's future seems tied to other bits of hardware. Now with the new hiring spurt, we MAY see more resources allocated to figuring out this issue, they MAY also work on correcting the Fanatec FFB Fade problem or any number of other hardware issues.(even though the next round of Virtual events are co-sponsored by Thrustmaster....sooooo....who knows how much focus the put on fixing the fade thing as well as VR)
     
    atomed likes this.
  3. TurboHenk

    TurboHenk Registered

    Joined:
    Jul 8, 2021
    Messages:
    35
    Likes Received:
    18
    Great suggestion. Thanks, much appreciated but I tried this already too.. Didn't make a difference...
     
  4. Koni Blank

    Koni Blank Registered

    Joined:
    Sep 21, 2021
    Messages:
    3
    Likes Received:
    0
    Hi, same here! I/ 10850K, 3090, 32GB DDr and Reverb G2!
    I figured out that u have to be in your Playspace (Chaperone) and i set Audio to 16 Sounds and Windows Standard *or choosen i'm not 100% sure.
    Now i can race with only a few very short droopes! MY GPU load was and is only @ 50 - 60% but now without 300 droppes per minute! :) I hope i could help!
     
  5. Hank Madison

    Hank Madison Registered

    Joined:
    Jun 28, 2021
    Messages:
    18
    Likes Received:
    3
    Glad to hear it’s working well for you. I’m struggling to understand this clearly. Is there a video or other documentation showing how to make these adjustments? Thanks
     
  6. TurboHenk

    TurboHenk Registered

    Joined:
    Jul 8, 2021
    Messages:
    35
    Likes Received:
    18
    I like to know too, I don't understand this. Please explain it better, thanks in advance !
    Update: I bought an 3080TI and it makes ZERO difference.
     
  7. Hank Madison

    Hank Madison Registered

    Joined:
    Jun 28, 2021
    Messages:
    18
    Likes Received:
    3
    FWIW, I've had some success with my 3080/G2 setup using the RF2 Graphics Setup Wizard available on Github. The "VR Medium Sharp" setting looks good. But the big difference came from using only 6 AI cars. I've only been testing at Sebring with GTE cars so this may vary track to track, car class to car class. I can run short single player races with 6 AI and there are no pink spikes.

    And then for sometimes -- for whatever reason -- it'll start delivering the pink spikes again. If I do a restart, it seems to be fine again. My sense after reading about this elsewhere is that this is a CPU bottleneck. I'm sure others can speak to this better than I can.

    That said, I'm not a big enough RF2 fan to tolerate much of this so I've spent more time driving other sims.
     
  8. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    828
    Likes Received:
    522
    From my tinkering, the game for one reason or another causes a CPU bottleneck on the RTX30XX when running SteamVR/WMR software. I even went out and purchased different RAM sticks with higher frequency and lower CAS timings to rule out my RAM causing the issue in-game.

    I'm not clued up on the technicalities of game developemnt, but simply put, I believe that the problem is how Nvidia drivers interact with rF2 for WMR headsets. They seem to be throttling the CPU usuage in-game which in turn throttles the RTX30XX usage. I get between 40-60% usuage on my card in rF2 compared to 93%+ on AMS2, AC, ACC, & R3E.

    The fact that you say 6AI solves the issue again lends support for this & furthermore, you can adjust graphic settings with 19+AI and have very little effect on fps/frametime spikes.

    That's my theory anyway.

    I would just like it fixed. But I think first step of fixing something is acknowledging there is an issue, which I don't think there has been as yet, so I'm not holding my breath for either Nvidia or S397 to come up with a magical solution. One day I may boot Steam and SteamVR or WMR gets updated and suddenly find everything is working perefctly. Who knows what elements are at fault but right now, sadly, rF2 is broken for me.
     
    Last edited: Oct 2, 2021
    Hank Madison likes this.
  9. TurboHenk

    TurboHenk Registered

    Joined:
    Jul 8, 2021
    Messages:
    35
    Likes Received:
    18
    Spot on! That's exactly what it does here too. But when you try LeMans or for example Watkins Glen the lag spikes are (almost) always terrible, counting hundereds in a few laps, unplayable. Even with 6AI cards only and superlow settings. But with sunnny 2pm/Sebring/6AI cars it sometimes works flawless indeed. But this is one of the only scenario's that actually works (I tried many...).

    "That said, I'm not a big enough RF2 fan to tolerate much of this so I've spent more time driving other sims."
    I'm a big fan of rf2 but it's simply unplayable like this, and the most sad of all is: there is still zero feedback from Studio 397 about this subject.

    @Magus maybe so... I also tried other ram modules and also to turn XMP off etc. I even switched from the 3080 to the 3080TI (from different brand) and I bought an other motherboard. This all made zero difference. A good developer can fix the issue for 100% sure since it's not happening in ACC/AC/AMS2 etc. but then they must want to do the effort to fix it! And that last thing is the problem here, nobody from Studio 397 tells us that they are working on this major bug, they keep releasing new content but this is all unusable for us since we simply cannot play the game...
     
    Hank Madison and Hazi like this.
  10. Stefan_L_01

    Stefan_L_01 Registered

    Joined:
    Nov 18, 2012
    Messages:
    595
    Likes Received:
    383
    You guys run windows on high Performance as energy profile?
    If not, low load might window cause to throttle down your cpu while gaming.
     
  11. Hank Madison

    Hank Madison Registered

    Joined:
    Jun 28, 2021
    Messages:
    18
    Likes Received:
    3
    Yes. My rig is running High Performance in the energy profile.
     
  12. TurboHenk

    TurboHenk Registered

    Joined:
    Jul 8, 2021
    Messages:
    35
    Likes Received:
    18
    Thanks for your reply.

    Yes but it makes zero difference. Even with the GPU and CPU load both below 50%; the framedrops keep coming in enormous amounts.
     
  13. Vranq

    Vranq Registered

    Joined:
    Feb 8, 2017
    Messages:
    9
    Likes Received:
    9
    I noticed that in VR (Medion Erazer WMR headset) my FPS are stable at 90 FPS right in the moment when I begin moving the mouse or hit keys fast on my keyboard. This affects not only VR. With monitor I have constant 75 FPS without moving the mouse and constant (fixed) 140 FPS when moving the mouse. I am curious if someone with performance issues can reproduce my findings.
    I have already made a thread for this problem: https://forum.studio-397.com/index.php?threads/vr-90-fps-constant-as-soon-as-mouse-is-moved.70589/
    (My PC: AMD Ryzen 7 5800X, ARCTIC Liquid Freezer II 280 , MSI X570-A PRO AMD X570,16GB G.Skill RipJaws V DDR4-3600 DIMM CL16, Powercolor RX 6900XT, Bitfenix Whisper Series 850 W, Windows 10 Pro)
     
  14. RJVan

    RJVan Registered

    Joined:
    Sep 2, 2021
    Messages:
    3
    Likes Received:
    0
    I'm not sure why this helped, because I'm sure I've tried this in the past, but I set the "Current OpenXR Runtime" to SteamVR in the developer tab of SteamVR and it has greatly improved my situation. I'm running a G2 on a 3080. Before, I would get one or two clean laps in practice, then the purple spikes would start. 100's of dropped frames per lap by myself. (no traffic) This was very evident at Monza and Nuburgring.

    Now practice runs smooth with 1 or 2 dropped frames per lap and races are much better. I'll get a few dropped frames at the start until the field stretches out, then maybe 1 or 2 per lap after. I can actually play the game in VR now, so I'll take it. At least now it makes sense when the drop frames happen, because there are lots of cars around.
     
  15. RJVan

    RJVan Registered

    Joined:
    Sep 2, 2021
    Messages:
    3
    Likes Received:
    0
    Well, the stuttering is back. I give up. I've spent way too much time trying to figure this out.
     
  16. DJChrizz

    DJChrizz Registered

    Joined:
    Aug 18, 2017
    Messages:
    61
    Likes Received:
    15
    https://www.igorslab.de/community/t...rtx-karten-framedrops-in-vr.5602/page-2#posts
    Yes big problem in rFactor 2 too :-/

    Yesterday I tryed the new nvidia driver 497.09, works well and quick but .. purple spikes and not away but :
    I drove rFactor2 alone ... 2 peoples on a server GT3 Canada. smooth. No problem. I addes 5 KI - Driver and I got to many spikes and this is not really playabler. Remove the KI driver and all good. I don't know why the driving with some more players or KI-drivers make this big purple spike problems :-(
     
  17. fasttuning

    fasttuning Registered

    Joined:
    Dec 15, 2019
    Messages:
    31
    Likes Received:
    12
    RX6900XT
    ryzen5600x

    Huge FPS drop with another cars on track. I have tested very accurate how much FPS drop with +1 car if I look at this car = 10FPS drop. Impossible to drive in online races , especially in eSports events. Absolutely all settings is set to "Low"

    Also anisotropic filtering must be updated too. 16x is not enough. Anti Aliasing is bad option for vr
     
  18. Craig Waddell

    Craig Waddell Registered

    Joined:
    Oct 20, 2020
    Messages:
    76
    Likes Received:
    40
    Has anyone made progress with this?

    I've a 3080 and Ryzen 5800x with a Reverb G2. Purple spikes galore!

    I've noticed that I get slightly better performance when doing online races which doesn't make any sense.

    Come on S397, join in the thread and help your loyal customers.
     
  19. PhilT

    PhilT Registered

    Joined:
    Jan 5, 2021
    Messages:
    29
    Likes Received:
    6
    I'd get on Discord in the VR channel. We've currently all ditched Steam VR and are using OpenXR with Jabbha's amazing OpenComposite ACC library. He's actively developing it and for the Reverb G2 it's pretty simple to setup. Install the OpenXR toolkit and grab OpenComposite from the link below and copy it into your rFactor2/bin64 folder (make backups of the files that will get overwritten).

    https://mbucchia.github.io/OpenXR-Toolkit/
    https://gitlab.com/Jabbah/open-composite-acc/-/releases

    Basically it gets rid of an extra layer of API calls and not only speeds everything up but the degradation you get from low FPS is now so much more gradual. Just try it. It's night and day difference.

    The reason you're seeing better performance when online is your PC isn't having to calculate all the AI drivers. Online races are always going to be better performance-wise than running AI.
     
  20. Craig Waddell

    Craig Waddell Registered

    Joined:
    Oct 20, 2020
    Messages:
    76
    Likes Received:
    40
    Fantastic Phil and thanks for the swift reply. I use that for FS2020 but had no idea that it was usable with RF2. Looking forward to the results ☺️
     
    PhilT likes this.

Share This Page