Hud Editor resolution 1280x960

Discussion in 'User Interface and HUD Modding' started by Antonio_MHO, Sep 28, 2013.

  1. Antonio_MHO

    Antonio_MHO Registered

    Joined:
    Oct 14, 2010
    Messages:
    13
    Likes Received:
    0
    Hey guys, I'm trying to create a Hud but I can not set 1280x960 resolution. Watching the capture to see my available resolutions.

    View attachment 10084

    How to force a resolution in config.ini or another file? I have tested but without result.

    ISI? Can unlock this in future versions?

    Thank you!


    Sorry for my bad english.
     
  2. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,989
    Likes Received:
    4,123
    A quick google suggests there might be a registry hack to add a custom resolution to windows (which devmode will then pick up), or if you go through your display settings you may be able to add a custom resolution. I'm on nVidia myself so I can't guide you through it.

    I have that required resolution already, but I added 1920x960 as a custom resolution through my nVidia settings and was then able to select it in devmode (windowed mode ON).

    If you run your screen in a higher resolution (1680x1050 I guess?) you should be able to make devmode run in windowed mode at 1280x960 as long as you can make your video card believe it's a possible resolution.

    Warning: I guess there's a chance you might break something by trying a custom resolution. I didn't, but if you do I'm afraid I can't help :)
     
  3. MJP

    MJP Registered

    Joined:
    Oct 5, 2010
    Messages:
    988
    Likes Received:
    20
    Have you tried adding 1280x960 to the CustomVidRes= line in the ModDev config.ini file?
     
  4. lordpantsington

    lordpantsington Registered

    Joined:
    Oct 5, 2010
    Messages:
    834
    Likes Received:
    66
    Change this in your HUD ini:
    To:
    or whatever your resolution is.
     
  5. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    8,989
    Likes Received:
    4,123
    Sounds like the OP already tried that, and I tried setting a new resolution that way but nothing appeared in rF2.

    If he uses a resolution with the same aspect ratio for setting out the HUD, rF2 will then scale that to all others without issue?
     
  6. lordpantsington

    lordpantsington Registered

    Joined:
    Oct 5, 2010
    Messages:
    834
    Likes Received:
    66
    From what I remember (it's been a while):
    If he uses a 4:3 AR for the HUD as default, it will skew at a 16:10 resolution. If he sets the HUD default @ 16:10, the only way it doesn't skew is on a 16:10 monitor.
     
  7. Antonio_MHO

    Antonio_MHO Registered

    Joined:
    Oct 14, 2010
    Messages:
    13
    Likes Received:
    0
    Yes but dont work.


    I don't find these lines in the ini file HUD, and I don't find hud generic ini file.

    I think it's related to DevMode, but I do not know where to look.


    Thanks!
     
  8. lordpantsington

    lordpantsington Registered

    Joined:
    Oct 5, 2010
    Messages:
    834
    Likes Received:
    66
    Devmode HUD should be located in *\My Documents\rFactor2\ModDev\HUD. Just copy/rename one of the existing to get started. If there aren't any there by default, grab a mas out of the core (*:\Program Files\rFactor2\Core\HUD) and extract all the files from the mas, then rename it to what you need it to be. If the ini you are working on is missing the references, add it after the FONT section.
     
  9. Antonio_MHO

    Antonio_MHO Registered

    Joined:
    Oct 14, 2010
    Messages:
    13
    Likes Received:
    0
    Thank you very much. I've been able to work. I added the lines in the .Ini Hud file.

    View attachment 10104
     

Share This Page