How to Enable or Disable "Receive Shadows" for IBL shader?

Discussion in 'Track Modding' started by svictor, Dec 10, 2021.

  1. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    977
    Likes Received:
    6,609
    According to official IBL Standard Shader definition, there is a "Receive Shadows" option (under General Configuration) in material editor which can be Enable or Disable:
    [​IMG]
    https://docs.studio-397.com/develop...a-guide-in-rfactor2/pbr-using-standard-shader

    But this option is not presented in current version of material editor. I'd like to know if there is a way to set this option to disable.

    So far I have found a few json files that contains "RECEIVESHADOWS":"@Null", line, tried to add it to json but does not work.

    It would be great help if it can be done. Thanks!
     
    philrob and DJCruicky like this.
  2. Jka

    Jka Member Staff Member

    Joined:
    Jan 31, 2011
    Messages:
    954
    Likes Received:
    213
    Looks like that screenshot is from older version of the standard shader.
    The latest version does not have that option.
    upload_2021-12-11_21-9-5.png

    The latest got retroreflector, which was not available from old shader etc.

    Btw, why you want to turn off receiving shadows from object..?
     
    Last edited: Dec 11, 2021
  3. svictor

    svictor Registered

    Joined:
    Jan 20, 2019
    Messages:
    977
    Likes Received:
    6,609
    Thanks. It will be useful for objects like 2d tree to avoid a harsh shadow line running across the texture surface, something similar to the old "T1 no shadow" shader.
     

Share This Page