HOW TO: Creating a RaceEvent with Paid Content

Discussion in 'Hosting Help' started by Christopher Elliott, Aug 1, 2017.

  1. Denis Mitchell

    Denis Mitchell Registered

    Joined:
    Aug 5, 2017
    Messages:
    13
    Likes Received:
    0
    Found another thread you mention it but can not find the solution.
    I presume when i bought it, it puts the file somewhere that possibly the server is not seeing?
     
  2. Denis Mitchell

    Denis Mitchell Registered

    Joined:
    Aug 5, 2017
    Messages:
    13
    Likes Received:
    0
    Ok i did a search and find the ServerKeys.bin file under userdata in the root of the rFactor 2 folder if that helps!
     
  3. Denis Mitchell

    Denis Mitchell Registered

    Joined:
    Aug 5, 2017
    Messages:
    13
    Likes Received:
    0
    What is the ServerKeys.bin file, i presume paid content licences?

    Surely if I am able to join other servers it is seeing my licence then just my server does not see it?
    Would moving the bin file to a different location not help this issue?
     
  4. Denis Mitchell

    Denis Mitchell Registered

    Joined:
    Aug 5, 2017
    Messages:
    13
    Likes Received:
    0
    Sorted out, had to run game in single player first, found that in another thread!

    Thanks very much for all your efforts Christopher, hopefully this helps others too.
    Remember a server with paid content needs the single player run first!!

    have a great weekend, my server is up wohoo!!!
     
  5. Christopher Elliott

    Christopher Elliott Administrator Staff Member

    Joined:
    Jul 31, 2014
    Messages:
    4,295
    Likes Received:
    6,297
    Great glad you got it working :)
     
  6. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Most servers don't use paid license to host a server, so running single player to make a server work with McLaren is not an option for most.
     
    Clemenca and GrimDad like this.
  7. Gupster

    Gupster Registered

    Joined:
    May 19, 2013
    Messages:
    404
    Likes Received:
    25
    if you want to run this mod in a dedicated server you must copy these files from your main rf2 userdata folder:

    ServerKeys.bin
    ServerUnlock.bin

    copy to your dedicated userdata folder.. mine is rfactor2-dedicated\UserData

    then run mod manager again and install the proper version of the mod. then go to mas tool and create mod for your server.

    hope this helps
    Thanks to Kris Cobb for pointing me in the right direction!
     
  8. GOLFGTiman

    GOLFGTiman Registered

    Joined:
    Sep 21, 2017
    Messages:
    9
    Likes Received:
    1
    ALGUIEN ME PUEDE AYUDAR?ESTOY INTENTANDO CREAR UN SERVIDOR DESDE EL LAUNCHER DE RFACTOR 2 DE STEAM Y CUANDO LO CREO NO APARECE EN EL LISTADO DE MULTIJUDAR,ME ESTOY VOLVIENDO MAJARA
     
  9. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Estás intentando usar el McLaren o es con otro mod?
     
  10. GOLFGTiman

    GOLFGTiman Registered

    Joined:
    Sep 21, 2017
    Messages:
    9
    Likes Received:
    1
    LO SIENTO,SE QUE HABLAIS DEL MCCLAREN DE PAGO,ERA POR CONOCER A GENTE HA VER SI ME PUEDE AYUDAR. CON CUALQUIER MOD INCLUSO DEL PROPIO STUDIO 397 O IS,CREO UN SERVIDOR DEDICADO Y ESTE NO APARECE EN EL LIISTADO DE MULTIJUGADOR,A MI AMIGO LE PASA IGUAL CUANDO CREA NO APARECE.ALGUIEN ME PUEDE AYUDAR,GRACIAS
     
  11. MAURO EKERMANN

    MAURO EKERMANN Registered

    Joined:
    Dec 21, 2017
    Messages:
    6
    Likes Received:
    0
    Why does not my dedicated server list the Launcher?
    Others can see ... but I do no.
    The event I created is running normal ...

    [​IMG]
     
  12. ebeninca

    ebeninca Registered

    Joined:
    Sep 7, 2016
    Messages:
    460
    Likes Received:
    178
    You have to change the combobox option to LAN on server list. If not...

    You're running the server on the same machine you're playing?

    There's some kind of problem with rF2 when you do this way. You will need to put the server in another machine, or create a sub network in your machine.
     
  13. MAURO EKERMANN

    MAURO EKERMANN Registered

    Joined:
    Dec 21, 2017
    Messages:
    6
    Likes Received:
    0

    Completely without logic.
    The purpose of the dedicated server is that I can play online with my friends, correct?
    For this I have to have two machines?
    I know some players who are abandoning RF2 because of these problems ...
    Can you help me solve it?
    Even putting in LAN, does not list my server, but other players are seeing in the Launcher list ...
     
    Last edited: Feb 23, 2018
  14. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    748
    Likes Received:
    496
    Ok, for a lan server to show in the steam matchmaker, ports have to be in the range of 27013 to 27018. Firstly make sure the server is not running, then in windows explorer open your multiplayer.json file(...Steam/steamapps/common/rFactor 2/userdata/player) and look for a line that's start with "http port", change the number to 27013. The other port line in the multiplayer.json file is the line starting with "simulation port".... Default for this is 54297....you can leave that as it is.
    On your router port forward TCP 27013, TCP/UDP 54297, UDP 27014 and UDP 27015 to the IP address of your hosting computer ( should be something along the lines of 192.168. etc.) Save your edits, then fire up your server and on your client under the lan tab you should be able to see your server.

    Sources for my info;
    https://forum.studio-397.com/index....-within-the-same-lan.52213/page-2#post-853397

    https://steamcommunity.com/app/365960/discussions/0/144512526679372857/
     
    Last edited: Feb 24, 2018
  15. MAURO EKERMANN

    MAURO EKERMANN Registered

    Joined:
    Dec 21, 2017
    Messages:
    6
    Likes Received:
    0
    Show !!!

    Thank you very much Goanna !!!
    After almost 60 days, I now see my dedicated server on the launcher.
    But...
    All who enter, are knocked down, and it is not by bad connection, the ping is between 60ms and 120ms.
    What could be causing this?

     
  16. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    748
    Likes Received:
    496
    Can you expand a little on knocked down....I'm assuming that it means they can see the server but cannot join, if that is the case do you know what error message/s they are receiving? In the meantime one thing to check is the firewall on the hosting machine...I would delete any rules for rFactor 2 and then fire up the server and it should ask to allow internet access.
     
  17. MAURO EKERMANN

    MAURO EKERMANN Registered

    Joined:
    Dec 21, 2017
    Messages:
    6
    Likes Received:
    0
    Hi Goanna

    There are no error messages.
    They enter the server and are dropped
    Connection lost
    I disabled the firewall and anti virus
    Now it's running normal !!!
    Thanks for your help
     
  18. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    748
    Likes Received:
    496
    No problems, glad you got it sorted
     
  19. joekart

    joekart Registered

    Joined:
    Dec 24, 2011
    Messages:
    55
    Likes Received:
    33
    Hello,
    I have a problem with hosting the Kartsim mod on our dedicated server.
    I did the same procedure as for the paid mod gt3 that works.
    I launched the offline game, copied the ServerKeys.bin and ServerUnlock.bin files and pasted them into the server's userdata folder. In modmanager, i can see all the kartsim items installed.
    When I create the mod, I can not see the karts, everything is empty but no problem for the tracks.
    I can still create the game, but when we enter the server, obviously, we can not choose our kart.
    With a friend, we tried everything, repeated the procedure many times and nothing changes.
    Would you have an idea to get us out of this problem please?
    Thank you
     
    Last edited: Apr 8, 2018
  20. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    748
    Likes Received:
    496
    You will need to run the dedi server up to the last screen ie to the load track screen (no need to click the load track button though) then exit, then copy the serverkeys.bin file from your dedi server to your local install and run Single Player, then copy the bin files back to your Dedi server.... you should then be able to install karts and tracks via the modmanager and create your vmod.
     

Share This Page