Help!!

Discussion in 'Technical & Support' started by Art_Pereira, Jul 8, 2021.

  1. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Hi :)

    Everything was working ok with rF2 till yesterday. I tried to launch it from Steam and after I clicked on the "Play" key, it seemed to launch but after 5s or so the green "PLAY" Steam key was shown again and nothing happened. I tried several times with several versions, the original (BETAS set to None) and all the other betas with the same result. The only way I could launch rF2 was with the original UI :(

    I uninstalled rF2 and get it installed early today, but things didn´t improve and rF2 refuses to launch with the new UI, no matter the version.

    Any help will be welcome!!
     
  2. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,849
    Likes Received:
    1,829
    Move your ..\rfactor 2\Userdata folder to another place (to have a backup) and launch rF2
     
    Art_Pereira likes this.
  3. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Thank you! I will do that and will be back on this later!
     
  4. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    No luck. After reinstalling rF2, I can only launch it with the old UI. Not one of the new UI versions work :(

    I tried with the command "+trace=3" but nothing happens and the trace file is not created.
     
  5. lagg

    lagg Registered

    Joined:
    Oct 1, 2012
    Messages:
    2,849
    Likes Received:
    1,829
    Try verifying the integrity of the files of rF2 in Steam and install all the runtimes included in ..\rFactor 2\support\runtimes
    I understand that you haven't put your Userdata folder in the rF2 path again
     
    Art_Pereira likes this.
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,606
    Likes Received:
    3,251
    Un-installing via steam does wipe the rf2 folder clean. make sure you either delete or rename the player folder. back up your controller profiles first
     
    Art_Pereira likes this.
  7. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Yes, I verified the integrity of the rF2 files and they were ok. And no, I haven´t put the old Userdate files into the rF2 path again.

    No change. rF2 only runs ok with the old UI version.
     
  8. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    I have just uninstalled rF2 and Stem, and cleaned the Windows 10 register from all references to Steam and rF2. I have installed Steam again and it is installing rF2 again. I have that backup. I am using the latest Nvidia drivers and Windows 10 is up to date.
    Fingers crossed.
     
  9. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,606
    Likes Received:
    3,251
    sorry, I just saw I made a typo, DOESN'T was the word I was trying for. Hope it works for you. rF2 is often persnickity, but the solutions are usually rather simple.
     
    Art_Pereira likes this.
  10. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    No problem. Thank you very much anyway. I am still waiting rF2 is installed again.
     
  11. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    No luck. rF2 still doesn´t work with the new UI, no matter the version (original (no betas), previous release, candidate release). It only works with the old UI.
     
  12. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
  13. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,606
    Likes Received:
    3,251
    What kind of equipment are you using? Laptop? vidcard & Video Memory? CPU? What version of Windows? Are you starting via Steam? How many USB controllers do you have connected? Wheel, pedals, button boxes, etc.
    You are a long time user, so I think we just all assumed you had the hardware figured out. Guess we'd better ask, if for nothing else, than to rule hardware issues out.
     
  14. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Desktop PC
    Videocard: Nvidia GeForce GTX 1660 SUPER
    Dedicated video memory: 6144 MB GDDR6
    Graphics driver_ Nvidia original v471.11
    Processor Intel(R) Core(TM) i7-4790 CPU @ 3.60GHz 3.60 GHz
    Installed RAM 4,00 GB (3,88 GB usable)
    System type Windows 10 Pro 64-bit operating system, x64-based processor
    Pen and touch No pen or touch input is available for this display
    rFactor2 64bit started through Steam
    When using rFactor2, I have 3 devices connected to USB: keyboard, mouse and Logitech 920 wheel (Logitech pedals are connected to the wheelbase)

    Today I reinstalled the Nvidia drivers thinking they could have been corrupted somewhere, and also reinstalled rFactor2. Same result. rF2 only works with the old UI.
    When using the standard version with the new UI, the previous release and also the current release candidate, I used the +trace=2 or 3, don´t remember now which one, but after I click on PLAY rF2 don´t launch and it goes back to the green PLAY button from Steam after about 4 or 5 seconds. When I launched rF2 with the old UI, rF2 creates the trace txt file without problems. I checked that file but couldn´t find anything unusual at the start that seems when the problem is located: rfactor2.exe is not launched at all I think, and the problem seems to be with the new UI I guess. When launch rF2 with the old UI, the new logo with the white background is shown before I can access to the rF2 menus.
    I thought to reinstall Windows 10, but that will demand me to also reinstall all the software I use to work (Office 2019 64 bit, Photoshop 2021, Adobe Acrobat DC, all the carsims (GPL, rF1 and rF2, Assetto Corsa and Assetto Corsa Competizione, etc.) plus iTunes, all the drivers for graphics, wheel/pedals, etc... a pain there I am afraid. Last time I did it, it took me 3 days to do this.

    Thank you very much for your help, Dave!! I really appreciate it!! :)
     

    Attached Files:

  15. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Btw, the monitor I use is connected to the video card with a HDMI cable and the printer is connected to my PC through the WiFi modem, so no cable for it. I use Logitech Pro headphones but they are connected with a double jack connector, not a USB.
     
  16. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    And yes, I´ve been using PCs since IBM launched the IBM PC-XT in 1985. Good old days :D
     
    atomed likes this.
  17. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    5,606
    Likes Received:
    3,251
    Installed RAM 4,00 GB (3,88 GB usable) Is that your total system ram? If so, there is your problem. I'm betting 8 would barely suffice.
     
    Art_Pereira likes this.
  18. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    I will add 8 more in a couple of weeks. Can´t stop using this PC before that because of work. However, rF2 has been working perfectly well since it was released and till the current release candidate.
    Oh well, we´ll see if that helps. Thank you very much Dave!
     
  19. BobbyD

    BobbyD Registered

    Joined:
    Jul 26, 2021
    Messages:
    4
    Likes Received:
    1
    I am having the same problem which seems to coincide with the newest updates. The game will not launch. I've verified the integrity of files, repaired my Steam library files and the game will not launch. Windows task manager states that the program is not responding. My other Steam games work fine.
     
    Art_Pereira likes this.
  20. Art_Pereira

    Art_Pereira Registered

    Joined:
    Oct 13, 2010
    Messages:
    159
    Likes Received:
    170
    Hi :)
    How much RAM do you have installed in your PC?
     

Share This Page